Jump to content

    
Sign in to follow this  
likeasm

Отваливается ila и dbg_hub

Recommended Posts

Доброе утро! Работаю на Vivado 19.1 с xilinx ku115. Использую несколько ila для отладки проекта. После прошивки проекта не определяются анализаторы. Раскопал, что dbg_hub у меня цепляется к clock'у 250Mhz от внешней PLL, данный clock при старте ПЛИС отсутствует. При подачи clock'а и выполнения команды Refresh Device, анализаторы не всегда определяются. Также вылетает ошибка [Labtools 27-3428] Ila core [hw_ila_4] clock has stopped. Unable to arm ILA core. Лечится реконфигурацией ПЛИС. Есть ли способ оживить или перегрузить анализаторы менее радикальным способом?

 

Share this post


Link to post
Share on other sites

Если проблема только в dbg_hub, его можно явными констрейнами переключить на другой клок. Если ILA должен работать от внешнего клока - то мириться с тем, что он порой будет отваливаться. Когда совсем достанет - перевести ILA на внутренний клок и поставить фифо-буфер для передачи данных от внешнего тактового домена.

Share this post


Link to post
Share on other sites

Спасибо! Дело не только в dbg_hub, сам ila тоже отваливается. На другой клок не получится, принимаю данные от АЦП через GTH, а дальше на JESD. Мыль про fifo проскакивала, но мне казалось, что должен быть механизм перезапуска ila из vivado. Буду городить фифо.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this