Jump to content

    

Проблемы с запуском второго instance Xpedition

С некоторых пор начал наблюдать непонятную проблему с запуском Xpedition. Во-первых, появились приличные тормоза с запуском топологии платы. И чем сложнее проект, тем дольше приходится ждать. Если 3D вкладка открыта, вообще c запуском вешаться можно. Во-вторых, появились проблемы с  запуском второй сущности Xpedition. Т.е., если открыть одну плату(в рамках одного проекта) в одном окне Xpedition, то при попытке открыть после вторую плату(в рамках другого проекта) в другом окне, практически всегда открытие начинается с появления окна о невозможности открытия еще одной сущности Xpedition. Потом как повезет - может открыться а может и не открыться. Тоже самое случается, если открывать какой-либо иной САПР(например - Автокад) и потом Xpedition. VX2.4. Core I7 7-го поколения, памяти 32Г, SSD. Смотрел в диспетчере задач загрузку системы, ничего крамольного не увидел, загрузка CPU процентов на 30-40, память используется процентов на 25, GPU на 3-5 процентов. Кто может подсказать что дельное по проблеме, кроме выключения антивируса?

1 (2).JPG

Share this post


Link to post
Share on other sites
23 minutes ago, keln said:

С некоторых пор начал наблюдать непонятную проблему с запуском Xpedition. Во-первых, появились приличные тормоза с запуском топологии платы. И чем сложнее проект, тем дольше приходится ждать. Если 3D вкладка открыта, вообще c запуском вешаться можно. Во-вторых, появились проблемы с  запуском второй сущности Xpedition. Т.е., если открыть одну плату(в рамках одного проекта) в одном окне Xpedition, то при попытке открыть после вторую плату(в рамках другого проекта) в другом окне, практически всегда открытие начинается с появления окна о невозможности открытия еще одной сущности Xpedition. Потом как повезет - может открыться а может и не открыться. Тоже самое случается, если открывать какой-либо иной САПР(например - Автокад) и потом Xpedition. VX2.4. Core I7 7-го поколения, памяти 32Г, SSD. Смотрел в диспетчере задач загрузку системы, ничего крамольного не увидел, загрузка CPU процентов на 30-40, память используется процентов на 25, GPU на 3-5 процентов. Кто может подсказать что дельное по проблеме, кроме выключения антивируса?

1 (2).JPG

Вы используете сетевую лицензию? Долгое открытие Layout или DxD может быть связано с тем что клиент пытается обратиться к серверу за наличием свободной лицензии и если например в MGLS_LICENSE_FILE или в LM_LICENSE_FILE указано несколько путей по которым система обращается для поиска доступных лицензии, то сканирование происходит слева направо, таким образом если он пытается обратиться по неправильному или несуществующему пути/адресу, то может происходить очень сильное замедление запуска приложений.

А лицензии потребляются следующим образом 1 проект = 1 лицензия, соответственно если вы параллельно хотите открыть несколько проектов вам нужно по лицензии на каждый проект.

Есть еще один трюк:

Установите переменную окружения MGC_DISABLE_PRESPLASH_CHECKS=1 (или любое ненулевое значение). Это позволяет обойти большинство первоначальных проверок лицензирования и немедленно отобразить диалоговое окно заставки. Обратите внимание, что при этом все опции будут доступны для выбора, и если что-то выбрано, для чего у вас нет лицензии , вы получите ошибку лицензии, когда вы попытаетесь продолжить. Прежде чем использовать этот метод, убедитесь, что вы знакомы с имеющимися у вас лицензиями и знаете с каким набором лицензии хотите запускать редактор.

Edited by philipov
add info

Share this post


Link to post
Share on other sites
4 hours ago, keln said:

СТ.е., если открыть одну плату(в рамках одного проекта) в одном окне Xpedition, то при попытке открыть после вторую плату(в рамках другого проекта) в другом окне, практически всегда открытие начинается с появления окна о невозможности открытия еще одной сущности Xpedition.

 

У меня подобное было уж не помню в каких версиях, но когда я пытался открыть локальные проекты (просто лежащие на диске). С открытием разных проектов через Design Cockpit (т.е. хранящихся на сервере и вытаскиваемых оттуда по мере надобности) проблем не возникало и не возникает -- но, понятно, само открытие ощутимо медленней, чем для локальных (пока оно с сервером свяжется и т.д. и т.п. -- тем более, что сервер в одном месте, а я -- совсем в другом).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now