Jump to content

    

проблема при запуске тестового примера отладочной платы

Имеется отладочная плата
https://www.terasic.com.tw/cgi-bin/page/archive.pl?Language=English&CategoryNo=205&No=1046&PartNo=1

На странице
https://www.terasic.com.tw/cgi-bin/page/archive.pl?Language=English&CategoryNo=205&No=1046&PartNo=4

Скачал диск
DE10-Nano CD-ROM (rev. C Hardware)

Там проект
DE10-Nano_v.1.3.7_HWrevC_SystemCD.zip\Demonstrations\SoC_FPGA\Nios_Access_DDR3

Проблема что с их sof файлом работает, с моим нет(который получаю при компиляции проекта). Заметил, что их sof файл 7276 КБ, мой файл 7275 КБ.  У меня квартус QUARTUS_VERSION "17.1.0 Standard Edition
Делал по
https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&ved=2ahUKEwicvv-8yYfmAhXMwosKHX_4DUQQFjAAegQIARAC&url=https%3A%2F%2Fwww.terasic.com.tw%2Fcgi-bin%2Fpage%2Farchive_download.pl%3FLanguage%3DEnglish%26No%3D1046%26FID%3D1c19d1d50e0ee9b21678e881004f6d81&usg=AOvVaw28MVWuh-9mygiqIj_B25S7
стр 73

Я делал через батники которые прилагаются в \de10nano_Nios_Access_DDR3\demo_batch
просто по очереди меняв на свой sof и elf
таким образом понял в чем проблема.

Что не так?

 

PS проект по требованию могу дать (хотя я просто обновил его до моей версии квартуса).

Share this post


Link to post
Share on other sites

а если sof через jtag сразу загнать (не как на стр 73 через SD), работает?

Share this post


Link to post
Share on other sites
3 hours ago, new123 said:

а если sof через jtag сразу загнать (не как на стр 73 через SD), работает?

я так делал - нет

Share this post


Link to post
Share on other sites
22 minutes ago, Maverick_ said:

я так делал - нет

если сорцы не трогали и просто собрали проект, а он не работает, сравните пины, может ошиблись в тактовом пине, намерено или нет не тот qsf выложили щас уже не разобрать)

Share this post


Link to post
Share on other sites
15 часов назад, Maverick_ сказал:

омпиляции проекта). Заметил, что их sof файл 7276 КБ, мой файл 7275 КБ.  У меня квартус QUARTUS_VERSION "17.1.0 Standard Edition
Что не так?

а камень выбираете такой, что на плате? ошиблись в букве-цифре и проект не стартует..

conf_done (led10) гаснет?

соберите и запустите простейший вариант - внешние 50Мгц поделить до 0.5Гц и вывести на светик

шаманство из ерраты попробуйте:

"Run as Nios II Hardware Fails
Description
Sometimes you cannot run a design as Nios II Hardware.
Workaround
Select Run Configurations from the Run menu, point to Apply, and click Run."

 

Share this post


Link to post
Share on other sites

проверил маркировку - правильная

распиновка - правильная

 

Share this post


Link to post
Share on other sites

Вы elf перегенерили? Может адреса поменялись в platform designer...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this