Jump to content

    
Sign in to follow this  
MaksR

ubilinux на Intel Edison

Recommended Posts

Здравствуйте!

Есть набор для разработки. Пытаюсь загрузить дистрибутив ubilinux по инструкции

Установка, вроде, проходит корректно, но возникает такая проблема, что ранее установленная система Yocto linux все равно запускается после перезагрузки (через клавишу reset на плате, например). Возможно, нужно как-то предварительно очистить flash устройства или что-то подобное... 

Подскажите, пожалуйста, что делаю неверно?

Новичок в Unix-подобных системах...

Share this post


Link to post
Share on other sites

flash.log выдает 

Спойлер

Opening DFU capable USB device...

ID 8087:0a99

Run-time device DFU version 0110

Claiming USB DFU Interface...

Setting Alternate Setting #6 ...

Determining device status: state = dfuIDLE, status = 0

dfuIDLE, continuing

DFU mode device DFU version 0110

Device returned transfer size 4096

Copying data from PC to DFU device

Download	[====================     ]  80%      4788224 bytesInvalid DFU suffix signature

A valid DFU suffix will be required in a future dfu-util release!!!

Error during download

dfu-util 0.9



Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.

Copyright 2010-2016 Tormod Volden and Stefan Schmidt

This program is Free Software and has ABSOLUTELY NO WARRANTY

Please report bugs to http://sourceforge.net/p/dfu-util/tickets/



Deducing device DFU version from functional descriptor length

Invalid DFU suffix signature

A valid DFU suffix will be required in a future dfu-util release!!!

Device has DFU interface, but has no DFU functional descriptor

No DFU capable USB device available

 

Сейчас буду разбираться

Share this post


Link to post
Share on other sites
48 минут назад, MaksR сказал:

flash.log выдает 

  Скрыть контент

 

попробуйте взять более короткий кабель или закормить плату с двух портов USB, может один порт не тянет по напряжению в процессе работы dfu-util

Share this post


Link to post
Share on other sites
14 минут назад, Jury093 сказал:

попробуйте взять более короткий кабель или закормить плату с двух портов USB, может один порт не тянет по напряжению в процессе работы dfu-util

Подключил от двух USB кабелей и все равно такая ситуация. На плате есть еще специальный разъем под питание 7-15V. Остается только найти блок питания и попробовать запитать через него)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this