Jump to content

    

нужно отредактировать символ блока на заходном листе схемы

Имею проект транслированный из EE7.9.5. Там все было просто и понятно. Здесь блок не дает себя отредактировать  и вообще как редактируемый элемент нигде не находится. Где бы на него не ткнул - ныряю в соответствующий лист схемотехники. Надо добавить пару шин и изменить пару имен шин. Снаружи на заходном листе не шина не сигнал контур блока не пробивают - пин не образуется. Шину добавил в BUS CONTENT добавил, но на листе иерархический блок не дает себя переименовать в эту шину. Что то совсем идей не осталось 

Share this post


Link to post
Share on other sites
4 hours ago, vldmr86 said:

Имею проект транслированный из EE7.9.5. Там все было просто и понятно. Здесь блок не дает себя отредактировать  и вообще как редактируемый элемент нигде не находится. Где бы на него не ткнул - ныряю в соответствующий лист схемотехники. Надо добавить пару шин и изменить пару имен шин. Снаружи на заходном листе не шина не сигнал контур блока не пробивают - пин не образуется. Шину добавил в BUS CONTENT добавил, но на листе иерархический блок не дает себя переименовать в эту шину. Что то совсем идей не осталось 

Наверное у вас символ заморожен(freeze). Разморозите   (Unfreeze) его и он должен редактироваться

BB0EB9A7-C533-4AF2-9E07-57A4CF275A06.png

Share this post


Link to post
Share on other sites

Получилось. Еще одно неудобство обозначилось. В 7.9.5 каждый сигнал на выходе из символа блока имел красный (или розовый) пятачок который четко обозначал что пин здесь и нитку цепи надо тянуть к той точке. Теперь в падсе символ пина невидим и его положение выдает только текст имени при условии что они друг напротив друга и не дай бог не по диагонали ( а точку стыковки придется рандомно искать). Символ пина можно как нибудь ручками исправить?

Share this post


Link to post
Share on other sites
1 hour ago, vldmr86 said:

Получилось. Еще одно неудобство обозначилось. В 7.9.5 каждый сигнал на выходе из символа блока имел красный (или розовый) пятачок который четко обозначал что пин здесь и нитку цепи надо тянуть к той точке. Теперь в падсе символ пина невидим и его положение выдает только текст имени при условии что они друг напротив друга и не дай бог не по диагонали ( а точку стыковки придется рандомно искать). Символ пина можно как нибудь ручками исправить?

Можно сделать в виде стрелочек обозначающих направление сигнала (in,out,bi)

Это можно сделать 2 способами:

  1. Через Setup-->Settings раздел Advanced  и там есть опция Pin Type Arrows
  2. Через Display Control (View-->Display Control)

image.thumb.png.f625bfe41945118e41b0cf834d9d2081.png

Share this post


Link to post
Share on other sites

Вопрос закрылся через PinType Arrows.

Лень новую тему создавать я здесь спрошу. Рипперы в шину выглядят не так как в экспедишине. Там было на ГОСТ похоже. В PADSе по умолчанию какие то самостийные. Как их поменять?

Share this post


Link to post
Share on other sites
20 minutes ago, vldmr86 said:

Вопрос закрылся через PinType Arrows.

Лень новую тему создавать я здесь спрошу. Рипперы в шину выглядят не так как в экспедишине. Там было на ГОСТ похоже. В PADSе по умолчанию какие то самостийные. Как их поменять?

Через setup—settings— special components и там выберите из выпадающего Списка ripper и добавьте символ он есть в библиотттеке 

Edited by philipov

Share this post


Link to post
Share on other sites

С NET RIPPERОм вопрос закрылся. После трех переименований все нормально заменилось.

 

Следующий вопрос. В нескольких местах на плате  появились белые крестики. Они не относятся какому конкретному компоненты или контактной площадке. Ошибок на этом месте нет. Как то это напрягает немного

 

белые крестики.jpg

Edited by vldmr86

Share this post


Link to post
Share on other sites
17 minutes ago, vldmr86 said:

В своей библиотеке нашел подходящий символ. Выглядит он (когда я его в библиотеке рассматриваю) подходяще, но называется почему то ESROPE. У него 2 контактных пина. Один видимо в шины втыкается а ко второму цепь подходит. Но когда я его через setup-settings-special component-netripper пытаюсь в библиотеке найти - его там нет. Или по каким то признакам этот "заменитель" его не определяет как подходящий  или еще по какой причине.

И еще один вопрос. В нескольких местах на плате  появились белые крестики. Они не относятся какому конкретному компоненты или контактной площадке. Ошибок на этом месте нет. Как то это напрягает немного

белые крестики.jpg

Символ рипера есть в стартовой библиотеке pads можете оттуда взять: 

а по поводу крестиков скорее всего там полигон не соединённый с внутренним слоем. Обычно они так крестиками обозначаются 

Edited by philipov

Share this post


Link to post
Share on other sites

Как в Component Explororе сделать так чтобы в списке остались только неустановленные компоненты. Они сейчас выделены жирным шрифтом на фоне всех остальных. А как бы все остальные убрать? 

Share this post


Link to post
Share on other sites
2 hours ago, vldmr86 said:

Как в Component Explororе сделать так чтобы в списке остались только неустановленные компоненты. Они сейчас выделены жирным шрифтом на фоне всех остальных. А как бы все остальные убрать? 

Никак;

вы можете отфильтровать неразмещённые компоненты чтобы они были вверху списка

Share this post


Link to post
Share on other sites
4 часа назад, philipov сказал:

Никак;

вы можете отфильтровать неразмещённые компоненты чтобы они были вверху списка

Есть в этом отрицательном ответе один положительный момент.  Я уже начал расстраиваться что не могу догадаться до очевидного. Оказывается все не так плохо...

Share this post


Link to post
Share on other sites
13 minutes ago, vldmr86 said:

Есть в этом отрицательном ответе один положительный момент.  Я уже начал расстраиваться что не могу догадаться до очевидного. Оказывается все не так плохо...

Почему отрицательном?)

Share this post


Link to post
Share on other sites
23 минуты назад, philipov сказал:

Почему отрицательном?)

Я привык к этой опции в EE7.9.5. Теперь буду отвыкать.

Share this post


Link to post
Share on other sites
6 minutes ago, vldmr86 said:

Я привык к этой опции в EE7.9.5. Теперь буду отвыкать.

Ну это не такое уж и плохое изменение;

как по мне так это удобней чем в 7:9:5

Share this post


Link to post
Share on other sites
17 часов назад, vldmr86 сказал:

Как в Component Explororе сделать так чтобы в списке остались только неустановленные компоненты. Они сейчас выделены жирным шрифтом на фоне всех остальных. А как бы все остальные убрать? 

Можно. Через фильтр.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now