Jump to content

    
Sign in to follow this  
haker_fox

LPC1788, рябь на экране, очень странный случай

Recommended Posts

Добрый день, коллеги, дамы и господа, создатели прекрасной электроники)))) Два года выпускали прибор и никаких проблем не было. Не меняли схемотехнику и ПО. Неожиданно на некоторых приборах, собранных, скажем там после мая сего года, появились полосы на дисплее. После предварительных исследований сделали вывод, что полосы возникают во время работы с SDRAM 64 Мб. В SDRAM находятся два видеобуфера, массивы для расчётов, heap. Конечно, мы пробовали играть с приоритетами CPU, LCD Controller на шине AHB. Мы оценивали пропускную способность шины по известному документу NXP. Выполняли разные эксперименты по замене местами в SDRAM областей буферов и кучи. На 10 раз перепроверили настройки EMC и LCD Controller. Результатов практически нет. Полосы "меняют свою интенсивность", т.е. их чуть больше или меньше становится. Интересный нюанс: если МК запаять вручную микроволной, то полос нет. Но термопрофиль на печке не менялся... Запрос в техподдержке NXP ничео не дал. В общем не удаётся найти решение. Может быть кто-то владеет информацией: ну, например, изменился техпроцесс изготовления микроконтроллеров? Конечно, мог и измениться техпроцесс изготовления SDRAM и дисплея. Все игры с ПО, на мой взгляд, бессмысленны, ибо раньше проблемы не было.

Вот что можно посоветовать в таком случае?

Share this post


Link to post
Share on other sites
7 hours ago, haker_fox said:

появились полосы на дисплее

Фотку бы... 
проблема 100% воспроизводится или время от времени?
 

7 hours ago, haker_fox said:

что полосы возникают во время работы с SDRAM 64 Мб.

Что значит во время работы с SDRAM? Что-то отрисовывается из другой памяти чтото из SDRAM?
То-есть можно думать что неисправность LCD исключена? Проблема в SDRAM и в ней реально испорченные данные?
 

8 hours ago, haker_fox said:

Конечно, мы пробовали играть с приоритетами

Пробовали играть с таймингами SDRAM? (Или LCD?)
 

8 hours ago, haker_fox said:

Интересный нюанс: если МК запаять вручную микроволной, то полос нет.

В этом случае изменяется емкость на выводе (или сопротивление припоя), опять же стоит понизить частоты работы памяти(или LCD), если заработает значит пробема в разводке, раньше кое как работало на одном из порогов, новая память уже капризничает.
Если не заработает значит припой поменяли на более херовый или ваша печка состарилась и не выдерживает термопрофиль как это было раньше и последнее это брак SDRAM(или LCD).
 

Share this post


Link to post
Share on other sites
3 hours ago, Integro said:

Фотку бы... 

Чуть позже, сейчас я не на работе(

3 hours ago, Integro said:

Что значит во время работы с SDRAM?

В память кладутся результаты вычислений.

3 hours ago, Integro said:

То-есть можно думать что неисправность LCD исключена?

Исключена. Меняли.

3 hours ago, Integro said:

Проблема в SDRAM и в ней реально испорченные данные?

От коллеги появились сведения, что при некоторой комбинации расположения регионов памяти (видеобуффера, кучу) в SDRAM, прибо виснет. Т.е, похоже, что данные в памяти действительно портятся. Но это пока догадки.

3 hours ago, Integro said:

Пробовали играть с таймингами SDRAM? (Или LCD?)

Да, конечно. И с теми, и с теми. Результата ноль.

3 hours ago, Integro said:

опять же стоит понизить частоты работы памяти(или LCD)

Понижали, меняется интенсивность ряби и полос (такая рябь из пикселей, напоминает полосы при плохой настройке на канал аналогового телевизора).

3 hours ago, Integro said:

не выдерживает термопрофиль как это было раньше

О! Идея!

3 hours ago, Integro said:

брак SDRAM

Не похоже, эта же память из этой же партии паяется в другие приборы.

Share this post


Link to post
Share on other sites
58 minutes ago, haker_fox said:

Понижали, меняется интенсивность ряби и полос

Тогда остается не качественный монтаж или брак компонентов, но если SDRAM из проверенной партии тогда появляются вопросы к питанию и контроллеру, есть ли среди них компоненты из новой поставки?
 

Edited by Integro

Share this post


Link to post
Share on other sites
57 minutes ago, Integro said:

ли среди них компоненты из новой поставки?

Возможно, я не могу знать точно. Вопросом снабжения занимается отдельный человек. Уточню.

58 minutes ago, Integro said:

Тогда остается не качественный монтаж

Тоже на это думаем, особенно после ручной пайки проца.

Share this post


Link to post
Share on other sites

Самый банальный вариант... непромытый флюс или смена флюса. На производстве я не знаю возможно ли такое, но некоторые товарищи пользуют активный флюс, а потом ни чего не работает.

Share this post


Link to post
Share on other sites
2 часа назад, seniorandre сказал:

Самый банальный вариант... непромытый флюс или смена флюса.

Было подобное на мс ft232 просто переставали работать. Пропаивал, промывал и о, чудо, начинали работать снова и уже на года...

Share this post


Link to post
Share on other sites
1 hour ago, mantech said:

Было подобное на мс ft232 просто переставали работать. Пропаивал, промывал и о, чудо, начинали работать снова и уже на года...

Эт бывает когда чипы без упаковки долго лежат.
У меня не далее как позавчера попала в руки  бракованная плата с чипом в корпусе LQFP. 
Глянул в микроскоп, а ноги в припое, но не смочены им. И ноги чернее обычного, сразу визуально видно. 
Делаем эти платы периодическими партиями и возможно поизводитель в ленту заложил какие-то остатки уже окисленные. 

Share this post


Link to post
Share on other sites
31 минуту назад, AlexandrY сказал:

Глянул в микроскоп, а ноги в припое, но не смочены им. И ноги чернее обычного, сразу визуально видно. 

Нее, у меня как-раз случай, что с виду все припаяно, и темного ничего нет, но флюс г... и не отмыт по-хорошему, видимо емкость между ног была не маленькая, или сопротивление низкое из-за проводимости флюса...

Share this post


Link to post
Share on other sites
11 hours ago, seniorandre said:

непромытый флюс или смена флюса

Платы, конечно, моют в специальной машине. Но кто знает... На счёт смены флюса. В общем всё это я узнаю на работе в монтажном цехе.

6 hours ago, AlexandrY said:

Эт бывает когда чипы без упаковки долго лежат

Прикольно, впервые такое слышу! Надо тоже проверить...

 

6 hours ago, AlexandrY said:

но не смочены им

Другими словами, припоё не "прилип" к ноге, обволок её с плохим контактом по постоянке. Всё работает на переменке.

6 hours ago, mantech said:

или сопротивление низкое из-за проводимости флюса

Всё проверим.

Спасибо, коллеги!!!

Share this post


Link to post
Share on other sites

Что-то такое было. Три момента: 1) Проврьте качество блокировочных, может поставили не те, не того номинали или X7R заменили Y5V. 2) Проверьте импульсники, особенно катушки и соответствие их феррита. Диоды и др. 3) Плохое качество плат, под маской осталась микронная пленка с низким сопротивлением, при плохой промывке в процессе производства плат.

Также потыкав осцилографом в нужные места можно найти причину.  

Share this post


Link to post
Share on other sites
В 09.08.2019 в 15:41, haker_fox сказал:

Понижали, меняется интенсивность ряби и полос (такая рябь из пикселей, напоминает полосы при плохой настройке на канал аналогового телевизора).

Была похожая картина с сериализатором RGB->LVDS, тоже пиксели "бегали". Забавно, но на матрице 1280x1024, а на 1920x1080 нормально всё

По питанию стояли 0.1мкФ X7R

Добавили параллельно 4.7мкФ X5R и проблема исчезла

 

Share this post


Link to post
Share on other sites
3 минуты назад, haker_fox сказал:

Коллеги, мне разрешили выложить видео с рьябью)

cut.mkv

Посмотрел. Ну что можно сказать? Хорошая рябь, крупная такая. :wink:

Ваш случай не первый, уже были аналогичные и уже есть опробованные методы лечения. См. здесь:  http://evdokimov.ru/anatolij-trushkin/kto-vinovat.html

:biggrin:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this