Jump to content

    

ШИМ + Драйвер = проблема

Столкнулся с такой проблемой, пока для меня необъяснимой. 

Имеется:
Двигатель ПостТока на 12 Вольт.
Драйвер DRV8872 ( от 6,5 вольт питание, до 3.6 А).
Управляющий сигнал с STM32 (допустим 40%).

При подключении ДПТ с ШИМ-ом, ощущение что драйвер уходит в какую то отсечку, проседает напряжение (вплоть до 1 вольта) когда на двигателе появляется нагрузка. Напруга падает сильно, а следовательно сильно падает момент и двигло не тянет что ему положено. 

Напряжение без двигателя было 4.1 вольта, подключаю двигатель без нагрузки - напряжение увеличивается до 5.5 вольт на двигле (вал свободный)...пытаюсь рукой сымитировать нагрузку - напруга падает до 1 вольта.

Источник не проседает(мерил), перед ним стоит LM2596-12 на 3А
Мерил ток в разрыве...максимум 300 мА, т.е. не по току Драйвер отключается. Других особо защит не нашёл в ДШ.
(При подобных нагрузках напрямую от источника там токи до 1А)
И подумал уже что и драйвер фигня, или микросхема левая или подгорела уже...но провёл два эксперимента и не знаю что думать

 

Эксперимент 1.
Питаю драйвер 12тью вольтами. Подаю ШИМ таким образом, что без нагрузки напряжение на выходе 6,9 вольта.
Подключаю двигатель без нагрузки...напряжение на двигателе ВОЗРОСЛО до 8-9 Вольт (показалось, что зависит от частоты ШИМа, пробовал от 40 Гц до 80 кГц)
Подаю нагрузку рукой, напряжение на двигателе падает до 5 вольт....ну и момент так видно что уходит. 
В общем примерно тоже что и выше писал, но другие цифры.

 

Эксперимент 2.
С источника подал на Драйвер ровно 6.9 вольта, отрезав LM2596.
И включил драйвер в ключевом режиме, без ШИМа, 100% duty cycle так сказать.
На выходе без мотора было те же 6.9 вольта. 
Подключил Двигло. Напряжение 6.7 вольта, попытался рукой дать нагрузку на вал, напруга просела до 6.2 что логично. Но и момент остался соответствующим. 

 


Главный вопрос! Почему драйвер так не любит ШИМ? И как ещё можно адекватно управлять двиглом, уже думаю что на других драйверах меня ждёт такая же участь? 
Уже готов на H-мостовую схему...ибо катать надо в обе стороны.

Edited by draksnov

Share this post


Link to post
Share on other sites

Верхние транзисторы питает помпа без внешних конденсаторов, а значит очень слабая, только для работы на НЧ, хотя в паспорте много где сказано про 100 кГц.

 

Скорее всего, сперва это был обычный стабилизатор тока, затем маркетологи сказали допилить его до "других ниш рынка".

Share this post


Link to post
Share on other sites

Всякое уже испробовал. 

В итоге собрал обычный H-мост и он, ПРИ ТЕХ ЖЕ УСЛОВИЯХ, работает так как и положено.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now