Jump to content

    

Файл ELF не создается в Vivado 2017.4 для ZCU102

У меня на компьютере есть две версии Vivado: 2017.4 и 2018.3. Лицензия пришла с платой ZU102
Я реализовал один и тот же стандартный пример Xilinx Base_Zynq_MPSoC в 2017.4 и 2018.3 для платы ZCU102.
Затем я запустил SDK 2017 и SDK 2018 со стандартным приложением Hello World и возникла проблема:
После команды «Build All» SDK2018 создает файл ELF без проблем, но SDK2017 вообще не создает файл ELF. Есть ли логическое объяснение?

Share this post


Link to post
Share on other sites
2 hours ago, mirobest said:

После команды «Build All» SDK2018 создает файл ELF без проблем, но SDK2017 вообще не создает файл ELF. Есть ли логическое объяснение?

Если бы вы дали сюда вывод лога сборки проекта в сдк2017 то вопрос был бы более предметным, а экстрасенсы обитают на другом форуме.

Лицензия обычно "режет" новые версии, а старые должны работать.

Share this post


Link to post
Share on other sites

SDK2017 log :

15:42:23 INFO    : Launching XSCT server: xsct.bat -interactive C:\Users\zz\project_sdk2017_test\project_sdk2017_test.sdk\temp_xsdb_launch_script.tcl
15:42:23 INFO    : XSCT server has started successfully.
15:42:23 INFO    : Successfully done setting XSCT server connection channel  
15:42:23 INFO    : Successfully done setting SDK workspace  
15:42:23 INFO    : Registering command handlers for SDK TCF services
15:42:23 INFO    : Processing command line option -hwspec C:/Users/zz/project_sdk2017_test/project_sdk2017_test.sdk/Base_Zynq_MPSoC_wrapper.hdf.
15:42:25 INFO    : Checking for hwspec changes in the project Base_Zynq_MPSoC_wrapper_hw_platform_0.

 

«Build All»  не генерирует сообщений в SDK Log 

Share this post


Link to post
Share on other sites
23 minutes ago, mirobest said:

«Build All»  не генерирует сообщений в SDK Log 

Вывод лога сборки идет на закладку Console в SDK.

Не запаривайтесь для 102 борды со старыми вивадами - 2018.3 даже относительно 2018.2 имеет ряд полезных улучшений. Насчет 2019.1 уже не скажу - не тестил. А при повторной загрузке проекта по JTAG дурят все одинаково.

Share this post


Link to post
Share on other sites

Проблема здесь:

 

16:57:46 **** Build of configuration Debug for project 2017_A53 ****
make all 
Building file: ../src/helloworld.c
Invoking: ARM v8 gcc compiler
make: Interrupt/Exception caught (code = 0xc00000fd, addr = 0x4227d3)

16:57:48 Build Finished (took 1s.767ms)

Share this post


Link to post
Share on other sites
28 minutes ago, mirobest said:

Invoking: ARM v8 gcc compiler
make: Interrupt/Exception caught (code = 0xc00000fd, addr = 0x4227d3)

По этой фразе ошибка прекрасно гуглится

https://forums.xilinx.com/t5/Embedded-Development-Tools/SDK-won-t-build-in-WIN7-errors-out/td-p/241584

https://www.xilinx.com/support/answers/67854.html

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this