Jump to content

    
Sign in to follow this  
LAS9891

Не работает MOXA UPort 1130

Recommended Posts

Имеется плата, которая подключается к компьютере посредством интерфейса RS-485 с использованием MOXA UPort 1130. При подключении всего перечисленного ничего не работает. На MOXA горит постоянно светодиод "Active" и в момент передачи светится "TxD". На осциллографе видны импульсы на выводе 3 Data+(B). Как проверить работоспособность MOXA без подключения платы, чтобы убедиться в её невиновности?

Share this post


Link to post
Share on other sites

1. Установить драйвер

2. Подключить 1130 к USB

3. Установить режим RS-485 4W (стр. 21) (четырехпроводный режим)

4. Запустить гипертерминал или putty и настроить ее на работу с 1130

5. Осциллографом смотреть на выводы 1 и 2 разъема у Мохи относительно вывода 5 (GND) (стр. 42). На выводах должны быть импульсы противоположной полярности при нажатии кнопок на клавиатуре.

6. Замкнуть вывод 1 с выводом 4, вывод 2 с выводом 3. При нажатии кнопок на клавиатуре на экране должны появляться соответствующие символы.

7. Установить режим RS-485 2W (стр. 21) (двухпроводный режим)

8. Осциллографом смотреть на выводы 3 и 4 разъема у Мохи относительно вывода 5 (GND). На выводах должны быть импульсы противоположной полярности при нажатии кнопок на клавиатуре и на экране должны появляться соответствующие символы.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this