Jump to content

    

Не работает MOXA UPort 1130

Имеется плата, которая подключается к компьютере посредством интерфейса RS-485 с использованием MOXA UPort 1130. При подключении всего перечисленного ничего не работает. На MOXA горит постоянно светодиод "Active" и в момент передачи светится "TxD". На осциллографе видны импульсы на выводе 3 Data+(B). Как проверить работоспособность MOXA без подключения платы, чтобы убедиться в её невиновности?

Share this post


Link to post
Share on other sites

1. Установить драйвер

2. Подключить 1130 к USB

3. Установить режим RS-485 4W (стр. 21) (четырехпроводный режим)

4. Запустить гипертерминал или putty и настроить ее на работу с 1130

5. Осциллографом смотреть на выводы 1 и 2 разъема у Мохи относительно вывода 5 (GND) (стр. 42). На выводах должны быть импульсы противоположной полярности при нажатии кнопок на клавиатуре.

6. Замкнуть вывод 1 с выводом 4, вывод 2 с выводом 3. При нажатии кнопок на клавиатуре на экране должны появляться соответствующие символы.

7. Установить режим RS-485 2W (стр. 21) (двухпроводный режим)

8. Осциллографом смотреть на выводы 3 и 4 разъема у Мохи относительно вывода 5 (GND). На выводах должны быть импульсы противоположной полярности при нажатии кнопок на клавиатуре и на экране должны появляться соответствующие символы.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now