Jump to content

    

не инициализируется TUSB2046 от внешнего клока 48 МГц

Имеем TUSB2046, который  через раз инициализируется от внешнего клока 48 МГц который делает ему процессор AM4376. Процессор получает внешний сигнал 25 МГц и прекрасно от него работает вплоть до 1 ГГц.  Для HUBа делает 48 PLLкой с выхода CLKOUT1.От внешнего кварца на 6МГц стартует нормально

Share this post


Link to post
Share on other sites

А активен ли клок, когда TUSB получает RESET?

Share this post


Link to post
Share on other sites

Вас следует понимать так. Сначала подать питание, потом клок и уже потом моргнуть резетом?

Share this post


Link to post
Share on other sites
Quote

Clock signal has to be active during the last 60 us of the reset window.

 

 

Share this post


Link to post
Share on other sites

48 не кратно 25. PLL будет заводиться и устанавливаться долго. Делать резет TUSB нужно по lockout PLL. И проверить стабильность PLL. Сталкивались с тем что они дают много боковых частот.

Share this post


Link to post
Share on other sites

Требование про 60 микросекунд мы видели. Я не сказал о еще одном чудесном факте. За несколько месяцев до покупки микросхем для этого устройства мы купили в тестовых целях там же в Компеле несколько чипов. Так вот те чипы  - купленные ранее заводятся. Причем один и тот же чип мы перепаивали феном 3 раза и пробовали его на трех платах. И он везде нормально проходил инициализацию и заводился. Завтра посмотрим стабильность PLL. 

Share this post


Link to post
Share on other sites
22 minutes ago, vldmr86 said:

Требование про 60 микросекунд мы видели.

Так видели, или все же выполнили? Отличия в поведении микросхем из разных партий ни о чем не говорят, если требования даташита не соблюдены.

Share this post


Link to post
Share on other sites

Похоже не выполнили. У нас длительность низкого уровня больше.  А вы это время обеспечивали процессором или RC цепью?

Share this post


Link to post
Share on other sites
1 hour ago, vldmr86 said:

Похоже не выполнили. У нас длительность низкого уровня больше.

Не понимаю. По документации клок должен подаваться по меньшей мере в последние 60мкс активного уровня сигнала RESET.

Если больше, то это не проблема.

Share this post


Link to post
Share on other sites

Использовал STM32F4 для XTAL1/CLK48

Нормально всё работало.

Share this post


Link to post
Share on other sites

Всем спасибо кто поучаствовал и пытался помочь. Разобрались. Не в резете дело было и не в клоке. Процессор наш AM4376BZDN80 очень оригинально грузился в выбранном режиме. Он делал SWAP  входной шине хаба - менял местами DP и DM

Share this post


Link to post
Share on other sites
1 час назад, vldmr86 сказал:

Он делал SWAP  входной шине хаба - менял местами DP и DM

О как... 

21 час назад, vldmr86 сказал:

мы купили в тестовых целях там же в Компеле несколько чипов. Так вот те чипы  - купленные ранее заводятся.

Интересно, как это работало тогда??:biggrin:

Share this post


Link to post
Share on other sites

Мы тоже не ожидали. Но после того как все подходящее перебрали вернулись к описанию и оппа!

amazing near.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this