Jump to content

    

EDID для матрицы - 74.25MHz @ 1080p

Добрый день

Запостил сюда, вроде как ничего более близкого не нашёл.

Итак, есть собранный девайс HDMI->LVDS (2 channels) на известной связке TFP401->DS90C387A, т.е. скалера нет, всё гонится напрямую - первая "потрошит" в суммарно 48 бит цвета, вторая эти биты собирает и сериализует в двухканальный LVDS. Всё работает, по крайней мере с матрицами 1024х768 (девайс нормально отдаёт EDID ро I2C)

И теперь пришла пора FullHD. На данный момент в наличии китайская панель 32", именуемая как MGELED320-L02

Из даташитов информация странная - частота указана как 74.25МГц, в то время как везде она должна быть 148.5МГц для 60Гц

И упёрся в стену - никак не могу сконфигурировать нормально EDID - матрица вообще ничего не выводит

При этом натыкался на ответ TI, где представитель отвечает на вопрос по поводу FullHD, - да, могет 1080p - и TFP401, и DS90C387A !

И вот где-то спотыкаюсь я о граблю, которую даже не вижу в этом бурьяне :cray2:

Даташиты прилагаю, надеюсь на помощь

PS. Управляющие сигналы связки м/сх могу изменять "на лету" - не помогает. При этом SCDT от TFP401 вижу - компьютер в HDMI поток гонит

32inch LCD specification(1500nit).pdf

Share this post


Link to post
Share on other sites
1 hour ago, toweroff said:

Из даташитов информация странная - частота указана как 74.25МГц, в то время как везде она должна быть 148.5МГц для 60Гц

Каналов два, вот и частота вдвое ниже.

Share this post


Link to post
Share on other sites
3 часа назад, toweroff сказал:

И вот где-то спотыкаюсь я о граблю, которую даже не вижу в этом бурьяне :cray2:

Даташиты прилагаю, надеюсь на помощь

раз экран даже не моргает, то начните с простейшего: на стр №7 вашей доки есть пункт №5, в вольном переводе "если пин 44 на GND, то нормально работаем, если притянуть на "1", то выведу тестовый шаблон на экран"

я бы притянул к 1, если засветился (кстати, подсветка то включена?) и пошла тестовая графика, то есть смысл двигаться дальше.. если нет, то копать, питание, монтаж или экран кандидат в мусорку..

Share this post


Link to post
Share on other sites
16 часов назад, aaarrr сказал:

Каналов два, вот и частота вдвое ниже.

Да, это я уже тоже понял

 

14 часов назад, Jury093 сказал:

раз экран даже не моргает, то начните с простейшего: на стр №7 вашей доки есть пункт №5, в вольном переводе "если пин 44 на GND, то нормально работаем, если притянуть на "1", то выведу тестовый шаблон на экран"

я бы притянул к 1, если засветился (кстати, подсветка то включена?) и пошла тестовая графика, то есть смысл двигаться дальше.. если нет, то копать, питание, монтаж или экран кандидат в мусорку..

Подсветка есть, конечно

Тестовая графика выражается в последовательном чередовании белого--красного--зелёного--синего--черного цветов по всей матрице

 

 

Share this post


Link to post
Share on other sites
21 минуту назад, toweroff сказал:

Подсветка есть, конечно

Тестовая графика выражается в последовательном чередовании белого--красного--зелёного--синего--черного цветов по всей матрице

про подсветку я спросил на всякий случай, разные варики бывают..

отлично, считаем, что матрица запитана и внутренне исправна.

какая комбинация сетапа у 401? раз SCDT шевелится, значит nPD отпущен и чип детектит входную частоту

вот тут, при наличие осцилла, полезно пройтись по выходным контактам 401 и проверить, что сигналы из нее выбегают

далее, уровень сигнала на PowerDown у 387? д.б. в 1

я бы начал с простейшего - отключил вторую половину матрицы и на вход 401 дал бы не FullHD а что-нить поменьше - завелось, тогда копать дальше, нет - искать где не проходит сигнал, и потом задирать частоту

и что в качестве источника видео? комп, мелкий кит? если первое, то есть смысл поискать дампы EDID для похожего варианта, залить в 24c02 и подцепить на DDC канал - запросто может source капризничать..

и конечно, еще раз проверить монтаж и аккуратно прозвонить шлейфы - обрыв или к.з. фу-фу-фу..

Share this post


Link to post
Share on other sites

Сам преобразователь на 1024х768 матрице в два канала отлично работает. Режимы пробовал разные (как для 401, так и для 387), благо, как уже говорил, могу "на лету" с компа это всё менять - не помогает

Сейчас добился того, что матрица, вроде как, черный цвет видит нормально (:biggrin:)

При "вдвигании" окна в область второго монитора кратковременно появляется некая каша, в которой можно угадать очертания и содержимое этого окна, потом пропадает и пошёл опять перебор WRGBB

Убираем окно из области монитора - опять черный цвет и можно повторять упражнение

Share this post


Link to post
Share on other sites
1 hour ago, toweroff said:

При "вдвигании" окна в область второго монитора кратковременно появляется некая каша, в которой можно угадать очертания и содержимое этого окна, потом пропадает и пошёл опять перебор WRGBB

Похоже, данные в синхронизацию лезут в одном из каналов. TFP401 точно в режиме 2pix/clock? Ну и схемку бы, аль чертеж.

Share this post


Link to post
Share on other sites

image.png.47700a50a2a92005e5c0df4c93057068.png

Да, 401 в 2pix/clock mode.

По схеме - да там же ж всё стандартно. Все сигналы от 401 к 387 через 33 Ом, различие длин не более 2см (не было места выровнять). Дифпары от 387 выровнены до 0.5мм

Осциллографа нормального нет, к сожалению. Есть только до 50МГц полосой

Единственное - обвязка емкостями по 100нФ. Не уменьшить ли их до 10нФ?

Share this post


Link to post
Share on other sites

Может, полярности в парах где-нибудь перепутаны?

Share this post


Link to post
Share on other sites

Да, вроде, перепроверял уже раза три... Нормально всё

46 минут назад, aaarrr сказал:

Похоже, данные в синхронизацию лезут в одном из каналов

Так в том-то и штука, что матрица не использует синхронизацию, только DE

А вот как это отразить в EDID - не соображу

Share this post


Link to post
Share on other sites
14 minutes ago, toweroff said:

Так в том-то и штука, что матрица не использует синхронизацию, только DE

Тогда я бы попробовал физически отрезать соответствующие линии между TFP и DS.

 

14 minutes ago, toweroff said:

А вот как это отразить в EDID - не соображу

Никак, насколько я помню.

Share this post


Link to post
Share on other sites
В 04.06.2019 в 12:53, aaarrr сказал:

Может, полярности в парах где-нибудь перепутаны?

Оказалось, именно так. В обоих каналах перепутаны оба клока

Теперь всё орбайтн, тему можно закрыть

Всем спасибо!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now