Jump to content

    
Sign in to follow this  
cubot

Камера OV5642. Тишина на DCMI

Recommended Posts

Начал играться с камерой на OV5642 и хрень какая-то происходит. Камеру конечно в китайском посылторге брал, вот такая
На модуле уже распаян генератор на 24МГц. Подключаю к F746, по i2c отвечает, свой номер отдает правильно, настройки записываются, но. На DCMI - тишина. Я ведь правильно понимаю, что если подать питание и клок, на dcmi должно быть шевеление? По крайней мере проверил на ov7670, так и есть - подал питание и клок, и PXCLK, HREF, VSYNC зашевелились с похожей на правду частотой. А у этой тишина..
Это камера дохлая или лапки?
Кто-нить ковырял именно ov5642?

Share this post


Link to post
Share on other sites

эээ.. Наверное не особо ясно выразился. DCMI - это параллельный интерфейс у стм. Я правильно понимаю, что это то что они обзывают DVP, и с 0х18 получается что он включен.

Share this post


Link to post
Share on other sites

))) да, я уже разобрался что это лапки )))
Ввело в заблуждение что и 7670 и 2640 при дефолтных настройках сразу выдают шевеление на PXCLK, HREF, VSYNC, а эта нет.
Эта камера по ребуту действительно не выдает никакие сигналы - ее нужно сконфигурировать. И вот тут подкрались лапки - ошибся при настройке i2c и писал с однобайтным адресом регистра, а надо два байта. Конечно камера этого не понимала и не конфигурировалась -> на выход ничего не выдавала. Поправил запись регистра и все завелось. Ну в смысле хоть какую-то картинку начала выдавать.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this