Перейти к содержанию

    

Ошибка при прошивке EEPROM

Здравствуйте! 
У меня есть готовые два файла для прошивки ATxmega32A4 , основной файл и EEPROM. Пишу через AVR studio 4 программатор AVR ISP mkII. ТАк вот основная программа пишется без проблем, но следом при прошивке EEPROM возникает такая проблема ( как на картинке). Фьюзы тоже прикрепил! Может кто сталкивался с таким?

Screenshot_1.png

Screenshot_7.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте.

Если я не ошибаюсь, то вам нужно по внимательней прочитать информацию про фьюзы. И разобраться с "галкой"  EESAVE.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
6 minutes ago, Сергей said:

Здравствуйте.

Если я не ошибаюсь, то вам нужно по внимательней прочитать информацию про фьюзы. И разобраться с "галкой"  EESAVE.

EESAVE - фьюз для сохранение данных EEPROM  при стирании самого кристалла, если я ничего не путаю. Но я пытался и с этим фьюзом и без него! Результат одинаковый

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Насколько я понял не проходит сравнение записанных и прочитанных данных еепром.

Попробуйте перед записью еепрома очистить оный.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
On 3/1/2019 at 10:51 PM, zombi said:

Насколько я понял не проходит сравнение записанных и прочитанных данных еепром.

Попробуйте перед записью еепрома очистить оный.

Да, я пробовал после того как прошил основную программу, стирал EEPROm и записывал. Результат тот же. Изначально я подумал, что убита EEPROM в старом проце, поменял на такой же. Проблема была не в этом.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация