Перейти к содержанию

    

Перестал формироваться BOM

Добрый день!

Использую на работе лицензионный AD10 уже много лет, вполне успешно. Недавно переустановил Windows, поставил все как было: Windows 7 Professional, Office 2007, Altium Designer 10. Перестал формироваться Bill of materials, при попытке сформировать выдает ошибку "Failed to open Excel template". До переустановки все работало, а теперь не понимает ни одного шаблона, даже свои дефолтные. Куда копать, кто сталкивался с таким глюком? Использовать версию новее не могу, т.к. в офисе строго с лицензионной чистотой софта.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А Office не мог оказаться 64-разрядным?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 hours ago, Alex Kuritsyn said:

Добрый день!

Использую на работе лицензионный AD10 уже много лет, вполне успешно. Недавно переустановил Windows, поставил все как было: Windows 7 Professional, Office 2007, Altium Designer 10. Перестал формироваться Bill of materials, при попытке сформировать выдает ошибку "Failed to open Excel template". До переустановки все работало, а теперь не понимает ни одного шаблона, даже свои дефолтные. Куда копать, кто сталкивался с таким глюком? Использовать версию новее не могу, т.к. в офисе строго с лицензионной чистотой софта.

Проверить правильно ли с путями до темплейтов.

Если все ок, копать в сторону екселя

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Снес офис, экспорт BOM заработал, но криво: часть столбцов выводит, часть - нет. Шапку из шаблона вообще не выводит. Знаю, что шаблон рабочий: ранее на этой же машине с этими же версиями windows, altium и office все работало. Прочитал ветку по этой проблеме на сайте altium (на их форуме), у нескольких человек такая же фигня, но найти причину не могут...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вроде совсем без офиса нельзя!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
48 minutes ago, Alex Kuritsyn said:

Сейчас снова поставил офис и опять та же фигня - ошибка "Failed to open Excel template"...

А шаблоны в каком формате? .xlt?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Перепробовал все: xlt, xltx, xls. Стандартные шаблоны из общей папки - тоже. Везде ошибка.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Единственное решение, которое нашел в сети, это переустановка офиса с 2013 на 2016 "We were able to fix the two affected computers in our company. We uninstalled Office 2013, installed Office 2016 and this problem was gone. AD can open Excel templates again and create a BOM." https://forum.live.altium.com/#posts/228975?os=20

Причем другие люди пишут, что в их случае не прокатывает. Но у меня есть возможность поставить только офис 2007 :(

Изменено пользователем Alex Kuritsyn

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти