Jump to content

    

Проблема с отладкой в MPLAB X

Вроде пользуюсь этой средой не впервые, но всякий раз возникают новые чудеса. Отлаживал устройство на PIC16F88 - не было проблем.

Сейчас переделал плату на PIC16F873A (ног не хватило), стал отлаживать. Сталкиваюсь со странным поведением. Если запустить Debug Project - программа компилируется, прошивается, запускается. Работает, пока не остановишь. Стоит сделать паузу и попытаться пустить дальше - выдаёт ошибку:

Quote

The target device is not ready for debugging. Please check your configuration bit settings and program the device before proceeding. The most common causes for this failure are oscillator and/or PGC/PGD settings.
Failed getting PC

Что это может быть?

Отладчик - PicKit 3, OS - WIN10, резонатор - керамический 20МГц. Биты конфигурации:

#pragma config FOSC = HS          // Oscillator Selection bits (HS oscillator)
#pragma config WDTE = OFF       // Watchdog Timer Enable bit (WDT disabled)
#pragma config PWRTE = OFF     // Power-up Timer Enable bit (PWRT disabled)
#pragma config BOREN = ON       // Brown-out Reset Enable bit (BOR enabled)
#pragma config LVP = OFF           // Low-Voltage (Single-Supply) In-Circuit Serial Programming Enable bit 
// (RB3 is digital I/O, HV on MCLR must be used for programming)
#pragma config CPD = OFF          // Data EEPROM Memory Code Protection bit (Data EEPROM code protection off)
#pragma config WRT = OFF         // Flash Program Memory Write Enable bits 
// (Write protection off; all program memory may be written to by EECON control)
#pragma config CP = OFF            // Flash Program Memory Code Protection bit (Code protection off)

Ничего необычного.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this