Jump to content

    
toshas

Altium Designer 19 (365)

Recommended Posts

On 4/17/2019 at 6:33 AM, sast777 said:

Altium 19.1.3  Schematic - задержка при перемещении объектов.

Пришлось переставить Windows - за 4 года 7-ка сдохла.
Поставил Win 10, 1809. (I7 4770K, 16Gb RAM, NVIDA GeForce 750)

Привычный Altium 17.1.9 Schematic крашится при попытке сделать "Copy" - вылетает по exeption.

Поставил Altium 19.1.3
Schematic - при попытке перемещения выделенных объектов зависает на n секунд и лишь после задержки выделенные объекты перемещаются.

Задержка явно зависит от числа выбранных объектов.

Перемещение одиночного Net Label после выделения и перемещения мыши  вызывает появление вращающегоя кружка примерно на 1-2 секунды, потом Net Label оказывается в нужной позиции.

Перемещение компонента с 10-ю пинами и 10 присоединенными цепями с Net Label вызывает замерзание на 3-5 секунд.

Перемещение ~ 80 компонентов с цепями практически невозможно - замерзание таково, что не предугадать, куда попадешь.
windows Task manager  во время зависания Altium на перемещение объектов дает загрузку CPU ~14-15%, независимо от того, сколько объектов перемещаю. Used RAM < 3.5Gb.

Preference -> Schematic менял: GDI+; Drag Step (Smallest -Large). 

Явное ощущение, что причина где-то в настройках.

Где бы поставить- убрать птичку, подвинуть ползунок?

Столкнулись с подобной проблеммой на больших листах. После перемещения любого объекта идет компиляция и на большом листе длиться довольно долго.

Share this post


Link to post
Share on other sites

Не скажу с какой. Я не использую большие размеры листов.
Это страшно не удобно

В моей практике только один человек попадался - любитель все размещать на одном листе.
Это было давно и приводила к существенному торможению при работе на таком листе

 

Share this post


Link to post
Share on other sites

Добрый день!

Подскажите куда копать. Делаю трассировку, начал заливать полигоны. Они либо вообще не подключаются к КП SMD, либо подключаются одной-двумя дорожками из указанных в правиле 4х дорожек термобарьера.

Плавила стандартные, своего ничего особо не выдумывал. Но стоит вытащить кусок трассировки с компонентами и полигоном за пределы ПП, всё подключается как надо.

Приложить исходники к сожалению не могу (

Share this post


Link to post
Share on other sites
В 31.03.2020 в 21:06, Владимир сказал:

Где то есть Shelved полигоны в этой зоне.
все сделайте активными и перезалейте

Спасибо, помогло.

Еще вопрос. У меня есть компонент, на данный момент он представлен в виде одного УГО.

Для удобства отрисовки схемы, решил его разбить на 4 части. Делаю альтернативное представление компонента, разбиваю на 4 части. Всё хорошо работает.

Но когда возвращаюсь к нормальному представлению разбиение остается, просто оставшиеся три части пустые.

Как правильно организовать библиотеку или нарисовать УГО чтобы решить проблему?

Share this post


Link to post
Share on other sites

сделать раздельно.
Один компонент- один уго. и  желательно без альтернативы

Альтернативные изображения не должны изменять Netlist на схеме при замене. То есть должны содержать одинаковое число PIN и частей. и положение Pin должно совпадать. Иначе при Update можете получить большую проблему, если выберете не тот вариант.

То есть они предназначены например для русского и американского изображения резистора. Для разного отображения состояния контактов реле и прочей графической гадости.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.