Перейти к содержанию

    

Пошаговая отладка в Keil 5.17 идет только по асемблеру (окно Disassembly)

Я бы пошел по пути поиска источника проблемы: создал бы пустой проект БЕЗ ЗАГРУЗЧИКА с нуля под выбранный камень и поэтапно добавлял в него исходники из проблемного проекта.

Разумеется, предполагается, что пустой проект сразу будет работать по шагам как надо.

Если этого с ходу не будет, то проблему искать в среде или отладчике.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Спасибо за уделенное время. Буду пробовать менять настройки, сам кейл и читать мануалы. Как только исправлю неудобства - сообщу.

Если же будут какие нить идеи - пишите не стесняйтесь.

Всем хорошего настроения! :good3:

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
52 минуты назад, wellcom сказал:

Внизу нет никаких ошибок. Где этот мап мемори ? это файл или настройки?

В меню Debug есть вкладка Memory Map.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кажись все заработало.

Запустил батник, почистил все и вроде как пашет.

Пользуйтесь. (файл приложен). Ложить этот батник нужно в корневую папку с проектом (см. картинку где лежит у меня).

Что удаляется - см. сам батник. Ну и конечно не забыть сделатть ребилд.

2018-11-18_154005.jpg

keilkilll.bat

Изменено пользователем wellcom

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 минуты назад, Arlleex сказал:

А просто Clean Target не помог?

Этим не пользовался. В следующий раз попробую!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти