Jump to content

    

Пошаговая отладка в Keil 5.17 идет только по асемблеру (окно Disassembly)

Я бы пошел по пути поиска источника проблемы: создал бы пустой проект БЕЗ ЗАГРУЗЧИКА с нуля под выбранный камень и поэтапно добавлял в него исходники из проблемного проекта.

Разумеется, предполагается, что пустой проект сразу будет работать по шагам как надо.

Если этого с ходу не будет, то проблему искать в среде или отладчике.

Share this post


Link to post
Share on other sites

Спасибо за уделенное время. Буду пробовать менять настройки, сам кейл и читать мануалы. Как только исправлю неудобства - сообщу.

Если же будут какие нить идеи - пишите не стесняйтесь.

Всем хорошего настроения! :good3:

Share this post


Link to post
Share on other sites
52 минуты назад, wellcom сказал:

Внизу нет никаких ошибок. Где этот мап мемори ? это файл или настройки?

В меню Debug есть вкладка Memory Map.

Share this post


Link to post
Share on other sites

Кажись все заработало.

Запустил батник, почистил все и вроде как пашет.

Пользуйтесь. (файл приложен). Ложить этот батник нужно в корневую папку с проектом (см. картинку где лежит у меня).

Что удаляется - см. сам батник. Ну и конечно не забыть сделатть ребилд.

2018-11-18_154005.jpg

keilkilll.bat

Edited by wellcom

Share this post


Link to post
Share on other sites
3 минуты назад, Arlleex сказал:

А просто Clean Target не помог?

Этим не пользовался. В следующий раз попробую!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now