Jump to content

    
Sign in to follow this  
wellcom

Пошаговая отладка в Keil 5.17 идет только по асемблеру (окно Disassembly)

Recommended Posts

Я бы пошел по пути поиска источника проблемы: создал бы пустой проект БЕЗ ЗАГРУЗЧИКА с нуля под выбранный камень и поэтапно добавлял в него исходники из проблемного проекта.

Разумеется, предполагается, что пустой проект сразу будет работать по шагам как надо.

Если этого с ходу не будет, то проблему искать в среде или отладчике.

Share this post


Link to post
Share on other sites

Спасибо за уделенное время. Буду пробовать менять настройки, сам кейл и читать мануалы. Как только исправлю неудобства - сообщу.

Если же будут какие нить идеи - пишите не стесняйтесь.

Всем хорошего настроения! :good3:

Share this post


Link to post
Share on other sites
52 минуты назад, wellcom сказал:

Внизу нет никаких ошибок. Где этот мап мемори ? это файл или настройки?

В меню Debug есть вкладка Memory Map.

Share this post


Link to post
Share on other sites

Кажись все заработало.

Запустил батник, почистил все и вроде как пашет.

Пользуйтесь. (файл приложен). Ложить этот батник нужно в корневую папку с проектом (см. картинку где лежит у меня).

Что удаляется - см. сам батник. Ну и конечно не забыть сделатть ребилд.

2018-11-18_154005.jpg

keilkilll.bat

Edited by wellcom

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this