Jump to content

    

ModelSim*-Intel® FPGA (Starter) Edition какие камни поддерживает?

Доброго всем!
Работаю с Cyclone II (его русским аналогом), моделирую в Modelsim-e 10.1d (из Quartus-a 13.0sp1).
Хочется взять Modelsim посвежее, тем более, что на сайте есть слова: Device support    
All Intel® FPGA devices (Including Intel® MAX® CPLDs, Intel® Arria®, Intel® Cyclone®, and Intel® Stratix® series Intel® FPGAs)
Так вот вопрос: тварь ли я дрожащая или право имею? 

Share this post


Link to post
Share on other sites
1 час назад, AnatolySh сказал:

Хочется взять Modelsim посвежее,

ИМХО смысла в этом нет никакого.

ModelSim-Altera синхронизируется с версиями квартуса в первую очередь в плане наличия библиотек симуляции для новых семейств.

А в квартусе v18.1, кстати, Cyclone II уже не поддерживается.

Конечно, можно проверить, не осталось ли в соответствующей версии ModelSim-IntelFPGA Edition библиотеки Cyclone II в виде рудимента (что сомнительно). В любом случае, переход на новую версию в этом случае никаких дополнительных плюшек не даст.

Share this post


Link to post
Share on other sites
17 hours ago, StewartLittle said:

В любом случае, переход на новую версию в этом случае никаких дополнительных плюшек не даст.

А если (удастся) перетащить библиотеки и старой версии  ModelSim-Altera Edition в ModelSim-IntelFPGA Edition - это может дать дополнительные плюшки?
Как вариант установить свежую версию  ModelSim-а ("чистого", не Intel Edition-a) и скомпилить библиотеки из старого квартуса в него. 
Попытка скомпилить библиотеки только для Cyclone II из квартуса 13.0sp1 для ModelSim-IntelFPGA Edition успеха не принесла, ибо квартус говорит, что ModelSim-IntelFPGA Edition уже содержит в себе библиотеки (что есть правильно, но неправильно то, что он не содержит их все!)..

Share this post


Link to post
Share on other sites
3 минуты назад, AnatolySh сказал:

А если (удастся) перетащить библиотеки и старой версии  ModelSim-Altera Edition в ModelSim-IntelFPGA Edition - это может дать дополнительные плюшки?

Скорее нет.

 

4 минуты назад, AnatolySh сказал:

Как вариант установить свежую версию  ModelSim-а ("чистого", не Intel Edition-a) и скомпилить библиотеки из старого квартуса в него.

А вот это правильный путь! Вот тут плюшек будет много, главная - "чистый" ModelSim гораздо быстрее работает.

 

6 минут назад, AnatolySh сказал:

Попытка скомпилить библиотеки только для Cyclone II из квартуса 13.0sp1 для ModelSim-IntelFPGA Edition успеха не принесла, ибо квартус говорит, что ModelSim-IntelFPGA Edition уже содержит в себе библиотеки (что есть правильно, но неправильно то, что он не содержит их все!)..

Ну, при большой любви танцев с бубном можно попробовать сделать так - врукопашную вынести готовые библиотеки из папки modelsim_ae, затем скомпилировать туда библиотеку для старого семейства, и затем вернуть новые библиотеки обратно. Сработает это или нет - надо проверять.

Share this post


Link to post
Share on other sites
5 minutes ago, StewartLittle said:

"чистый" ModelSim гораздо быстрее работает

Почему, если не секрет?
Раз уж мы заговорили про "чистый" ModelSim: кто из них чище, и чем отличаются его версии: SE, DE, PE и прочие (если есть)?
Или вопрос смысла не имеет, если в закромах лежит только одна версия: её и надо пользовать? )
 

Share this post


Link to post
Share on other sites
17 минут назад, AnatolySh сказал:

Почему, если не секрет?

Потому, что в OEM-версиях Mentor Graphics производительность принудительно урезает.

 

17 минут назад, AnatolySh сказал:

Раз уж мы заговорили про "чистый" ModelSim: кто из них чище, и чем отличаются его версии: SE, DE, PE и прочие (если есть)?
 

Сейчас самый край - это QuestaSim.

А что касается разный версий моделсима, то, ЕМНИП, самый простой - PE, самый навороченный - SE:

Цитата

ModelSim PE (Personal Edition) is the industry-leading, Windows-based simulator for VHDL, Verilog, or mixed-language simulation environments offering a very cost effective solution for RTL and gate level simulation;

ModelSim DE (Deluxe Edition) includes full PE functionality plus PSL & SystemVerilog assertions, Code Coverage,  Enhanced Dataflow, Waveform Compare, and support for Xilinx SecureIP as standard;

ModelSim SE (System Edition) combines high performance and high capacity with the code coverageand debugging capabilities required to simulate larger blocks and systems and attain ASIC gate-level sign-off. ModelSim SE offers the ability to simulate very large designs.

Share this post


Link to post
Share on other sites
12 minutes ago, StewartLittle said:

Потому, что в OEM-версиях Mentor Graphics производительность принудительно урезает.

Т.е. производительность Modelsim (не ОЕМ) > производительности Modelsim (ОЕМ)  > производительности Modelsim (ОЕМ) Starter Edition?

12 minutes ago, StewartLittle said:

Сейчас самый край - это QuestaSim.

Т.е. если у меня стоит (поставленная когда-то для изучения) Questa, я могу смело сносить Modelsim любой версии и забыть про него, как о рудименте Quartus-а?

12 minutes ago, StewartLittle said:

А что касается разный версий моделсима, то, ЕМНИП, самый простой - PE, самый навороченный - SE:

Спасибо

Share this post


Link to post
Share on other sites
2 часа назад, AnatolySh сказал:

Т.е. производительность Modelsim (не ОЕМ) > производительности Modelsim (ОЕМ)  > производительности Modelsim (ОЕМ) Starter Edition?

Совершенно верно!

 

2 часа назад, AnatolySh сказал:

Т.е. если у меня стоит (поставленная когда-то для изучения) Questa, я могу смело сносить Modelsim любой версии и забыть про него, как о рудименте Quartus-а?

Да, только не забудьте альтеровские библиотеки под квесту скомпилировать. Это надо будет делать каждый раз при обновлении квартуса или квесты.

Ну и еще один неприятный момент - квеста может "стучать" правообладателю об использовании нелицензионной версии. Так что в этом плане тоже нужно будет меры принимать.

Share this post


Link to post
Share on other sites
On 11/8/2018 at 9:19 PM, StewartLittle said:

Да, только не забудьте альтеровские библиотеки под квесту скомпилировать. Это надо будет делать каждый раз при обновлении квартуса или квесты.

Это понятно. Немного повозиться пришлось, чтобы понять, как в МоделСим затащить эти библиотеки.

On 11/8/2018 at 9:19 PM, StewartLittle said:

Ну и еще один неприятный момент - квеста может "стучать" правообладателю об использовании нелицензионной версии. Так что в этом плане тоже нужно будет меры принимать

Примем, ели намекнёте, по каким адресам она стучит?
Да, даже, если и стучит, то что с того?

Share this post


Link to post
Share on other sites

StewartLittle уже ответил по существу вопроса, поэтому осталось уточнить - что хотите симулировать?

Если простой RTL плюс минимальные IP-ядра (PLL, LPM), то поддержка конкретного семейства в Modelsim и вовсе не нужна, т.к. модели поведенческие.

 

Если это воронежские ПЛИС, то симулировать, насколько я понимаю, будете простой RTL. Синтез, кстати, должен быть под какой-то старый Stratix (если я правильно помню тамошний workflow).
 

Quote


Примем, ели намекнёте, по каким адресам она стучит?
Да, даже, если и стучит, то что с того? 

 

Домой не придут (случаев пока не наблюдалось), а в контору могут как минимум написать письмо из серии "не купите лицензию - передадим куда следует" (было такое с AWR Microwave Office). Если инициатива лично Ваша - могут быть последствия. От большинства проблем спасает доступ в интернет через прокси с паролем.

Share this post


Link to post
Share on other sites
On 12/16/2018 at 4:06 PM, hdl_student said:

От большинства проблем спасает доступ в интернет через прокси с паролем.

Так вот он зачем нужен-то!!! Наконец-то пояснили ))))

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now