Jump to content

    

проблемы с прошивкой МК

Периодически слетает прошивка МК Atmega16.

Иногда удается залить по новой. Иногда нет.

Шью AVRPROG. При стирании МК программа ошибок не выдает.

А при записи "address: 0x0000 expected: 0xffff received: 0x00c4"

Не могу понять что с МК?

 

Edited by messenger

Share this post


Link to post
Share on other sites

Слетает ? Возможные причины:

0. Выбросы в интерфейсных линиях, "добирающиеся" до GPIO микроконтроллера.

1. Выбросы в линии питания, например, из-за некорректной разводки платы или схемотехники питающего плату БП.

2. Мощная радиопомеха.

3. Незадемпфированная индуктивность, находящаяся где-то рядом, например, обмотка реле, контактора, незадемпфированная первичка трансформатора, от которого питается схема, и проч.

4. Неисправен сам МК. Но это вряд ли, я такой неисправности еще не видел ...

Share this post


Link to post
Share on other sites

Обдумаю перечисленные варианты. 

Как думаете, что может означать ошибка выдаваемая программатором "address: 0x0000 expected: 0xffff received: 0x00c4"

Share this post


Link to post
Share on other sites
6 minutes ago, messenger said:

Обдумаю перечисленные варианты. 

Как думаете, что может означать ошибка выдаваемая программатором "address: 0x0000 expected: 0xffff received: 0x00c4"

Стертая память должна содержать 0xffff, получается, что или не стерлась или уже что-то записалось после стирания.

Share this post


Link to post
Share on other sites

у двух разных серийных плат фиксирую такой результат.

Проверил что все ноги SPI не имеют лишних сигналов.

Я не понимаю как такое вообще может быть.

Это же не фьюз биты?

Share this post


Link to post
Share on other sites

Содержимое Flash может разрушаться весьма разнообразно, и совсем не обязательно после разрушения там будут все 0xFF. Еще раз, смотрите в сторону некорректной разводки ПП, помех и проблем с питанием вроде "иголочек" в линии питания ...

Share this post


Link to post
Share on other sites
On 10/2/2018 at 10:45 PM, messenger said:

. . . Я не понимаю как такое вообще может быть. . . .

 

1. Замените для проверки источник питания программатора и процессора на аналоговый или даже батарейный, с достаточным током. И правильным напряжением.

Возможно причина в импульсном преобразователе источника питания, а точнее мощной помехе от него (по линиям питания и не только).

У меня аналогичная ситуация была с STM32. 

2. Прошейте Вашим программатором другую плату и другим программатором Вашу плату.

3. Если используется USB - замените кабель на заведомо "правильный" с минимальной длиной (для проверки достаточно "хвостик" 10-30 см.)

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this