Jump to content

    

Добавление 3D Моделей в ЦБ

В обычном маршруте (без EDM Library) можно добавить 3D модели к компонентам используя следующую последовательность:

1. Добавляете компонент на схему\плату в тестовый проект, к которому подключена данная ЦБ.

2. Импортируете 3D модель внутри Cell Editior внутри проекта (ПКМ>Edit_Selected_Cell на выбранной ячейке в топологии).

3. Обновляете ЦБ из проекта (3D>Models>Update_Library)

В результате модель(и) и привязка(и) оказывается в ЦБ и соответственно во всех проектах, где будет использована данная ЦБ.

Если новый компонент(ы) должен иметь такую же модель, как уже существующий привязанный в ЦБ, то можно разместить в тестовом проекте оба этих компонента и затем через 3D>Models>Manage_Mappings скопировать привязку модели. Далее обновить ЦБ (3D>Models>Update_Library).

Share this post


Link to post
Share on other sites

Добрый день, коллеги, обнаружилась странная ситуация, установил VX2.3, все работает, но при нажатии кнопки Add 3D view происходит как бы загрузка 3D, но при этом экран на закладке 3D остается белым, не видно ни борта,ни компонентов, хотя, курсор показывает наличие детали. Есть у кого-нибудь мысли, в чем дело? Спасибо за ответ.

Share this post


Link to post
Share on other sites
17 hours ago, Roman53 said:

Добрый день, коллеги, обнаружилась странная ситуация, установил VX2.3, все работает, но при нажатии кнопки Add 3D view происходит как бы загрузка 3D, но при этом экран на закладке 3D остается белым, не видно ни борта,ни компонентов, хотя, курсор показывает наличие детали. Есть у кого-нибудь мысли, в чем дело? Спасибо за ответ.

Как вариант проблема с поддержкой OpenGL видео карточкой.

Share this post


Link to post
Share on other sites

Вот получил ответ с Ментора, все заработало, может, кому-то пригодится

Windows 10

 

Some machines such as the Dell Precision laptops with NVIDIA graphics cards may show a black 3D window with their default 3D settings. The toolbars in the 3D window will still be present, but the board display area is black.

 

  1. Open Windows' Control Panel > NVIDIA Control Panel > 3D Settings > Manage 3D Settings
  2. Change the Global Presets setting to 3D App - Global Default Settings.
  3. Change the Preferred Graphics Processor setting to High-performance NVIDIA processor and click Apply.
  4. Reboot your computer. 
  5. Open PADS Layout, load a design and open the 3D window.
 

Share this post


Link to post
Share on other sites

Добрый день.

Столкнулся со следующим моментом.

При добавлении моделей некоторых деталей, сталкиваюсь со следующим моментом:  в меню "Aligin 3D Model" оказываются не доступными кнопки "Search", "Import". Соответственно модель не добавить.

Никак не могу понять закономерность, из-за чего такое происходит. Вроде и имена проверил и названия.... К части деталей модель добавляется, к части нет.

Share this post


Link to post
Share on other sites
5 hours ago, cniism said:

Добрый день.

Столкнулся со следующим моментом.

При добавлении моделей некоторых деталей, сталкиваюсь со следующим моментом:  в меню "Aligin 3D Model" оказываются не доступными кнопки "Search", "Import". Соответственно модель не добавить.

Никак не могу понять закономерность, из-за чего такое происходит. Вроде и имена проверил и названия.... К части деталей модель добавляется, к части нет.

Обратите внимание на Тип Ячейки. Например Edge Connector естественно не может иметь 3D модель.

Share this post


Link to post
Share on other sites
3 hours ago, fill said:

Обратите внимание на Тип Ячейки. Например Edge Connector естественно не может иметь 3D модель.

Кроме того, такое может происходить, если ячейка не привязана к part

Share this post


Link to post
Share on other sites

Спасибо. У меня стоял именно Edge Connector, я так понимаю его сделали из соображения что он расположен с краю.

Не подскажите что подразумевается под Edge Connector?

Share this post


Link to post
Share on other sites
1 hour ago, cniism said:

Спасибо. У меня стоял именно Edge Connector, я так понимаю его сделали из соображения что он расположен с краю.

Не подскажите что подразумевается под Edge Connector?

как я понимаю это разъём состоящий только из контактных площадок после травления меди на краю платы (ламели PCI на видео карте) 

Share this post


Link to post
Share on other sites
12 minutes ago, Frederic said:

как я понимаю это разъём состоящий только из контактных площадок после травления меди на краю платы (ламели PCI на видео карте) 

Спасибо.

Никогда не делали такие разъемы как элемент.

 

Share this post


Link to post
Share on other sites

А как после апдейта библиотеки из платы убедиться в том, что в библиотеке присутствуют 3D-модели? Вроде как открываю Library Manager а у него(и у Cell Editor) 3D посмотреть нигде нельзя. Как-то можно в Cell Editor, вызванного из обычного Library Manager, включить меню 3D и 3D View?

Share this post


Link to post
Share on other sites
1 час назад, keln сказал:

А как после апдейта библиотеки из платы убедиться в том, что в библиотеке присутствуют 3D-модели? Вроде как открываю Library Manager а у него(и у Cell Editor) 3D посмотреть нигде нельзя. Как-то можно в Cell Editor, вызванного из обычного Library Manager, включить меню 3D и 3D View?

Вообще-то нормальный процесс подразумевает, что библиотекарь прежде чем выложить библиотеку для всех остальных, должен проверить сделанные компоненты на тестовом пример.

Соответственно, достаточно сделать тестовый проект, накидать на схему эти компоненты, аннотировать в топологию и убедится что 3D модели загрузились автоматом.

Другой вариант, это просто посмотреть в папки 3DModels\PartDB\Packages\User и 3DModels\PartDB\User - появились ли там подпапки с соответствующими именами.

Share this post


Link to post
Share on other sites

Не подскажете:

1) что это за маркеры у 3D компонентов в виде пирамид сверху и снизу, для чего они нужны?

2) почему у некоторых компонентов они присутствуют а у некоторых их нет?

3) что за буквы-символы у них на гранях, в большинстве случаев - L, в некоторых - F?

Share this post


Link to post
Share on other sites
9 minutes ago, keln said:

3) что за буквы-символы у них на гранях, в большинстве случаев - L, в некоторых - F?

L - locked, F - fixed.

Share this post


Link to post
Share on other sites

А можно как-то убрать 3D модель с посадочного места, чтобы во вкладке 3D View Xpedition было только посадочное место, без каких-либо 3D объектов и соотвественно при импорте в step-файл было тоже пустое посадочное место? Простым удалением удаляется также и посадочное место.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now