Jump to content

    
Sign in to follow this  
Andbiz

Усилитель Hyundai Kia AMP-180AM

Recommended Posts

Здравствуйте, уважаемые форумчане. Вопрос не разработки, а ремонта. Столкнулся с отладкой аудиопроцессора STA308A в штатном усилителе Hyundai Kia AMP-180AM.

Ситуация следующая - аудиосигнал входит в аудиопроцессор STA308A, но не выдается на его выхода.

IMG_4667.jpg

IMG_4668.jpg

IMG_4673.jpg

Даташит STA308A https://img.ozdisan.com/ETicaret_Dosya/434346_8230513.pdf

Режимы ST-BY, MUTE на магнитоле не включены, REMOTE подан.

Следующие сигналы на процессоре имеются:

- 15 (POWER_ON_RST);

- 64 (PWRDWN);

- 20 (XTI) тактовые импульсы;

- 10 (LRCK) тактовые импульсы

Связь EEPROM 24C16 - процессор STA308 имеется. Прошивку EEPROM 24C16 проверял - с ней все нормально (сравнивал с прошивкой другого усилителя. Прошивки один в один, т.е. прошивка и неисправность EEPROM исключается.

Смотрел обмен по шине I2C. Но он есть кратковременный только при включении усилителя. Дальше на шине наступает тишина.

image.jpg

 

Ссылка на логи при включении:

untitled.txt

Master mute register (0x09) не включен. В даташите есть строка: "The master mute when set to 1 will mute all channels"

 

Master volume register (0x0A) соответствует +0dB:

 

1.419097250000000,16,0x40,0x0A,Write,ACK
1.419386125000000,16,0x40,0x00,Write,ACK

 

 

Channel 1 volume (0x0B) соответствует +0dB:

 

1.420071500000000,17,0x40,0x0B,Write,ACK
1.420361625000000,17,0x40,0x60,Write,ACK

 

 

В прочем все каналы установлены с нулевой громкостью (0 dB):

 

1.420071500000000,17,0x40,0x0B,Write,ACK
1.420361625000000,17,0x40,0x60,Write,ACK
1.421049500000000,18,0x40,0x0C,Write,ACK
1.421338375000000,18,0x40,0x60,Write,ACK
1.422026125000000,19,0x40,0x0D,Write,ACK
1.422316250000000,19,0x40,0x60,Write,ACK
1.423004125000000,20,0x40,0x0E,Write,ACK
1.423294125000000,20,0x40,0x60,Write,ACK
1.423982000000000,21,0x40,0x0F,Write,ACK
1.424273250000000,21,0x40,0x60,Write,ACK
1.424961125000000,22,0x40,0x10,Write,ACK
1.425248750000000,22,0x40,0x60,Write,ACK
1.425936625000000,23,0x40,0x11,Write,ACK
1.426225500000000,23,0x40,0x60,Write,ACK
1.426913375000000,24,0x40,0x12,Write,ACK
1.427202250000000,24,0x40,0x60,Write,ACK

 

 

Все регистры Channel X volume trim, mute, bypass настроены на +9-10 dB

 

1.427890000000000,25,0x40,0x13,Write,ACK
1.428180125000000,25,0x40,0x07,Write,ACK
1.428869125000000,26,0x40,0x14,Write,ACK
1.429158000000000,26,0x40,0x07,Write,ACK
1.429847125000000,27,0x40,0x15,Write,ACK
1.430137125000000,27,0x40,0x06,Write,ACK
1.430825000000000,28,0x40,0x16,Write,ACK
1.431115125000000,28,0x40,0x06,Write,ACK
1.431802875000000,29,0x40,0x17,Write,ACK
1.432094250000000,29,0x40,0x06,Write,ACK
1.432782000000000,30,0x40,0x18,Write,ACK
1.433070875000000,30,0x40,0x06,Write,ACK
1.433758750000000,31,0x40,0x19,Write,ACK
1.434048875000000,31,0x40,0x06,Write,ACK
1.434736625000000,32,0x40,0x1A,Write,ACK
1.435026750000000,32,0x40,0x06,Write,ACK

 

 

Т.е. получается что все каналы все же настроены на нулевой уровень громкости не смотря на отключенный режим Mute.

 

Сигнал REMOTE (ACC) на разъем приходит и отслежен до тех пор, пока не уходит во внутрение слоя платы.

Сигнал MUTE - проверил подачей 12 В на вывод разъема - процессор даже не стартует, TDA7560 - 0.3 В на муте, т.е. вошла в этот режим.

Процессор не стартует и логи состоят из двух строчек

 

0.758600875000000,0,0x40,0x08,Write,ACK
0.758889750000000,0,0x40,0x80,Write,ACK

 

При отключенном REMOTE (не подача питания +12 В) - усилитель не стартует, логов нет.

 

Т.е. режимы работают нормально.

 

Можно ли как-то из логов узнать причину, по которой STA308A не стартует и устанавливает уровень громкости по всем каналам равной 0?

Share this post


Link to post
Share on other sites
...все каналы установлены с нулевой громкостью (0 dB)...

0 dB это без изменения от входа к выходу, а не нулевая громкость ("громкость в ноль")

Share this post


Link to post
Share on other sites
Ситуация следующая - аудиосигнал входит в аудиопроцессор STA308A, но не выдается на его выхода.

Т.е. на выходах DDX нет ШИМ? Или где?

 

Можно ли как-то из логов узнать причину, по которой STA308A не стартует и устанавливает уровень громкости по всем каналам равной 0?

Уровень громкость видимо записан в EEPROM по умолчанию, аудиопроцессор читает его от туда и устанавливает.

Чтобы узнать почему не стартует, надо подключится к нему по I2C, считать значения регистров и проверить правильность по даташиту.

Share this post


Link to post
Share on other sites

Давно не заходил на форум. Отвечаю с опаздыванием по этой ситуации. На всякий случай. 

Это оказались логи нормальной работы усилителя. Входа логического анализатора подтянуты на питание. При подключения анализатора к RESET усилителя, последний работал нормально. При отключении - тишина. В результате оказался обрыв подтягивающего сопротивления RESET на плате усилителя.

Share this post


Link to post
Share on other sites
В 16.10.2018 в 10:28, Andbiz сказал:

Давно не заходил на форум. Отвечаю с опаздыванием по этой ситуации. На всякий случай. 

Это оказались логи нормальной работы усилителя. Входа логического анализатора подтянуты на питание. При подключения анализатора к RESET усилителя, последний работал нормально. При отключении - тишина. В результате оказался обрыв подтягивающего сопротивления RESET на плате усилителя.

Добрый день! У меня аналогичная проблема. Не могли бы подсказать более подробной как ее решить, что необходимо заменить или перепаять желательно на фото. Заранее спасибо!

Share this post


Link to post
Share on other sites
On 3/18/2019 at 3:09 PM, toxa.belyi said:

Добрый день! У меня аналогичная проблема. Не могли бы подсказать более подробной как ее решить, что необходимо заменить или перепаять желательно на фото. Заранее спасибо!

Добрый день. Вот подробное описание диагностики и ремонта усилителя Hyundai Kia AMP-180AM https://easywork.com.ua/usilitel-hyundai-kia-amp-180am-net-zvuka.html Резистор 10 кОм необходимо прозвонить от вывода аудиопроцессора. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this