Перейти к содержанию

    

KSZ8895RQX потеря пакетов

Обычно порядок подачи напряжений от самого большого к самому низкому. Или, хотя бы, чтобы более высокое всегда было больше, чем более низкое, дабы обратные диоды в структуре кристалла не открылись.

Микрел говорит, что для сабжа порядок не важен, но береженого бог бережет.

 

Интервала как такового не требуется, но к моменту окончания сигнала RESET оба напряжения должны быть в норме. Честно говоря, я всегда использовал встроенный регулятор.

 

Значит тут все нормально.

 

Конденсаторы C27-C30 (и остальные аналогичные) по вашей схеме - почему 22пФ? Там 0.1мкФ должны быть или вообще убрать, чтоб не мешались.

Трансформатор, который указан на вашей схеме, вроде как для гигабитной сети. Зачем такое?

 

Попробовал вручную подать 3.3, и сразу же 1.2, результата нет. По поводу 22пф, верно подмечено, уже не помню точно, но такие конденсаторы применял. Сейчас убрал их совсем - результат тот же. Попробовал убрать еще и резисторы от средних точек - ничего.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Попробовал вручную подать 3.3, и сразу же 1.2, результата нет. По поводу 22пф, верно подмечено, уже не помню точно, но такие конденсаторы применял. Сейчас убрал их совсем - результат тот же. Попробовал убрать еще и резисторы от средних точек - ничего.

1) Страпом (нога 101) задайте свичу генерировать 50МГц для RMII и осциллографом померьте там частоту на 60 ножке (чтобы щуп не влиял). Симптомы слишком характерны для кварца.

2) Выясните что именно не работает: прием, передача, оба направления, один порт или все. В общем, попытайтесь локализовать проблему.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1) Страпом (нога 101) задайте свичу генерировать 50МГц для RMII и осциллографом померьте там частоту на 60 ножке (чтобы щуп не влиял). Симптомы слишком характерны для кварца.

2) Выясните что именно не работает: прием, передача, оба направления, один порт или все. В общем, попытайтесь локализовать проблему.

 

На 60 ноге стоял - 50мгц есть. Порты работают все, линк есть на всех. Если стоять на дифф парах, причем мне важно RX или TX - сигнал есть. Уровень и форма сигнала соответствуют эталонным девайсам (свитч, пк).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
На 60 ноге стоял - 50мгц есть.

Частота должна быть в диапазоне 49.995 до 50.005. Это так?

 

Порты работают все, линк есть на всех. Если стоять на дифф парах, причем мне важно RX или TX - сигнал есть. Уровень и форма сигнала соответствуют эталонным девайсам (свитч, пк).

Я предлагаю вам выяснить, что именно плохо работает: прием или передача? Посмотрите в счетчики свича, например. И потом уже копайте это направление.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Частота должна быть в диапазоне 49.995 до 50.005. Это так?

 

 

Я предлагаю вам выяснить, что именно плохо работает: прием или передача? Посмотрите в счетчики свича, например. И потом уже копайте это направление.

 

Частотомера нет, а осцил не всегда правильно показывает, но из того что смог замерить, частота от 49.98 до 50.05, большую часть времени держится 50 ровно, редко скачет до 50.05, а менее 50 пару раз в минуту. Кажется на данный момент перепробовал уже все.

 

З.Ы А как можно определить что плохо работает? Сигналы на Tx и Dx по форме одинаковы, т.е он что то принимает и что то отправляет, только вот как узнать что? По поводу счетчиков, не смог найти такого.

 

По итогу: Менял микросхему, снимал трансформатор, несколько раз менял кварц и совсем убирал его кондеры, убирал всю обвязку трансформатора, запитывал свитч от батарейки, соединял опорную землю до трансформатора с основной землей, менял местами Rx Tx, меня в диф парах + и - местами, отключал MDI-X, пробовал сначала подать 3.3 и сразу же 1.2в питания (вручную), менял номинал резистра на ISET (по даташиту 12.4кОм) ставил подстроечник, и ничего из этого не дало практически никакого результата, единственное после впайки кварца с материнки ПК немного улучшилась передача из 10 в 100, доходит примерно 15% пакетов. Сегодня попробовал тактировать кварцевым генератором на 25Мгц, но генератор на 5в, а при запитке от 3.3. уже нет синусоиды, запустить не удалось.

 

Из оставшихся вариантов - купить микруху из другой партии, либо заказать плату на заводе, но даст ли это положительный результат неизвестно. Всем спасибо за помощь, если будут еще какие либо идеи буду благодарен.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
З.Ы А как можно определить что плохо работает? Сигналы на Tx и Dx по форме одинаковы, т.е он что то принимает и что то отправляет, только вот как узнать что? По поводу счетчиков, не смог найти такого.

В даташите на свич, регистры MIB. Там есть куча всяких счетчиков по каждому порту: количество принятых пакетов, количество принятых битых пакетов, количество отправленных и т.д. Кроме того, каждому порту можно провести Cable diagnostic test и по результатам выдвинуть какие-то предположения.

PS. На этом сеанс телепатии завершаю

Изменено пользователем LightElf

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вообщем пришла плата с завода, с немного другой разводкой и все работает хорошо. В чем была проблема так и останется тайной. Возможно изготовленная ЛУТОМ плата имела непротравы..

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти