Jump to content

    

Обсуждение Library Manager

Recommended Posts

PBO
Just now, pavor said:

Еще вопрос в ту же тему. А что значит сообщение:

 

Ошибка удаления2.jpg

Возможно из за того что вы что-то не то удалили в структуре библиотеки

 

 

Share this post


Link to post
Share on other sites

pavor

Думаю, что нет. Это я достал библиотеку из бекаппа, где еще ничего не удалял, стал отвязывать ячейки от компонентов и когда пробуешь удалить не привязанную ячейку, она так ругается.

Но так ругаются не все ячейки, некоторые просто удаляются.

Edited by pavor

Share this post


Link to post
Share on other sites

Frederic
28 minutes ago, pavor said:

Думаю, что нет. Это я достал библиотеку из бекаппа, где еще ничего не удалял, стал отвязывать ячейки от компонентов и когда пробуешь удалить не привязанную ячейку, она так ругается.

Но так ругаются не все ячейки, некоторые просто удаляются.

 

а зачем отвязывать Cell ? Part без Cell не имеет смысла держать в ЦБ 
удалите Part и Cell освободиться для удаления

Share this post


Link to post
Share on other sites

pavor
15 часов назад, Frederic сказал:

а зачем отвязывать Cell ? Part без Cell не имеет смысла держать в ЦБ 
удалите Part и Cell освободиться для удаления

Cell из раздела который нужно удалить были скопированы  в другие разделы, то есть есть дубликаты и соответственно Part удалять не желательно.

Вопрос решился. Скорее всего проблема была не в библиотеке. Скопировал эту библиотеку на другой ПК и там, сразу и без проблем все удалилось.

Всем спасибо за помощь.

Share this post


Link to post
Share on other sites

pavor

Добрый день.

Ситуация: создал символ элемента, создал Cell элемента, собрал их в компонент (Part). Разместил на схеме. И вроде все хорошо. Стал более глубоко читать мануал на элемент и оказалось, что один из выводов должен быть инверсным.

В символе элемента изменил имя на инверсное добавив в начале ~.  Разумеется пошел в Part Edit поправить привязку пина символа к ячейке. Просто изменить имя не дает. Хорошо, удаляю Элемент в Part Edit. Создаю новый с таким же именем. Пытаюсь сохранить и получаю ошибку ( Смотри ниже.)

В чем может быть ошибка и как ёе исправить??

Error.jpg.a4b67819ca6cadb66c83c769d5dec1f1.jpg

Share this post


Link to post
Share on other sites

PBO
2 minutes ago, pavor said:

Добрый день.

Ситуация: создал символ элемента, создал Cell элемента, собрал их в компонент (Part). Разместил на схеме. И вроде все хорошо. Стал более глубоко читать мануал на элемент и оказалось, что один из выводов должен быть инверсным.

В символе элемента изменил имя на инверсное добавив в начале ~.  Разумеется пошел в Part Edit поправить привязку пина символа к ячейке. Просто изменить имя не дает. Хорошо, удаляю Элемент в Part Edit. Создаю новый с таким же именем. Пытаюсь сохранить и получаю ошибку ( Смотри ниже.)

В чем может быть ошибка и как ёе исправить??

Error.jpg.a4b67819ca6cadb66c83c769d5dec1f1.jpg

В символе тильды, удалите ее и вместо этого используйте свойство Пина inverted

Share this post


Link to post
Share on other sites

pavor

Да, это вариант.

И все таки как можно, корректно и правильно, внести изменение имени в существующем символе/элементе?

 

 

Прошу прощения, вопрос снимается. Нашел встроенную защиту "от дурака" (От случайного/намеренного изменения) элементов.

Нужно не напрямую в символе править, а воспользоваться инструментом Modify Cell & Sumbol Pins...

Edited by pavor

Share this post


Link to post
Share on other sites

PBO
15 minutes ago, pavor said:

Да, это вариант.

И все таки как можно, корректно и правильно, внести изменение имени в существующем символе/элементе?

 

 

Прошу прощения, вопрос снимается. Нашел встроенную защиту "от дурака" (От случайного/намеренного изменения) элементов.

Нужно не напрямую в символе править, а воспользоваться инструментом Modify Cell & Sumbol Pins...

Да, именно так, вы правы 

Share this post


Link to post
Share on other sites

PBO
3 hours ago, SII said:

Есть ли прямая возможность затащить ЦБ, сделанную в Экспедишне, в PADS Pro?

Через export edx из либы Xpedition и импорт edx в либу pads pro. 
так же для pads pro есть бесплатная лицензия, которая позволяет напрямую читать библиотеки от Xpedition 

Share this post


Link to post
Share on other sites

SII
9 minutes ago, PBO said:

так же для pads pro есть бесплатная лицензия, которая позволяет напрямую читать библиотеки от Xpedition 

А как её заполучить?

Share this post


Link to post
Share on other sites

PBO

Написать в поддержку.

Если вы недавно купили , то вам они скоро отгрузятся. Но эта лицензия позволяет только читать библиотеку, то есть можно размещать компоненты упаковывать , но изменить их в pads library tools вы не сможете . Для изменения нужно использовать метод описанный выше 

Share this post


Link to post
Share on other sites

Faris

Здравствуйте!

У меня проблема с библиотекой. V2.10

После нескольких циклов записи библиотеки на флешку и обратно получилась вот такая ситуация:

Вчера создавал Компонент (Part), сегодня открываю библиотеку – этого компонента нет. Создаю его по-новой и при попытке сохранения выводится сообщение, что такой компонент уже существует и, поэтому, не сохраняет. Закрываю редактор, смотрю в списке компонентов – и снова не нахожу этого компонента.

Подскажите, в чем может быть проблема?

Share this post


Link to post
Share on other sites

makc

Попробуйте сделать реиндексацию библиотеки путем удаления SysIndex.cbf и повторного запуска Library Manager.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.