Перейти к содержанию

Установка Q17.1 на Linux

Привет Всем!
На виртуалке стоит Linux Mint. Хочу туда поставить Q17. В связи с этим появились вопросы:
- по какому пути лучше ставить? Может завести отдельный диск?
- есть ли какие-нибудь особые моменты при установке?

PS: в оф. документации отмечается Red Hat'подобный linux и для него:
window X libraries: make, libX11.i686, libXau.i686, libXdmcp.i686,
libXext.i686, libXft-devel.i686, libXft.i686, libXrender.i686, libXt.i686, and
libXtst.i686.
— GIMP toolkit: GTK+2.
А у меня Минт, мне то что делать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
а Вам есть разница какой линукс, раз Вы на виртуалке???

я бы поставил RHEL/CentOS, затем:

Код
sudo yum install -y make libX11.i686  libXau.i686 libXdmcp.i686 libXext.i686 libXft-devel.i686 libXft.i686 libXrender.i686 libXt.i686 libXtst.i686

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(Fynjisx @ May 2 2018, 00:18) <{POST_SNAPBACK}>
Привет Всем!
На виртуалке стоит Linux Mint. Хочу туда поставить Q17. В связи с этим появились вопросы:
- по какому пути лучше ставить? Может завести отдельный диск?
- есть ли какие-нибудь особые моменты при установке?

PS: в оф. документации отмечается Red Hat'подобный linux и для него:
window X libraries: make, libX11.i686, libXau.i686, libXdmcp.i686,
libXext.i686, libXft-devel.i686, libXft.i686, libXrender.i686, libXt.i686, and
libXtst.i686.
— GIMP toolkit: GTK+2.
А у меня Минт, мне то что делать?

В большинстве современных дистрибутивов эти библиотеки уже установлены. Вслучае чего всегда можно доустановить, но только лучше по названиям без расширений. Ибо расширения, могут различаться у разных дистрибутивов.

Цитата(Doka @ May 3 2018, 20:48) <{POST_SNAPBACK}>
а Вам есть разница какой линукс, раз Вы на виртуалке???

я бы поставил RHEL/CentOS, затем:

Код
sudo yum install -y make libX11.i686  libXau.i686 libXdmcp.i686 libXext.i686 libXft-devel.i686 libXft.i686 libXrender.i686 libXt.i686 libXtst.i686

Смысл?

Всё это нормально работает и так. Я проверял на AltLinux, Минте, openSuse, Debian.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(wolfman @ May 3 2018, 22:47) <{POST_SNAPBACK}>
Вслучае чего всегда можно доустановить, но только лучше по названиям без расширений. Ибо расширения, могут различаться у разных дистрибутивов.

то, что вы называете расширением - на самом деле архитектура,
и если в зависимостях указан пакет на i686, то именно он нужен тулу для запуска,

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(Doka @ May 4 2018, 19:22) <{POST_SNAPBACK}>
то, что вы называете расширением - на самом деле архитектура,
и если в зависимостях указан пакет на i686, то именно он нужен тулу для запуска,

У SUSE, Alta, да и, помоему минта, есть 64-х разрядные пакеты x86_64 и 32-х разрядные i586.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(Doka @ May 3 2018, 15:18) <{POST_SNAPBACK}>
а Вам есть разница какой линукс, раз Вы на виртуалке???

Ну, вообщем да. Mint как-то попривычней.
Цитата(Doka @ May 3 2018, 15:18) <{POST_SNAPBACK}>
я бы поставил RHEL/CentOS, затем:

Код
sudo yum install -y make libX11.i686  libXau.i686 libXdmcp.i686 libXext.i686 libXft-devel.i686 libXft.i686 libXrender.i686 libXt.i686 libXtst.i686

Да, я поставил CentOS. В нем запускается.

Цитата(wolfman @ May 3 2018, 23:47) <{POST_SNAPBACK}>
Всё это нормально работает и так. Я проверял на AltLinux, Минте, openSuse, Debian.

Да чётто как-то...Понимаете на Mint поставил но некоторые виджеты не прорисовываются. К примеру границы кнопок диалоговых панелей, пиктограммочки раскрытия в дереве(вот куда надпись Fitter пропала?), в настройках когда встаешь на нужный параметр он исчезает (License Setup)/. Чего- то не хватает. Притом Минт 18.3.
Еще заметил такую фишку, когда что-то одно в системе начинает выполняться вся система становится неотзывчивой. В виртуалке 4 ядра поставил, памяти 4ГБ и вот результат -> Один поток на всю систему!. Или Linux шустрым становится, когда его без всяких виртуальных выкрутасов ставишь?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(Fynjisx @ May 5 2018, 13:45) <{POST_SNAPBACK}>
...некоторые виджеты не прорисовываются...

у кваКтуса гуйовины через Qt прорисовываются, если запускаете его из консоли - посмотрите на то какие Err/Warn выдаёт, станет понятно что именно ему не нравится.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
У меня на Ubuntu всё абсолютно без проблем. Может сменить стиль оформления системы? Настроить через Qt Config?
Подозреваю из-за попытки применить системный стиль что-то отъезжает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Стоит на нескольких машинах под Arch/Manjaro, везде все работает нормально, но есть неприятный глюк с хелпом - он не работает. Просто ничего не происходит при вызове хелпа через меню, или же при клацании по описанию варнинга. Никто не сталкивался?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(R6L-025 @ May 9 2018, 13:11) <{POST_SNAPBACK}>
Стоит на нескольких машинах под Arch/Manjaro, везде все работает нормально, но есть неприятный глюк с хелпом - он не работает. Просто ничего не происходит при вызове хелпа через меню, или же при клацании по описанию варнинга. Никто не сталкивался?

Если при этом в консоли выскакивают сообщения про "GLIBCXX__$Version not found", то это из-за того, что квартус тащит с собой старую версию libstdc++. Лечится простым удалением квартусовской версии библиотеки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Спасибо, посмотрю внимательнее на вывод

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти