Jump to content

    
Sign in to follow this  
Roma_ne

SIM868 - проблема SIM not inserted

Recommended Posts

Добрый день, всем!

Случилась беда: начал работать с SIM868, и с каждым днем мне все хуже и хуже.

Вобщем проблема такая. При включении устройства лампочка Netlight моргает с периодом 800мс (не зарегистрирован в сети), спустя некоторое время она уже моргает стабильно с периодом 3 сек (зарегистрирован в сети), правда стоит оговориться, что нет нет да и моргает через 800мс. При этом на запрос: AT+CPIN? стабильно выдает: SIM not inserted.

Рядом лежит отладка на SIM800, так там без сим-карты стабильно моргает с периодом 800мс. А на SIM868 какая то черезполосица. Хотелось бы послушать мнение специалистов, которые уже много времени повозились с этим модулем.

 

Share this post


Link to post
Share on other sites

На всякий случай бросил вчера всю плату в ацетон. Не помогло. Поведение тоже самое - моргает переменно (то зарегистрирован в сети, то не зарегистрирован). При этом всегда сообщает, что SIM карта not inserted.

Share this post


Link to post
Share on other sites
На всякий случай бросил вчера всю плату в ацетон. Не помогло. Поведение тоже самое - моргает переменно (то зарегистрирован в сети, то не зарегистрирован). При этом всегда сообщает, что SIM карта not inserted.

По причине занятости или отсутствия телепатов и экстрасенсов - Вы бы схемку подключения карточки нарисовали . А там может кто то что то и подскажет . Цепи подключения карточек довольно привередливые к "разводке" питания и земли итд.

 

Share this post


Link to post
Share on other sites
Добрый день, всем!

Случилась беда: начал работать с SIM868, и с каждым днем мне все хуже и хуже.

Вобщем проблема такая. При включении устройства лампочка Netlight моргает с периодом 800мс (не зарегистрирован в сети), спустя некоторое время она уже моргает стабильно с периодом 3 сек (зарегистрирован в сети), правда стоит оговориться, что нет нет да и моргает через 800мс. При этом на запрос: AT+CPIN? стабильно выдает: SIM not inserted.

Рядом лежит отладка на SIM800, так там без сим-карты стабильно моргает с периодом 800мс. А на SIM868 какая то черезполосица. Хотелось бы послушать мнение специалистов, которые уже много времени повозились с этим модулем.

 

Добрый день!

мне пришли модули с второй сим картой по умолчанию. дал команду на смену сим карты, все заработало (AT+CDSDS=1)

Edited by Андрей190

Share this post


Link to post
Share on other sites
Добрый день!

мне пришли модули с второй сим картой по умолчанию. дал команду на смену сим карты, все заработало (AT+CDSDS=1)

 

По умолчанию 2, потому, что на тестах на производстве 2ю сим-карту проверяют после 1й.

С последних прошивок синтаксис CDSDS расширили. Обычно, CDSDS пишет по умолчанию параметр в память, т.е. при перезагрузке текущая сим-карта не сменится. Новый синтаксис AT+CDSDS=x[,0] , 0 - необязательный параметр, который говорит, что писать первый параметр в память не нужно. Это полезно при очень частой смене сим-карт, чтобы не нагружать NVM.

Edited by Цырен.

Share this post


Link to post
Share on other sites
По умолчанию 2, потому, что на тестах на производстве 2ю сим-карту проверяют после 1й.

С последних прошивок синтаксис CDSDS расширили. Обычно, CDSDS пишет по умолчанию параметр в память, т.е. при перезагрузке текущая сим-карта не сменится. Новый синтаксис AT+CDSDS=x[,0] , 0 - необязательный параметр, который говорит, что писать первый параметр в память не нужно. Это полезно при очень частой смене сим-карт, чтобы не нагружать NVM.

до этого использовал SIM900-DS и SIM800C-DS. там была 1 по умолчанию, поэтому и не сразу разобрался здесь в чем дело.

сейчас сначала проверяю какая СИМ карта установлена по умолчанию, а затем если нужно меняю.

Share this post


Link to post
Share on other sites

Аналогичная проблема с SIM-картой. Вставляю две симки, иногда не видит одну из них (запрашиваю командой AT+CDSDS?) Отключаю питание, включаю и симка обнаруживается. Т.е. физически нагар с контактов симки не соскабливаю, а она сама обнаруживается или не обнаруживается. Закономерность пока не нашёл. С чем может быть связано такое поведение? Команда  AT+CSDT ни на что не влияет.

Share this post


Link to post
Share on other sites

 

10 hours ago, ДЕЙЛ said:

Аналогичная проблема с SIM-картой. Вставляю две симки, иногда не видит одну из них (запрашиваю командой AT+CDSDS?) Отключаю питание, включаю и симка обнаруживается. Т.е. физически нагар с контактов симки не соскабливаю, а она сама обнаруживается или не обнаруживается. Закономерность пока не нашёл. С чем может быть связано такое поведение? 

С разводкой платы.

Share this post


Link to post
Share on other sites

Ваш ответ - SMS05C выбросить нахрен. Cогласно даташита рекомендовано ESDA6V1.

Более того еще и предупредили специально отдельной строчкой - Add some TVS with parasitic capacitance should not exceed 50pF

А вы что туда всунули? Номинальная емкость сборки 260pF, а максимальная 400.  Естественно там все фронты завалены до состояния ямок :)

Еще лучше поставить что-нибуть из защиты от USB. Там меньше 10pF обычно - идеальный вариант.

 

Ну и тогда при таком ляпусе показывайте и разводку - наверняка же GND в стороне от модуля на полигон воткнули.

 

Share this post


Link to post
Share on other sites
14 hours ago, ДЕЙЛ said:

SMS05C,  0.1 мк на питании, 22 Ома и 22 пФ на линии данных

 

попробуйте для конкретной "плохой симкарты"  удалить 0,1 по питания, а так же посмотреть не станет ли лучше работать при удалении 22 пик..

там есть ньюансы с некоторыми симкартами. Антенна у вас отдельная или на плате?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this