Jump to content

    

Intel Apollo Lake IoT вопросы

Занимаюсь запуском платы на Intel Apollo Lake IoT (семейство E39xx, в частности первая плата на E3940).

 

Уткнулись в следующую проблему: BIOS должен грузиться с SPI Flash, что и происходит. Но очень быстро все умирает, грузится только первый блок (4KByte, на самом деле даже меньше), содержащий параметры Flash памяти, SoftStraps и базовую конфигурацию периферийных устройств. После этого должен быть переход на загрузку BootLoader (address 0x1000), но этого не происходит.

 

Тот же самый BIOS продолжает загрузку как и должнО на 2-х демо платах: Oxbow Hill & Apollo Island. BIOSы с названных плат на нашей ведут себя также как и наш BIOS - затыкаются на начальном блоке.

 

Какие-нибудь идеи???

Share this post


Link to post
Share on other sites

Отличия есть в SCH и Layout в Вашем изделии в сравнении с Reference Design ?

Share this post


Link to post
Share on other sites
Отличия есть в SCH и Layout в Вашем изделии в сравнении с Reference Design ?

Конечно есть - иначе нафига бы мы это делали :biggrin:

Share this post


Link to post
Share on other sites
Конечно есть - иначе нафига бы мы это делали :biggrin:

Где изменено там и искать.

BIOS - это только прошивка или chip(Flash) с прошивкой(перестановка с платы на плату) ?

Share this post


Link to post
Share on other sites
Где изменено там и искать.

BIOS - это только прошивка или chip(Flash) с прошивкой(перестановка с платы на плату) ?

Не может быть!!!

Вопрос задан для тех, кто знает Интеловские процессоры, а не для произнесения пустых звуков. Sorry ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this