Jump to content

    
Sanchosd

2018 Вопросы начинающих

Recommended Posts

3 hours ago, Krake said:

От края платы до землянного полигона  и от края линии до землянного полигона

 

 

Да, такая ошибка есть. Никогда не обращал внимания. И вроде не мешало. Забейте. Вам оно надо? 

Share this post


Link to post
Share on other sites

Что-то количество ошибок в Altiume меня начинает озадачивать.

Из последних - после компиляции схемы в списке цепей вижу название сигналов с инверсией очень странными. Схему и плату импортировал из P-CAD. Теперь при попытке "Update PCB document...". Altium ругается на разные названия цепей. Ну почему спрашивается он их сделал неодинаковыми? И в плате они выглядят более привычными(правильными). Хотел перекинуть названия цепей из платы в схему, а он не дает!

1400312580_.thumb.png.fd2d1c2ed56143282f5468391c322533.png

 

После компиляции в списке нарушений, альтиум выдает unconnected line, выделяет участок шины.  Находил упоминание об этой ошибке в интернете.  Ошибка до сих пор не устранена и что делать непонятно. Не переходить же в самом деле на дюймовую систему.

Почему то некоторые разведенные LVDS, которых вроде не касался, опять начинают "глючить". То длина одной цепи в диф. паре уплыла. То signal length стала n/a. После того как сделал DRC проверку, все LVDS стали без ошибок. Чему верить?

Непонятно как информацию, которую я настроил в плате по Net class и диф парам перекинуть в схему? Опять никак?

Share this post


Link to post
Share on other sites
30 minutes ago, dinam said:

Не переходить же в самом деле на дюймовую систему.

Вообще-то те кто понимают источник проблемы именно так и делают. Не обязательно использовать единицы измерения mils. У меня миллиметры но шаг сетки 1.27мм, 2.54мм, 5.08мм. Главное чтобы он был кратен дюймам.

Share this post


Link to post
Share on other sites
3 минуты назад, uriy сказал:

Вообще-то те кто понимают источник проблемы именно так и делают. Не обязательно использовать единицы измерения mils. У меня миллиметры но шаг сетки 1.27мм, 2.54мм, 5.08мм. Главное чтобы он был кратен дюймам.

Просто когда переходишь с устаревшего программного продукта на более новый не ожидаешь таких детских болезней от нового продукта. Тем более производитель один и тот же.

Share this post


Link to post
Share on other sites

Кто-то в курсе, как в ActiveBOM отключить сортировку группировку по DesignItemID? Версия 20.0.2.

Одинаковые компоненты (конкретно - банальные блокировочные конденсаторы 100 нФ 0603) разделились на три группы. Несколько часов провозился, пока нашёл причину. Схема составлялась долго, в разных местах из трех разных библиотек. Сейчас-то привёл к "единому знаменателю"...

Share this post


Link to post
Share on other sites
1 час назад, dinam сказал:

после компиляции схемы в списке цепей вижу название сигналов с инверсией очень странными.

Ничего странного. Обратный слэш после символа будет отображаться как ""над этим символом.

Share this post


Link to post
Share on other sites
3 часа назад, Harbinger сказал:

Кто-то в курсе, как в ActiveBOM отключить сортировку по DesignItemID? Версия 20.0.2.

Одинаковые компоненты (конкретно - банальные блокировочные конденсаторы 100 нФ 0603) разделились на три группы. Несколько часов провозился, пока нашёл причину. Схема составлялась долго, в разных местах из трех разных библиотек. Сейчас-то привёл к "единому знаменателю"...

Клик по другому заголовку  столбцу-- будет по нему сортироваться.
Правый клик там же -- выбор сортировки

5 часов назад, dinam сказал:

Что-то количество ошибок в Altiume меня начинает озадачивать.

Из последних - после компиляции схемы в списке цепей вижу название сигналов с инверсией очень странными. Схему и плату импортировал из P-CAD. Теперь при попытке "Update PCB document...". Altium ругается на разные названия цепей. Ну почему спрашивается он их сделал неодинаковыми? И в плате они выглядят более привычными(правильными). Хотел перекинуть названия цепей из платы в схему, а он не дает!

1400312580_.thumb.png.fd2d1c2ed56143282f5468391c322533.png

 

После компиляции в списке нарушений, альтиум выдает unconnected line, выделяет участок шины.  Находил упоминание об этой ошибке в интернете.  Ошибка до сих пор не устранена и что делать непонятно. Не переходить же в самом деле на дюймовую систему.

Почему то некоторые разведенные LVDS, которых вроде не касался, опять начинают "глючить". То длина одной цепи в диф. паре уплыла. То signal length стала n/a. После того как сделал DRC проверку, все LVDS стали без ошибок. Чему верить?

Непонятно как информацию, которую я настроил в плате по Net class и диф парам перекинуть в схему? Опять никак?

1 в алтиум два типа поддержжки инверсии. У вас выбран возможно другой

2 вообще лучше от схемы работать.  Но из PCB Тоже можно. Но нужно чтобы проект был синхронизирован. Скорее всего у вас не так

3 Так переходите на дюймовую. Но в этом случае у вас не прокатит. Исходно похоже импортировано в миллиметрах

4 Там есть 2 длины , о какой речь идет? к тому же у правил есть приоритеты. Может кто передавливает

5. Классы создавайте в схеме. Из PCB Можно передать изменения, только если класс уже сделан на схеме.  Потому как на каком листе в каком месте и т.п разместить директивы Altium не знает

 

 

4 часа назад, dinam сказал:

Просто когда переходишь с устаревшего программного продукта на более новый не ожидаешь таких детских болезней от нового продукта. Тем более производитель один и тот же.

Это разные производители. Алтиум просто купил умирающий PCAD и не развивал его. Только добавил импорт в какой то степени

Share this post


Link to post
Share on other sites
27 минут назад, Владимир сказал:

Алтиум просто купил умирающий PCAD и не развивал его.

Я сказал бы, "купил, чтобы умертвить".

Share this post


Link to post
Share on other sites
1 час назад, Владимир сказал:

Клик по другому заголовку  столбцу-- будет по нему сортироваться.

Извиняюсь, неправильно выразился. Не сортировка, а группировка. Чтобы компоненты попали в одну группу, нужно, помимо совпадения выбранных параметров, иметь ещё и одинаковый DesignItemID, да ещё из одной и той же библиотеки  - и это не нашёл, как отключить. В предыдущих версиях такое не встречалось, может, просто повезло.

35 минут назад, ViKo сказал:

Я сказал бы, "купил, чтобы умертвить".

С ранее приобретённым Protel, который был взят за основу, он плохо скрещивался. А параллельно развивать два разных продукта сочли, по-видимому, нецелесообразным.

Share this post


Link to post
Share on other sites
9 минут назад, Harbinger сказал:

С ранее приобретённым Protel, который был взят за основу, он плохо скрещивался. А параллельно развивать два разных продукта сочли, по-видимому, нецелесообразным.

И они увидели, что купили, только после покупки? :prankster2: К тому же и транжиры.

Share this post


Link to post
Share on other sites

Так купили небось с большим дисконтом, или в самом деле деньги были лишние - авось пригодится? :pardon:

 

...Бодаюсь дальше с Draftsman. С одной из плат (пока единственной) попытка поместить на лист "board assembly view" приводит к вот такому сообщению:

 

draftsman_error.gif

Плата 4-слойная. Больше вроде никаких отличий от тех, которые транслируются без ошибок (они все 2-слойки, большинство импортировано из PCAD).

(upd) В 17.1.9 проблем нет. Спишем на "сырость" бета-версии.

Share this post


Link to post
Share on other sites
5 часов назад, Harbinger сказал:

 Не сортировка, а группировка.

группировка пможет быть по одному или нескольким параметрамimage.thumb.png.8cb31ddb4e7f83e5ce6a52ecba81329e.png

6 часов назад, ViKo сказал:

Я сказал бы, "купил, чтобы умертвить".

Да он сам умирал без прикорма к тому времени несколько лет.
Покупка  не дала корма PCAD, а в добавок лишила и подпитки.

Да ладно уж. Чего жалеть

Share this post


Link to post
Share on other sites

Поначалу DesignItemID не был включен в этот список, а группировка по нему выполнялась. Включил в список и деактивировал:

grouping.gif

- и ничего не изменилось. Ну пусть это будет не бага, а фича. :)

Share this post


Link to post
Share on other sites
18 hours ago, uriy said:

Вообще-то те кто понимают источник проблемы именно так и делают. Не обязательно использовать единицы измерения mils. У меня миллиметры но шаг сетки 1.27мм, 2.54мм, 5.08мм. Главное чтобы он был кратен дюймам.

Не совсем понимаю такой подход. Лично мне представляется что задавать толщину линии скажем в 8 мил удобнее, чем 0.2 мм. Целые числа удобнее дробей.  Никто же не предлагает болт на 2 3/16 дюйма :) 

Тем более что единицы измерения переключаются одной клавишей  "Q".  

Share this post


Link to post
Share on other sites
5 часов назад, alexf сказал:

Не совсем понимаю такой подход. Лично мне представляется что задавать толщину линии скажем в 8 мил удобнее, чем 0.2 мм. Целые числа удобнее дробей.  Никто же не предлагает болт на 2 3/16 дюйма :) 

Тем более что единицы измерения переключаются одной клавишей  "Q".  

В исходном вопросе речь шла об схеме. В схеме нет возможности задать произвольную ширину линии связи и нет переключения по указанной клавише

Цитата

После компиляции в списке нарушений, альтиум выдает unconnected line, выделяет участок шины.  Находил упоминание об этой ошибке в интернете.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.