Jump to content

    
Sanchosd

2018 Вопросы начинающих

Recommended Posts

Именно так.
Но если схемы на разных листах (а это так) то и это не обязательно.

В настройках проекта установите добавление суффикса номера листа к цепям. Если в качестве земли используется Global Port то в NETSCOPE выберите так, чтобы он был локальный тоже

Share this post


Link to post
Share on other sites

А как можно посмотреть классы, сгенерированные при компиляции PCB-проекта? Их генерацию или отсутствие можно задавать галочками в опциях проекта на вкладке Class Generation. Но вот какие именно классы в итоге сгенерировались, как они называются и что в них входит посмотреть не удаётся. Да, если перейти к PCB, то там можно посмотреть классы в меню Design -> Classes... Но не всегда это дает полную картину. 

Например:

1. PCB в проекте ещё нет. Не добавлена, не сделана. Пока что есть только схема. Хотелось бы знать, какие классы с какими членами сгенерировались при её компиляции.

2. PCB в проекте уже есть, но при переносе изменений из схемы в PCB или наоборот между классами цепей схемы и PCB есть различия. Для полноты картины хотелось бы видеть, что за классы сгенерировались при компиляции схемы и какие классы есть в PCB. Если с просмотром классов в PCB проблем нет, то вот как поглядеть классы, сгенерированные в результате компиляции схемы?

Share this post


Link to post
Share on other sites

Найдите все директивы- там классы и указаны., но что в ходи в класс-- возможно в панели навигатора есть. как это вам поможет--- не знаю

Share this post


Link to post
Share on other sites

Здравствуйте. Открываю схему в версии 18.0.9 и вижу отсутствие узлов электрической связи на схеме. Вчера уходя с работы  все сохранил и было все нормально. В чем может быть дело?

Лечиться перезагрузкой AD. Но иногда повторяется.

 

AD_problem_el.PNG

Share this post


Link to post
Share on other sites

Нет. На где-то на тех версиях наблюдал пару раз. Они слишком быстро устарели. Перезагрузки не нужно было. Сдвиг на экран с другим разрешением и прочие действия приводили отображение в нормальное состояние

 

Share this post


Link to post
Share on other sites

А поясните, пожалуйста, как работает Auto wire (Schif+Space) ? Никак не получается, чтоб заработал. Я так понимаю, просто указываешь начало-конец, а проводник автоматически будет брошен же? 

Share this post


Link to post
Share on other sites
4 hours ago, Scanner said:

Здравствуйте. Открываю схему в версии 18.0.9 и вижу отсутствие узлов электрической связи на схеме. Вчера уходя с работы  все сохранил и было все нормально. В чем может быть дело?

Лечиться перезагрузкой AD. Но иногда повторяется.

 

 

Это галочка "Otimize wire". За которую разработчик который ее придумал, надеюсь, горит в аду!! А в последствии будут гореть те, кто считает, что при установки альтиума эта галочка должна быть включена по умолчанию

Share this post


Link to post
Share on other sites
On 10/8/2018 at 2:08 PM, Владимир said:

Нет там случайности. Что нибудь стоит просто не в сетке и "чуть-чуть" не совпадает.
Никогда не видел проблемы.

Этот Annotate уже достал. Прошу все-таки подсказать более конкретно, что я делаю не так:

Выделяю часть схемы, например такую,

Clipboard41.jpg.f76a63978d98eb44aca961745a71e401.jpg

копирую и вставляю ее вертикально вниз по сетке несколько раз.

В Annotate Schematics задаю нумерацию свеху-вниз, слева-направо. Process location задаю по Dasignator. По точкам привязки проверил Location X - они совпадают и у самих компонентов и у RefDes. Все равно в результате и нумерация реле и нумерация разъемов получается произвольной.  

Share this post


Link to post
Share on other sites

Вижу сетку
1.  Почему выводы компоненты не находятся в узлах сетки?
2. Почему точка привязки текст точно не в сетке, и тем более.

Вы проверяете схему на нахождение элементов в узлах сетки? -- врядли
как вы проверяете выраввнивание-- зрительно по отображаемым цифрам? -- так они не все отображаются, а только первый несколько.
Для установки всетку есть специальные команды привязки -- ими и пользуйтесь

Share this post


Link to post
Share on other sites
35 minutes ago, Владимир said:

Вижу сетку
1.  Почему выводы компоненты не находятся в узлах сетки?
2. Почему точка привязки текст точно не в сетке, и тем более...

У меня шаг сетки -1мм. Вот увеличенный до видимости такой сетки фрагмент приведенного выше рисунка

Clipboard42.jpg.c4a93fd365532ec6c1630f352a7c0771.jpg

здесь видно, что координаты X и для RefDes и для Part находятся в этой сетке. В PCAD командой Viev -> Snap to grid можно было задать движение курсора по сетке, здесь такого не нешел.

Share this post


Link to post
Share on other sites

Здесь есть любители миллиметровых сеток. Это к ним. Пусть  покажут класс и настроят вам.
У меня к этому отношение такое, если используете миллиметры  на схеме у вас может быть и "наводнение, и засуха и не урожай".

Я всегда был против такой сетки (хотя начинал тоже с нее)

Share this post


Link to post
Share on other sites

1. Перейти в mil'ы

2. Выставить всем дезигнаторам - Autoposition

3. При нумерации указать ориентировку по координатам Part.

4. Забыть что такое "оформление схемы"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.