Перейти к содержанию

    

2018 Вопросы начинающих

Именно так.
Но если схемы на разных листах (а это так) то и это не обязательно.

В настройках проекта установите добавление суффикса номера листа к цепям. Если в качестве земли используется Global Port то в NETSCOPE выберите так, чтобы он был локальный тоже

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А как можно посмотреть классы, сгенерированные при компиляции PCB-проекта? Их генерацию или отсутствие можно задавать галочками в опциях проекта на вкладке Class Generation. Но вот какие именно классы в итоге сгенерировались, как они называются и что в них входит посмотреть не удаётся. Да, если перейти к PCB, то там можно посмотреть классы в меню Design -> Classes... Но не всегда это дает полную картину. 

Например:

1. PCB в проекте ещё нет. Не добавлена, не сделана. Пока что есть только схема. Хотелось бы знать, какие классы с какими членами сгенерировались при её компиляции.

2. PCB в проекте уже есть, но при переносе изменений из схемы в PCB или наоборот между классами цепей схемы и PCB есть различия. Для полноты картины хотелось бы видеть, что за классы сгенерировались при компиляции схемы и какие классы есть в PCB. Если с просмотром классов в PCB проблем нет, то вот как поглядеть классы, сгенерированные в результате компиляции схемы?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Найдите все директивы- там классы и указаны., но что в ходи в класс-- возможно в панели навигатора есть. как это вам поможет--- не знаю

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте. Открываю схему в версии 18.0.9 и вижу отсутствие узлов электрической связи на схеме. Вчера уходя с работы  все сохранил и было все нормально. В чем может быть дело?

Лечиться перезагрузкой AD. Но иногда повторяется.

 

AD_problem_el.PNG

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Наверно шаг сетки не кратен 2.54мм

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нет. На где-то на тех версиях наблюдал пару раз. Они слишком быстро устарели. Перезагрузки не нужно было. Сдвиг на экран с другим разрешением и прочие действия приводили отображение в нормальное состояние

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А поясните, пожалуйста, как работает Auto wire (Schif+Space) ? Никак не получается, чтоб заработал. Я так понимаю, просто указываешь начало-конец, а проводник автоматически будет брошен же? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 hours ago, Scanner said:

Здравствуйте. Открываю схему в версии 18.0.9 и вижу отсутствие узлов электрической связи на схеме. Вчера уходя с работы  все сохранил и было все нормально. В чем может быть дело?

Лечиться перезагрузкой AD. Но иногда повторяется.

 

 

Это галочка "Otimize wire". За которую разработчик который ее придумал, надеюсь, горит в аду!! А в последствии будут гореть те, кто считает, что при установки альтиума эта галочка должна быть включена по умолчанию

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 hours ago, peshkoff said:

Это галочка "Otimize wire"

Где она находится?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
On 10/8/2018 at 2:08 PM, Владимир said:

Нет там случайности. Что нибудь стоит просто не в сетке и "чуть-чуть" не совпадает.
Никогда не видел проблемы.

Этот Annotate уже достал. Прошу все-таки подсказать более конкретно, что я делаю не так:

Выделяю часть схемы, например такую,

Clipboard41.jpg.f76a63978d98eb44aca961745a71e401.jpg

копирую и вставляю ее вертикально вниз по сетке несколько раз.

В Annotate Schematics задаю нумерацию свеху-вниз, слева-направо. Process location задаю по Dasignator. По точкам привязки проверил Location X - они совпадают и у самих компонентов и у RefDes. Все равно в результате и нумерация реле и нумерация разъемов получается произвольной.  

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вижу сетку
1.  Почему выводы компоненты не находятся в узлах сетки?
2. Почему точка привязки текст точно не в сетке, и тем более.

Вы проверяете схему на нахождение элементов в узлах сетки? -- врядли
как вы проверяете выраввнивание-- зрительно по отображаемым цифрам? -- так они не все отображаются, а только первый несколько.
Для установки всетку есть специальные команды привязки -- ими и пользуйтесь

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
35 minutes ago, Владимир said:

Вижу сетку
1.  Почему выводы компоненты не находятся в узлах сетки?
2. Почему точка привязки текст точно не в сетке, и тем более...

У меня шаг сетки -1мм. Вот увеличенный до видимости такой сетки фрагмент приведенного выше рисунка

Clipboard42.jpg.c4a93fd365532ec6c1630f352a7c0771.jpg

здесь видно, что координаты X и для RefDes и для Part находятся в этой сетке. В PCAD командой Viev -> Snap to grid можно было задать движение курсора по сетке, здесь такого не нешел.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здесь есть любители миллиметровых сеток. Это к ним. Пусть  покажут класс и настроят вам.
У меня к этому отношение такое, если используете миллиметры  на схеме у вас может быть и "наводнение, и засуха и не урожай".

Я всегда был против такой сетки (хотя начинал тоже с нее)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

1. Перейти в mil'ы

2. Выставить всем дезигнаторам - Autoposition

3. При нумерации указать ориентировку по координатам Part.

4. Забыть что такое "оформление схемы"

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти