Перейти к содержанию

    

Не работает один из PLL Cyclone 4

Всем привет.

 

Собираю платы на EP4CE55 уже не впервой, конструкция можно сказать обкатанная временем. Вдруг, один из экземпляров не работает, но как-то странно - плисина успешно грузится но половина ее схемы не шевелится. Очевидно, что нет такта от одной из PLL. Заменил чип, все заработало. Думаю, ну брак, бывает.

 

Как же я удивился, когда следующие две платы тоже не работают, причем плисины из разных партий, даже корпусом отличаются.

 

Пришлось углубиться. Тренируюсь на тестовой прошивке.

 

Проверил, доходит ли внешний опорник до входа PLL - доходит.

 

Сделал еще один PLL, с такой же конфигурацией как и неработающий, начал играться с коэффициентами и в общем-то не могу сказать ничего определенного.

Получал на выходе самые разные комбинации. Например первый ПЛЛ выдает какие-то герцы вместо килогерц, сигнала locked нет, второй при этом отлично работает. Оба выдают неправильную сильно заниженную частоту, оба не выдают никакого сигнала. Бывало, на выходе какие-то хаотичные импульсы, бывало со старта работает полсекунды и глохнет.

Какой-либо системы не выявлено, полный хаос.

 

Опорник - 122.8 Мгц 1.8 вольт, входной порт указан как 1.8 Вольт вход.

 

На плате есть также еще один опорник с почти такой же частотой - 125МГц 3.3 вольта. При подаче его на вход ПЛЛ они работают хорошо. Конечно, при больших коэффициентах деления бывает не работает, но с этими приколами я знаком давно.

 

Есть какие-то мысли что может быть и что делать ? Работаю с циклоном 4 уже не первый год, никогда проблем не было, а тут массовый падеж.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

По таблице ножек (питаниям) нужно пройтись, для PLL еще свои отдельные выводы бывают. Чтобы все соответствовало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Опорник - 122.8 Мгц 1.8 вольт, входной порт указан как 1.8 Вольт вход.

Стандарты ввода-вывода совпадают, LVCMOS-LVCMOS?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
По таблице ножек (питаниям) нужно пройтись, для PLL еще свои отдельные выводы бывают. Чтобы все соответствовало.

Входы опорной конечно же специальные выводы, иначе Квартус даже не подключит их к ПЛЛ.

 

Стандарты ввода-вывода совпадают, LVCMOS-LVCMOS?

Да, CMOS, никаких извращений.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Тогда наверное имеет смысл посмотреть осцилографом, что там происходит. Ну и может быть уже запостить схему.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Тогда наверное имеет смысл посмотреть осцилографом, что там происходит. Ну и может быть уже запостить схему.

Дык смотрю осциллографом. Вывел выходы ПЛЛ наружу и смотрю. Один из ПЛЛ работать с данным входом категорически отказывается Сам вход рабочий, ибо подключил к нему делитель на счетчике и получил требуемую частоту без проблем.

По схеме там ничего интересного, такт приходит от АЦП, банк io и сам АЦП запитан от 1.8 вольт.

Единственное, оба спецвхода и прямой и инверсный у меня замкнуты и на них обоих подается частота.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Опорник - 122.8 Мгц 1.8 вольт, входной порт указан как 1.8 Вольт вход.

как гипотеза - неправильный опорник или деградация параметров после монтажа..

если все платы с отказом уверенно работают с другим опорником, то копайте в этом направление..

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
такт приходит от АЦП

Вот. Когда такт приходит от АЦП - всё работает криво. Когда такт приходит от генератора - всё работает нормально. Чем они отличаются? Первое, что мне приходит на ум - генератор стартует сразу, а АЦП - нет. То есть при работе от АЦП возможно надо через некоторое время после загрузки ПЛИС подать сброс на PLL.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Входы опорной конечно же специальные выводы, иначе Квартус даже не подключит их к ПЛЛ.

Я про VCCD_PLLx говорю.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Посмотрите отчеты Timequet !

Присутствуют ли в этих отчетах синтезируемая частота на PLL ?

Если в отчётах частота не присутствует - значит Quartus удалил одну из частот... Этот гад может так сделать. А самое главное будет молчать как партизан !

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Я про VCCD_PLLx говорю.

Да, это обьяснило бы происходящее. Но я проверил еще раз все пины связанные с ПЛЛ и все правильно. VCCD_PLLx подключены к 1.2 вольта, VCCAx к 2.5 вольт, GNDAx на земле.

 

 

То есть при работе от АЦП возможно надо через некоторое время после загрузки ПЛИС подать сброс на PLL.

Здравая мысль. попробую сброс поставить, может он приведет его в чувство.

 

 

 

Посмотрите отчеты Timequet !

Присутствуют ли в этих отчетах синтезируемая частота на PLL ?

Если в отчётах частота не присутствует - значит Quartus удалил одну из частот... Этот гад может так сделать. А самое главное будет молчать как партизан !

Ну что вы, так нагло подрезать клок идущий наружу через пин это наврядле. Не забывайте, что с той же прошивкой прекрасно работает эталонная плата и с десяток собранных ранее.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сброс никак не помогает.

 

В общем, ситуация такова:

Есть два одинаковых клока 122.880 на входе от двух АЦП, на разных банках, оба 1.8 вольт

Есть два одинаково настроенных ПЛЛ, выходы которых выведены наружу для контроля на осциллографе.

 

Если первый ПЛЛ подключен к первому клоку а второй ПЛЛ ко второму, то первый ПЛЛ не работает а второй работает нормально

 

Если оба ПЛЛ подключены к первому или второму клоку - оба ПЛЛ не работают

 

Если первый ПЛЛ подключен ко второму клоку а второй к первому, то кроме того, что оба они не работают, то еще тухнет третий ПЛЛ, который работает себе от совсем другого клока 125МГц от другого источника и вообще не при делах.

 

Если кто-то видит в этом систему, пишите.

 

А я наверное попробую сменить версию Квартуса.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

ТС, "Например первый ПЛЛ выдает какие-то герцы вместо килогерц", в Altera можно PLL-ом генерировать килогерцы? В Xilinx ниже 4 МГц вроде как нельзя...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
ТС, "Например первый ПЛЛ выдает какие-то герцы вместо килогерц", в Altera можно PLL-ом генерировать килогерцы? В Xilinx ниже 4 МГц вроде как нельзя...

Я формирую 80 кГц из 122.88 . Это не всегда работает, но если это единственный выход ПЛЛ то работает точно. Ниже не пробовал, без надобности.

В пятом циклоне можно делать каскадное включение выходов, то есть следующий выход будет предыдущий поделенный счетчиком. Смысла в этом мало, так как счетчик и в коде можно завсегда поставить.

 

 

 

Попробовал тестовый код на эталонной плате - оба ПЛЛ работают без проблем. Похоже, какие-то бракованные плисины попадаются или я не знаю что и думать.

 

 

Изменено пользователем rolin

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Статикой может пробились микросхемы. В Cyclone II наблюдал нечто похожее после разряда. ПЛИС пришлось заменить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация