Jump to content

    

Зависание IAR 5.10 для MSP430

Если после загрузки ОС Windows 7 - x64 запустить IAR 5.10 для MSP430, то он работает 3 - 5 минут, а затем виснет наглухо.

В начале всё нормально. Через несколько минут происходит зависание в момент редактирования файла (нажал любую кнопку - повисло).

После принудительного закрытия IAR и повторного запуска, виснет сразу после нажатия любой кнопки.

Если запустить Windows в безопасном режиме, то всё работает нормально.

Думаю, что работу IAR блокирует какая-то программа, которая запускается при старте ОС (антивирус например).

Как устранить сбой в работе IAR? Может кто сталкивался с таким глюком?

 

 

 

Share this post


Link to post
Share on other sites

Я старые версии для AVR на виртуалке запускаю с XP... они под 7кой тоже глючат!

Попробуйте в режиме совместимости запускать или виртуалку!

 

Share this post


Link to post
Share on other sites

Проверьте Ваш инсталятор IAR. Установите на другой комп с такойже OS.

Если ситуация повторится - надо взять что-то посвежеее из IAR. Или тойже версии IAR,

но другой комплект. У нас ничего не вешалось ни на XP, ни на W7.

Оптимально было бы делать установки рабочего софта на "чистую" OS и HDD,

без награмождения антивирусов и прочей хрени которая сидит резидентно на "замусоренном"

компе.

ps - проверьте исправность HW Вашего компа, остобенно тест RAM.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this