Jump to content

    

RFM95 (SX1276)

Подружил несколько модулей RFM95 на базе sx1276. Связь по LoRa на частоте 864,7 МГц.

Собрал свой модуль на базе SX1272 - модуль RFM95 его не слышит. Настройки лоры одинаковые, частота передачи одинаковая - НЕТ СВЯЗИ!!!

Посмотрел анализатором что "где" и "что" передает мой модуль - стоит хорошая палка на 864,70 МГц.

Посмотрел что и где друг другу передают модули RFM95(SX1276) - палка стоит на частоте 864,65 МГц.

Перестроил свой модуль на 864,65 - связь появилась.

 

 

Возникает куча вопросов....

1)Почему так происходит? Это нестабильные кварцы в РФМ95? Но модулей 95 около десятка и они все друг друга видят. (правда я заметил, что при определённых настройках лоры, например при SF = 4096 связи по лоре у рфм95 на столе нет).

2)что с этим делать? Как то можно sx1276 калибровать?

3)при серийном производстве нужно будет проверять стабильность резонатора? Нужно будет проверять, что мой модуль передает на нужно частоте? Получается необходим дорогой анализатор спектра. И как следствие вся дешевизна и простота организации связи на радиоканале с помощью sx1272/sx1276 испаряется.

 

Кто нибудь сталкивался с такой проблемой? Как решить?

Share this post


Link to post
Share on other sites

Такая проблема обычно из за кварцев, в узкополосных системах обычно используют с точностью порядка 10ppm. И не плохо сделать подстройку частоты при работе, иначе могут быть проблемы в температурном диапазоне.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this