Перейти к содержанию

ЗагадоШная работа микросхем RS485.

Столкнулся с проблемой работы 485 интерфейса, обращаюсь к плате от "MOXA NPORT 5230". С микросхемой MAX487 все работает нормально, ставишь вместо нее ADM485 или MAX487 из другой партии(по свежее) и не работает, пропадает стартовый бит после преобразования, соответственно принимаю совсем не то слово.
1. Осциллограмма А и Б с MAX487. А - желтая, Б - синяя. Красным стартовый бит. Все работает, стартовый бит есть.

2. Осциллограмма А и Б с ADM485. А - желтая, Б - синяя. Красным стартовый бит. Не работает, стартовый бит не видится, хватается за следующий информационный бит.

3. Осциллограмма А и Б с ADM485. А - желтая, Б - синяя. Красным стартовый бит. Вообще с выключеным питанием.



Вижу, что с Б творится, что то не ладное, уровень ее меньше чем у А почти в 3 раза, а почему, понять не могу.


Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(Gvozdidir @ Aug 31 2017, 17:07) <{POST_SNAPBACK}>
покурил форум, и все решилось подтяжкой линий А к +5В, Б к земле.

если А - +5 и Б - земле, то как по вашим осцилограммам опознать стартовый бит?

И собственно в чем проблема отсутствия подтяжки была? у вас очень длинная линия?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация