Jump to content

    
Sign in to follow this  
leha2000

Полигон заливает свои очертания неполностью

Recommended Posts

Работаю PCAD2001, в проекте делаю земляной полигон, который должен иметь соединение с цепью GND, и обходить зазором 0,3 остальные цепи. Вместо этого получаю полигон не везде соединенный с цепью GND, а кроме освобождения под другие цепи и элементы, внутри создаваемого полигона имеются многочисленные и очень обширные области, не содержащие метализацию, хотя никаких других элементов и запретов в этих областях нет. На моей памяти это уже не первый такой случай. Может у кого такое уже встречалось? Подскажите что делать! Плз

_____________________.pcb

Share this post


Link to post
Share on other sites

Меня годик назад этот глюк просто з"тр@хал, лечил шамнством открывания файла на других машинах. В 2002 такого вроде не наблюдается.

Share this post


Link to post
Share on other sites
Меня годик назад этот глюк просто з"тр@хал, лечил шамнством открывания файла на других машинах. В 2002 такого вроде не наблюдается.

А вот у меня к сожалению наблюдается! Меня этот глюк уже тоже з"тр@..л, и методом открывания файла на других машинах я тоже его лечить пытался, но мне повезло меньше...

Share this post


Link to post
Share on other sites

Причина, похоже в конденсаторах типов 0603 и 2220. Рядом с каждым таким конденсатором формируется вырез. Но почему это происходит еще не разобрался.

 

PS. Вырезы получаются из-за того, что атрибут Type находится в слое TOP. Он хоть и невидим, но вырез вокруг формируется. Перенесите эти атрибуты в несигнальный слой.

Share this post


Link to post
Share on other sites

Да действительно в элементах 2220 и 0603 имелись невидимые аттрибуты TYPE, помещенные на TOP, но после перемещения TYPE на TOP SILK картина изменилас не очень сильно.

_____________________.pcb

Share this post


Link to post
Share on other sites

Получилось!!!! :blush::blush: ;) ;) ;)

У меня просто не сразу получилось компоненты переписать и, оказывается, необходимо было удалить полигон и создать его заново!!!!!!

Share this post


Link to post
Share on other sites

Вы не обновили конденсаторы 0603. Легко сможете в этом убедиться, сделав видимыми атрибуты Type в свойствах компонента. Если в паттерне Вы уже перенесли Type в другой слой, то проще всего обновить нужные компоненты через Utils/Force Update.

Share this post


Link to post
Share on other sites

С Force Update я поторопился: атрибуты в другой слой не переносятся. Тогда только вручную, сделав видимыми Type, выделяя их по очереди и перенося в другой слой.

 

PS. Force Update тоже можно использовать, но нужно не забыть выбрать Replace Attributes In The Design.

Share this post


Link to post
Share on other sites

Действительно :)

у вас еще могут проблемы возникнуть если вы будете пользовать такие компоненты при трассировке :)

Share this post


Link to post
Share on other sites
Не пойму, к чему такие страдания, рисуйте в PCAD2002.

A чем PCAD2002 в данном случае мог помочь? Ведь это не глюк, а ошибка при создании корпуса.

Share this post


Link to post
Share on other sites

Ошибка не ошибка, а на последних платах которые создавались в 2002 такого эффекта не наблюдалось (эквивалентная сложность и компоненты), правда перетаскивать в 2001 приходится ручками (небольшое несоответствие форматов).

Share this post


Link to post
Share on other sites

Огромное вам спасибо!Действительно я облажался и сам того не понял, т.к. думал, что компонент обновляется через его свойства.

Но главное, что все уже позади. Еще раз большое спасибо!!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this