Jump to content

    

HDMI десериализация. Интересное поведение сигнала DENA

Есть плата для обработки HDMI видео потока с десериализатором (приемником) TFP401. Видео обрабатывается ПЛИСом и выводится на LVDS TFT панель. Тестовый сигнал, сгенерированый на ПЛИС отображается нормально. С видео, полученным по HDMI проблема - сбивается синхронизация кадров. С помощью встроенного лог.анализатора Xilinx ChipScope наблюдаем след. картину (сигналы DENA, VS, HS с м/с десериализатора):

 

post-62983-1492613369_thumb.pngpost-62983-1492613378_thumb.png

 

А именно - проблема с сигналом DENA. Полистал стандарт HDMI, но, как я понял, аудио данные и управляющие пакеты должны приходить при DENA=0. Тогда что же это за "пички" на сигнале DENA?

 

С уважением, Юрий.

 

P.S. добавлю, что источник видеосигнала вот такая балалайка.

Edited by Кузнецофф Ю.

Share this post


Link to post
Share on other sites

Отвечу сам себе - заменил балалайку переходником, чтобы можно было подать сигнал HDMI с компа, всё заработало.

Если все же у кого-то будут мысли по поводу DENA, очень интересно было бы услышать.

Share this post


Link to post
Share on other sites
Если все же у кого-то будут мысли по поводу DENA, очень интересно было бы услышать.

Так TFP401 на прием HDMI потока и не расчитан, он только DVI 1.0 "умеет".

Share this post


Link to post
Share on other sites
Так TFP401 на прием HDMI потока и не расчитан, он только DVI 1.0 "умеет".

 

Благодарю вас за ответ. В старом описании TFP401х есть ремарка:

DVI/HDMI* Receivers (* - HDMI Video-Only)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this