Jump to content

    
Sign in to follow this  
Kolya87

stm32f105vc

Recommended Posts

Монтажники, они такие очень разные, у них же даташита нет - кто-то сам выберет ключ, а кто-то пойдет уточнять.

Пойдёт?! 8-\ Ага… Они работу работают, а разработчик-бездельник будет вызван пред ясные их очи (;

И рассматриваемый нами случай - это правильный случай тревоги, не пустяк.

Share this post


Link to post
Share on other sites
это правильный случай тревоги, не пустяк.

Фотография платы с МК от ТС убедительно закрыла бы этот вопрос.

С ключом, есть неоднозначность, которая не может быть снята без чтения DS.

Когда на корпусе одна точечка, то как-то не задумываешься;

а когда их становится больше... в общем, ждем фото.

Share this post


Link to post
Share on other sites
Правильность монтажа согласно выше приведенной схеме проверял ни раз.

Пины 21, 22, 28 вызывают сомнения.

Пин 14 ни с чем еще не замыкает?

Кварц вообще не понятно что тут делает?

 

чип пустышка, наверняка

На фотке вполне-себе не выдающий никаких признаков левости чип.

Нужно просто сделать все правильно - после этого чип заработает: тут вам не AVR.

Share this post


Link to post
Share on other sites
чип пустышка, наверняка
Сначала у автора темы был 105. Теперь на фото 107 с такими же симптомами. Какова вероятность такого "везения"? Я бы скорее грешил на ST-link. Автор, где вы находитесь? Вполне возможно, на форуме есть кто-то из ваших мест с заведомо рабочим программатором и заведомо рабочей платой с процессором. Соединяя их в разных комбинациях с вашими вы очень быстро найдете виновного.

 

Share this post


Link to post
Share on other sites
Глянул я на фотку: есть подозрение, что с таким "монтажом" прибиваются процы первой же подачей питания.

Практика показывает, что "прибитые" процы начинают потреблять амперы, хотя могут при этом сносно работать не только печкой.

Мне тоже кажется что проблема не в МК, а в плате, ST-Linke, питании...

Банально, нужно подать в ST-Link питание извне, чтобы заработали преобразователи уровней (например).

А может, ST-Link не ST-Link, а какой-нить J-Link или иной отладчик (может даже с опторазвязкой).

А если это ST-Link на discovery, то при задействованном RESET и обесточенном targete на discovery (снята перемычка Idd)

RESET будет на земле, и все будет плохо работать. Телепатить можно не устать еще на 3 страницы))

Share this post


Link to post
Share on other sites
Вот такая вот плата на данный момент. Правильность монтажа согласно выше приведенной схеме проверял ни раз.

:smile3046:

Эту фотку надо было цеплять сразу к первому сообщению.

Если так сделана "плата", то и остальное значит примерно так же. Такое и не должно работать.

 

PS: На "плате" не хватает только пятен пролитого кофе и налипших крошек B)

Share this post


Link to post
Share on other sites
Пойдёт?! 8-\ Ага… Они работу работают, а разработчик-бездельник будет вызван пред ясные их очи (;

И рассматриваемый нами случай - это правильный случай тревоги, не пустяк.

Так-то монтажники пойдут к технологам/конструкторам, а я вообще самый последний в цепочке, но до меня ближе :)

 

 

Я бы скорее грешил на ST-link.

Добавлю еще важный момент - по-максимуму укоротить провода от чипа до ST-Link.

Share this post


Link to post
Share on other sites
Добавлю еще важный момент - по-максимуму укоротить провода от чипа до ST-Link.

Добавлю свои "пять копеек": заменить отладчик на нормальный, например, J-Link.

С ним будет работать даже 2х метровый (!) JTAG провод (коллеги в цеху "умудрились" так сделать отладку одного из своих изделий, но на удивление 2Мбит тянет...).

Share this post


Link to post
Share on other sites

А что на обратной стороне платы? Почему так "сэкономлено" на блокировочных конденсаторах и питании?

Ведь по обратной стороне земля, питание, блокировки (даже 0805) размещаются как надо. Плата фабричная с маской: денег не жалко на такой дизайн?

Share this post


Link to post
Share on other sites

 

1892523-40.jpg

 

Пользуюсь вот таким вот ST-Link. Рабочий, со 103-й серией работает без проблем, прошивку обновил до последней. Думаю дело не в нем.

Возможно что-то в монтаже, хотя уже ни раз все проверил, замыканий никаких нет, питание в норме. Не первый раз уже собираю подобные схемы.

Сейчас думаю организовать нормальную плату под STM, на подобии arduino.

Share this post


Link to post
Share on other sites
А что на обратной стороне платы? Почему так "сэкономлено" на блокировочных конденсаторах и питании?

А где Вы там видите блокировочные конденсаторы?

То что на проводах болтается? Так на проводах оно уже не может быть блокировочным. :laughing:

Решение вопроса - плату в утиль и делать новую, т.е. - обратиться к людям, умеющим её сделать.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this