Jump to content

    
Sign in to follow this  
Kolya87

stm32f105vc

Recommended Posts

На ногах SWDIO, SWCLK напряжение 200-250 мВ.
А по документации на SWDIO должна быть включена встроенная подтяжка вверх.

На ноге NRST без резистора R19 напряжение 3,3 В
Это хорошо. Есть шанс что процессор правильный, но в него залита программа, выключающая JTAG/SWD. А какой уровень будет на SWDIO если подать питание с перемычкой на XP3 (зажатым сигналом сброса)? Если снова низкий - то эти микросхемы только в помойку.

Share this post


Link to post
Share on other sites
А по документации на SWDIO должна быть включена встроенная подтяжка вверх.

Это хорошо. Есть шанс что процессор правильный, но в него залита программа, выключающая JTAG/SWD. А какой уровень будет на SWDIO если подать питание с перемычкой на XP3 (зажатым сигналом сброса)? Если снова низкий - то эти микросхемы только в помойку.

 

 

После ручного сброса на SWDIO 3,3 В, на SWCLK - 0

Share this post


Link to post
Share on other sites
Тогда попробуйте подключиться с зажатым сбросом. И если получится - стереть кристалл.

 

Тоже не выходит. Пробую запуститься с сигналом сброса. Нет подключения. По USART2 тоже нет подключения. USB_VBUS подтянул к 0. Тоже никак не хотит.

Share this post


Link to post
Share on other sites
Есть еще вариант, что процессор неправильно впаян
Так ноги NRST и SWDIO ведут себя вроде как вполне адекватно.

 

Share this post


Link to post
Share on other sites
Запаял stm32f107vct6 по той же схеме, добавил тока два блокировочных конденсатора по питанию. То же самое, не хочет подключаться

Есть под рукой EM-STM3210C.

По схеме особых отличий нет (есть, типа, SWDIO к 3.3 подтянуть, а SWCLK к GND).

Проблем с прошивкой и отладкой через ST-LINK_v2 нет.

Может, у вас БП плохой? Как выполнено питание? LDO 3.3В рядом с МК?

Какой ток потребления? Есть ли активность на выводах? Что за ST-LINK?

Где брали МК?

Вроде, в 105/107 нет RDP2, чтоб залочить любую внешнюю отладку.

EM_STM3210C_Board_Schematic.pdf

Share this post


Link to post
Share on other sites
Есть под рукой EM-STM3210C.

По схеме особых отличий нет (есть, типа, SWDIO к 3.3 подтянуть, а SWCLK к GND).

Проблем с прошивкой и отладкой через ST-LINK_v2 нет.

Может, у вас БП плохой? Как выполнено питание? LDO 3.3В рядом с МК?

Какой ток потребления? Есть ли активность на выводах? Что за ST-LINK?

Где брали МК?

Вроде, в 105/107 нет RDP2, чтоб залочить любую внешнюю отладку.

 

 

Питание от лабораторного БП через стабилизатор LM1117-3,3. Потребление не более 40 мА от 12 В вместе с др. обвязкой. ST-LINK_v2 фирменный, покупной. МК куплены в магазине радиодеталей.

В момент попытки подключения через ST-LINK, на SWDIO и SWCLK наблюдаются пакеты по осциллографу. По USART2 тоже наблюдается пакет из ПК.

Share this post


Link to post
Share on other sites
"Будь труЪ - лабай black кури doc" ;)

Монтажники, они такие очень разные, у них же даташита нет - кто-то сам выберет ключ, а кто-то пойдет уточнять.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this