Перейти к содержанию

Kintex UltraScale & ASUS X99-E WS

Всем доброго времени суток

Обнаружена проблема. Два разных модуля на Kintex UltraScale неправильно инициализируется. Вместо режима Gen 3 включается режим Gen 1. Так происходит во всех слотах. В этом же компьютере несколько разных видеоадаптеров инициализируются как Gen 3. Модуль FMC122P в котором есть мост PLX также инициализируется как Gen 3.

Модули:
1. FMC126P - Kintex Ultrascale KU040
2. ADM-PCIE-KU3 - Kintex Ultrascale KU060

В других комьютерах работают нормально - Gen 3 x8

Системная плата: ASUS X99-E WS
Структурная схема в приложении.
Драйвера установлены, прошивка BIOS обновления не требует.

Процессор: Intel Core i7 - 5930K

Собственно вопрос - а кто-нибуть уже пробовал аналогичную конфигурацию ?


Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Дополнительная информация:
1. Собран ещё один компьютер с системной платой "ASUS X99-E WS" - проблема та же, инициализация только в режиме Gen1
2. Собран другой компьютер с системной платой "ASUS X99-E WS USB 3.1" - проблемы нет. Инициализация происходит в режиме Gen3

BIOS обновили.

Что ещё можно сделать ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Есть ли возможность тактирования не от слота, а от генератора ?
Есть ли в биос настройка spread spectrum ?
Можно поиграть и тем и тем.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Установки spread spectrum в BIOS нет.
У нас на модуле есть специальная микросхема для удаления spread из опорного сигнала.

Тактироваться от генератора возможности нет. Собственно говоря от встроенного генератора работали только системные платы первого поколения.
Дальше - только от слота.


Цитата(toshas @ Apr 6 2017, 10:54) <{POST_SNAPBACK}>
Есть ли возможность тактирования не от слота, а от генератора ?
Есть ли в биос настройка spread spectrum ?
Можно поиграть и тем и тем.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Когда плата переходит на gen1 переворот lane's при этом происходит ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(toshas @ Apr 6 2017, 12:14) <{POST_SNAPBACK}>
Когда плата переходит на gen1 переворот lane's при этом происходит ?


Не знаю, а как это можно посмотреть ?

P.S. Системная плата Z170-WS - то же самое. Только Gen 1

В обоих платах используется мост PLX с идентификатором 8747:
Скорее всего вот этот: https://www.broadcom.com/products/pcie-swit...ex8747#overview

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В ядре есть спец. ножки на которых после тренировки выставляется текущая скорость, ширина канала и прочее.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(toshas @ Apr 7 2017, 20:15) <{POST_SNAPBACK}>
В ядре есть спец. ножки на которых после тренировки выставляется текущая скорость, ширина канала и прочее.

Это просто информация. Я вижу результат - инициализация в Gen1;
Производители системных плат уже что-то изменили.
Есть две похожие платы:
ASUS X99-E WS - только Gen1
ASUS X99-E WS USB 3.1 - Gen3

Структура одинаковая. Мосты одинаковые. Однако более поздняя - работает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(dsmv @ Apr 11 2017, 14:27) <{POST_SNAPBACK}>
Структура одинаковая. Мосты одинаковые. Однако более поздняя - работает.

А Bios как различается ? А версия дистрибутива ОС и пакеты программного обеспечения от Intel ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(SFx @ Apr 11 2017, 18:52) <{POST_SNAPBACK}>
А Bios как различается ? А версия дистрибутива ОС и пакеты программного обеспечения от Intel ?

Плата ASUS X99-E WS USB3.1 - BIOS: X99-E WS/USB3.1 v3201 - работает Gen 3
Плата ASUS X99-E WS - BIOS: X99-E WS v3402 - работает только Gen 1

BIOS разный, ОС запускалась одна и та же (с одного винчестера), Windows 7 32bt. Но ОС тут уже ни причём, вся инициализация идёт на уровне BIOS

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В BIOS нет возможности изменить параметры для конкретного слота (например, только Gen3)? Конкретно с этой платой не работал, но в основном у Асуса есть возможность отключить SSC, только называться будет иначе.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(dsmv @ Apr 12 2017, 12:04) <{POST_SNAPBACK}>
Плата ASUS X99-E WS USB3.1 - BIOS: X99-E WS/USB3.1 v3201 - работает Gen 3
Плата ASUS X99-E WS - BIOS: X99-E WS v3402 - работает только Gen 1

Что ещё можно сделать ?

Материнская плата для рабочих станций-у них расширенная поддержка, смело пишите в техподдержку пока есть(или уже нет) жизненный её выпуска
возможна в версии USB3.1другая версия чипсета где пофиксена errata-ищите её на сайте интела.
В этом чипсете вроде есть проблемы в уровне сигнала в gen 3,инициализации регистров.
Были аналогичные проблемы gen1 с ASUS X79-E WS правда с видеокартами , тикет в техподдержку и в новой версии биос уже всё как надо.
Но со специфичной железкой надо много инфы прилагать и долго убеждать что это может также влиять НА СЕРИЙНЫЕ КОМПЬЮТЕРНЫЕ ПЕРИФЕРИЙНЫЕ ПЛАТЫ.
Версии чипсетов на платах ещё сравните .

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Цитата(dsmv @ Apr 11 2017, 14:27) <{POST_SNAPBACK}>
Это просто информация. Я вижу результат - инициализация в Gen1;

Где видится? Как видится? А видно что x8? Опять же где, любопытно.
А вообще, может попробовать... ОС Linux? Что если другую ОС попробовать, не Windows? Чем черти не шутят, вдруг это еще и от операционной системы зависит.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
У многих PCIe есть проблемы как с Lane reversal, так и с Lane polarity reversal. Множество раз наступал на эти грабли.
Также стоит заметить, что для Gen2/Gen3 изменился номинал конденсаторов по TX дифпарам - с 0,1 мкф до 0,22 мкф. но по факту оказывается что не везде стоит то что надо, даже на китах.

зы. когда делал 12-портовый 4х коммутатор на PLX8648 в далеком 2010, пришлось нафиг выключать Gen2 недокументированным пином ;-) просто потому что оно декларировало поддержку ASPM, но при попытке реально задействовать - вешало ОСь (любую).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация