Перейти к содержанию

    

Адаптер XMC_to_PCIe не работает

Купили адаптер XMC_to_PCIе (ADG052)Описание адаптера для экспериментов. После доработок по питанию (адаптер для 12В, а платформа 5В) воткнули сетевуху x4. В устройствах не видится. Есть ли какие-нибудь нюансы в таком подключении? Требуется ли определенная модификация PCIe-устройства для подключения через XMC.3 или такое подключение прозрачно?

 

Заранее спасибо!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Подключение должно быть прозрачным,

1. полагаю что 5В блок питания задерживает пробуждение PCIЕ устройства, что мешает BIOSу его рспознать при буте. PCIE ХОТ СВОП плохо работает в обычных материнках.

2. Пользуйте линукс и LSPCI или uefi shell. Так можно увидеть что видит BIOS не поднимая виндоус.

3. ВЫ сидите нa обычном PCIE слоте или PEG ? PEG как правило Х16 . В ПЕГ часто бывают проблемы с PEG_LANE_REVERS.

4. В БАЙОСЕ проверьте что слоты все на AUTO и не форсированны ма какойнить GEN3 / X16 only .

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Подключение должно быть прозрачным,

1. полагаю что 5В блок питания задерживает пробуждение PCIЕ устройства, что мешает BIOSу его рспознать при буте. PCIE ХОТ СВОП плохо работает в обычных материнках.

2. Пользуйте линукс и LSPCI или uefi shell. Так можно увидеть что видит BIOS не поднимая виндоус.

3. ВЫ сидите нa обычном PCIE слоте или PEG ? PEG как правило Х16 . В ПЕГ часто бывают проблемы с PEG_LANE_REVERS.

4. В БАЙОСЕ проверьте что слоты все на AUTO и не форсированны ма какойнить GEN3 / X16 only .

 

1. Подключали кит с плисой, там, вроде, Wake не поддерживается. Кит питался от своего источника и грузился раньше платформы.

2. Смотрели в QNX и в UEFI Shell.

3. Разъем xmc на PCIex8-порт проца заведен.

4. Нет слотов на платформе. Формат 6U. Ссылка на платформу

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1. Подключали кит с плисой, там, вроде, Wake не поддерживается. Кит питался от своего источника и грузился раньше платформы.

2. Смотрели в QNX и в UEFI Shell.

3. Разъем xmc на PCIex8-порт проца заведен.

4. Нет слотов на платформе. Формат 6U. Ссылка на платформу

Kontron круты, много с их COMEXPRESSами работаю.

Попагаю проблема не у них, я их раньше тож во многом винил, все косяки оказались моими.

Покупные готовые Х4 PCIE пашут в этом слоте с адаптором ? Я так понимаю в Контроне есть разьем XMC а оттуда вы ч адаптор выходите на обычный PCIE, верно ?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Kontron круты, много с их COMEXPRESSами работаю.

Попагаю проблема не у них, я их раньше тож во многом винил, все косяки оказались моими.

Покупные готовые Х4 PCIE пашут в этом слоте с адаптором ? Я так понимаю в Контроне есть разьем XMC а оттуда вы ч адаптор выходите на обычный PCIE, верно ?

 

Ну да, я так в начале и написал. И адаптер указал, если что. Но платы в нем не видны в биосе. Хотя должны бы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3. ВЫ сидите нa обычном PCIE слоте или PEG ? PEG как правило Х16 .

 

PEG не позволяет переключаться на х1 или x8? Какие у него ограничения?

У меня как-раз проблема с невидимостью видеокарты, даже из ШЕЛЛ.

 

В ПЕГ часто бывают проблемы с PEG_LANE_REVERS.

 

Не могу найти нормальное описание всех пинов, помогите, в каких состояниях должны быть: PEG_LANE_REVERS, Type0-2

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация