Jump to content

    

Recommended Posts

При подаче сигнала на пинN, настроенный на ввод и выполняющий определенную функцию в программе, часть других пинов плис, настроенных на ВВОД,переключаются на вывод и сажают выходы других микросхем на GND. Плис менял. Переназначал пинN. ничего не меняется. Плис тоже менял.

Share this post


Link to post
Share on other sites
При подаче сигнала на пинN, настроенный на ввод и выполняющий определенную функцию в программе, часть других пинов плис, настроенных на ВВОД,переключаются на вывод и сажают выходы других микросхем на GND. Плис менял. Переназначал пинN. ничего не меняется. Плис тоже менял.

Есть 2 способа жизни.

1. При помощи JTAG-тестирования вручную получить данные со входа и проверить, что нет замыкания на другие выводы.

2. Выкинуть "весь проект", кроме этого вывода и проверить, связано ли "чудо" с проектом...

Ну и никогда не писАть "определенную функцию в программе", ибо нет там "программы" и "функции", кроме случая софт-процессора...

 

Share this post


Link to post
Share on other sites
При подаче сигнала на пинN, настроенный на ввод и выполняющий определенную функцию в программе, часть других пинов плис, настроенных на ВВОД,переключаются на вывод и сажают выходы других микросхем на GND. Плис менял. Переназначал пинN. ничего не меняется. Плис тоже менял.

симулируется правильно?

Share this post


Link to post
Share on other sites

Причем, если я этот пинN сажаю на GND или VCC то все работает. Но если я его цепляю к шине где бегают данные, то тогда случается вышеописанная проблема. Даже если сделать пинN не используемым.

Share this post


Link to post
Share on other sites
Причем, если я этот пинN сажаю на GND или VCC то все работает. Но если я его цепляю к шине где бегают данные, то тогда случается вышеописанная проблема. Даже если сделать пинN не используемым.

Может это особо-выделенный вывод? Сброс глобальный или OE?

Без проекта ничего сказать нельзя. Что за шина, какие данные? Замыкания точно нет?

 

Share this post


Link to post
Share on other sites

Вывод обычный. Дальнейшая работа показала что если любой ввод плис прицепить к определенному проводу шины данных, которая находиться на другой плате, то появляется эта проблема. Платы связаны питанием.

Share this post


Link to post
Share on other sites
Вывод обычный. Дальнейшая работа показала что если любой ввод плис прицепить к определенному проводу шины данных, которая находиться на другой плате, то появляется эта проблема. Платы связаны питанием.

Шина какая двунаправленная? Кто на ней сидит? Как переключается?

Я не понимаю, почему из Вас надо все клещами тащить?

 

Share this post


Link to post
Share on other sites

Приходится угадывать, конечно... Шина, случаем, не 5В?

Сталкивался с похожей ситуацией, когда в результате ошибного подключения через пин попадало повышенной напряжение на локальное питание ПЛИС, отчего это питание задиралось и часть логических сигналов просто "проваливались" ниже уровня единицы, т.к. недотягивали.

Есть ещё вариант - всплески напряжения в шине при коммутациях, которые теоретически могут приводить ко всякого рода защёлкиваниям.

Share this post


Link to post
Share on other sites

шина связывает две плис . похожа на i2s. назначил другие порты на шину у плис к которой подключается проблемная плис ,..работает. Но в моем случае не вариант.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this