Jump to content

    

помощь в настройке ELDO от Mentor

Есть у меня на руках AMS с ELDO.

И есть библиотеки от XFAB. Вроде Cadence с ними я подружил. Но не могу понять: когда я запускаю симулятор eldo - он использует модели от xfab или нет?

Каких-то внятных слов в документации я не нашел. Кто-нибудь сталкивался? можете рассказать что к чему?

Share this post


Link to post
Share on other sites

В финальном нетлисте симулятора должно быть прописано подключение моделей.

Share this post


Link to post
Share on other sites

Или в каждом файле надо отдельно присоединять библиотеку, как это делается в T-Spice (только там в настройках симуляции, а тут, выходит в каждом файлике)?

 

Share this post


Link to post
Share on other sites
На выходе он выдает файл .chi, но списка моделей я там не вижу. К примеру
Вы показали выходной лог файл симулятора, а смотреть нужно нетлист, который запускается на моделирование. Он указан в 3-ей строке вашего лог файла (там указана команда запуска моделирования): rsffc.eldo.cir. Его и нужно смотреть.

Судя по ошибкам в конце лог файла, модели транзисторов NMOS и PMOS у вас не подключены.

 

Share this post


Link to post
Share on other sites

Из моей практики NMOS и PMOS - названия транзисторов в CAD-ах по умолчанию. Потому как ФАБ дополнительно кодирует в названии модели тип транзистораи, версию модели и область применения - I/O, core, SRAM, etc.

 

Share this post


Link to post
Share on other sites

Спасибо больше. Кажется разобрался что к чему.

 

Буду воевать с библиотеками. ELDO выдает предупреждения о том что какие-то параметры игнорируются, но при этом обсчитывает структуру.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this