Jump to content

    
Sign in to follow this  
bms

Не открывается библиотека символов

Recommended Posts

Не удается открыть некоторые библиотеки символов созданные в версии 9, пример такой библиотеки во вложении. Выдается сообщение "GenericError". Пробовал открывать её в версиях 13, 14, 15 - результат один и тот же. Другие библиотеки сделанные примерно в то же время, что и "кривая" открываются нормально.

В версии 9 библиотека открывается нормально.

Интегрированная библиотека, сделанная из "кривой" работает нормально, если же из нее извлечь библиотеку символов и попытаться ее открыть для редктирования - опять косяк.

INDUCTORS_1008_MAS.7z

Share this post


Link to post
Share on other sites

Все открывается.

Буквально вчера на это жаловались. Оказалось, если библиотека на локалке-- все открывается.

Если в сети--- то в зависимости от компа.

Локализовать не удалось, и доступа нет (хотя можно получить) и желания.

Так как я сторонник работы только с локалкой, а на сервере синхронизовать через SVN

Share this post


Link to post
Share on other sites
Все открывается.

Буквально вчера на это жаловались. Оказалось, если библиотека на локалке-- все открывается.

Если в сети--- то в зависимости от компа.

Локализовать не удалось, и доступа нет (хотя можно получить) и желания.

Так как я сторонник работы только с локалкой, а на сервере синхронизовать через SVN

 

Библиотека на локалке. Увы!

Еще раз обращаю внимание - другие библиотеки созданные в той же версии и в то же время ОТКРЫВАЮТСЯ нормально. Все библиотеки (и "кривые" и "прямые") лежат в одном месте.

Пробовали переносить в другие места на диске, в сети, на другие машины - результат тот же.

Share this post


Link to post
Share on other sites
Библиотека на локалке. Увы!

Еще раз обращаю внимание - другие библиотеки созданные в той же версии и в то же время ОТКРЫВАЮТСЯ нормально. Все библиотеки (и "кривые" и "прямые") лежат в одном месте.

Пробовали переносить в другие места на диске, в сети, на другие машины - результат тот же.

Ну я же открыл и просмотрел все ваши индуктивности. все открылись без такого сообщения.

 

то что я видел у других подобное сообщения--- меня это не удивило.

то что у вас на локалке и те же проблемы--- тут уж ничем помочь не могу. У меня нет проблем с вашей библиотекой

Share this post


Link to post
Share on other sites
Ну я же открыл и просмотрел все ваши индуктивности. все открылись без такого сообщения.

 

В какой версии Вы это сделали? Могу я Вас попросить сделать "Save As" и прислать мне на onpc1(собака)rambler.ru сохранённую в Вашей версии Altium библиотеку?

Share this post


Link to post
Share on other sites

Да нет проблем. версия алтия в названии файла.

 

Вопрос в том, что такая ошибка возникает. и ее как-то надо локализовать, дабы ее порешали.

 

вот файл

Share this post


Link to post
Share on other sites
Да нет проблем. версия алтия в названии файла.

 

Вопрос в том, что такая ошибка возникает. и ее как-то надо локализовать, дабы ее порешали.

 

вот файл

 

Спасибо за библиотеку.

Однако и Ваш вариант у нас тоже НЕ ОТКРЫВАЕТСЯ... Загадка...

Share this post


Link to post
Share on other sites
Спасибо за библиотеку.

Однако и Ваш вариант у нас тоже НЕ ОТКРЫВАЕТСЯ... Загадка...

Я скажу более того.

в другой библиотеке (она открывалась) была половина компонентов, которые не открывались.

Однако их можно было через кнопку Place поставить на схему.

На схеме скопировать этот компонент и копи пасте вставить в библиотеку.

Вроде бы должен был читаться--- ан нет--- фик с маком-- тоже ваше сообщение.

 

мне все кажется это использования процентов, слэшей и прочей гадости в наказании компонентов.

Ну привыкните, только английские большие + цифры, ну знак подчеркивания и все--

Не будете ловить дребедени.

 

Отвыкли уже что только 6 символов в названии и три в расширении, да и только в на английском раньше было.

Всем предложениями писать хочется. Сдерживать себя нужно

 

Share this post


Link to post
Share on other sites

Все открывается- алтиум последней генерации, никаких ошибок нет. Библиотека конечно ведется криво, но специальные символы влиять не должны, это не аллегро- да и похуже библиотеки видал. Другой вопрос что все это дело выглядит импортированным, часом не из пикада ли? Никогда в пикаде не работал,но видел как выглядят вещи вытянутые из него поэтому точно судить не берусь.

Share this post


Link to post
Share on other sites
Все открывается- алтиум последней генерации, никаких ошибок нет. Библиотека конечно ведется криво, но специальные символы влиять не должны, это не аллегро- да и похуже библиотеки видал. Другой вопрос что все это дело выглядит импортированным, часом не из пикада ли? Никогда в пикаде не работал,но видел как выглядят вещи вытянутые из него поэтому точно судить не берусь.

 

Есть версия, что проблемы появились после очередного обновления виндов... тут еще будем проверять. Если это так, то кто-то еще наверняка нарвётся на это, хотя и не сразу - к старым библиотекам иногда годами не возвращаются, как это произошло у нас.

Листы схем, где стоят эти индуктивности тоже ведут себя странно, хотя и не так фатально, как библиотека...

 

Насчет "кривого" ведения библиотеки - я бы на Вашем месте воздержался от подобных комментариев, ибо как известно на вкус и цвет товарища нет. К тому же есть специфика, под которую эти библиотеки были сделаны и которой Вы не знаете.

 

По поводу пикада - да, символ был когда-то импортирован оттуда. Хорошо ли это? Не уверен. Но тогда это было оправдано из-за жестких лимитов времени.

Символ был импортирован, как и десятки других, которые работают нормально. Хотя импорт из пикада я тоже держу на подозрении...

 

 

Share this post


Link to post
Share on other sites
Насчет "кривого" ведения библиотеки - я бы на Вашем месте воздержался от подобных комментариев, ибо как известно на вкус и цвет товарища нет. К тому же есть специфика, под которую эти библиотеки были сделаны и которой Вы не знаете.

 

А что-тут воздерживаться- субъективизма моего нет, библиотеки объективно очень и очень так себе. Согласен с Владимиром

по поводу:

 

мне все кажется это использования процентов, слэшей и прочей гадости в наказании компонентов.

Ну привыкните, только английские большие + цифры, ну знак подчеркивания и все--

Не будете ловить дребедени.

 

Отвыкли уже что только 6 символов в названии и три в расширении, да и только в на английском раньше было.

Всем предложениями писать хочется. Сдерживать себя нужно

 

Видно что методологии нет, компоненты взяты откуда то "оттуда" и к ним приделали свои костыли которые назвали специфическими требованиями, именуются они криво - ну и факт импорта конкретно из пикада ничего хорошего не добавляет. Это не выпад в Вашу сторону или нравоучение- это просто технический факт, не более того, без каких-либо окрасок и подтекстов.

Share this post


Link to post
Share on other sites
По поводу пикада - да, символ был когда-то импортирован оттуда. Хорошо ли это? Не уверен. Но тогда это было оправдано из-за жестких лимитов времени.

Символ был импортирован, как и десятки других, которые работают нормально. Хотя импорт из пикада я тоже держу на подозрении...

Возможно. В другом (точнее в первом ) случае, у меня не то что подозрение, а уверенность , что была импортирована из Pcad

 

2 камня в воронке-- это уже куча.

 

Возможно туда надо копать.

При импорте куча элементов, которые не видны, править невозможно и их не видно, но они обрабатываются.

 

Вот обработка и дает может это.

 

Придет Сабунин, может он прояснит

 

 

 

 

 

Share this post


Link to post
Share on other sites
А что-тут воздерживаться- субъективизма моего нет, библиотеки объективно очень и очень так себе. Согласен с Владимимром

по поводу:

 

 

 

Видно что методологии нет, компоненты взяты откуда то "оттуда" и к ним приделали свои костыли которые назвали специфическими требованиями, именуются они криво - ну и факт импорта конкретно из пикада ничего хорошего не добавляет. Это не выпад в Вашу сторону или нравоучение- это просто технический факт, не более того, без каких-либо окрасок и подтекстов.

 

Предлагаю Вам, EvilWrecker, в качестве примера выложить пару-тройку своих "правильных" библиотек, чтобы все кто не разбирается в предмете и страдает отсутствием методологии могли поучиться у настоящих гуру. Там ведь возможно действительно есть чему поучиться - так не скрывайте такую силу от людей.

 

И я по прежнему ожидаю откликов людей, которые столкнулись с подобными проблемами старых библиотек или могут подкинуть какие-либо идеи.

Библиотеки конечно вычищаются по мере надобности, но есть риск, что это вылезет где-то ещё и по хорошему надобы докопаться до причины явления.

Share this post


Link to post
Share on other sites

В свое время потрудился и перерисовал все библиотеки с нуля, хоть и были огромные наработки в пикаде.

Про возможные ошибки импорта именно пикад-альтиум не знал.

Чисто опыт. Любой импорт - зло.

Нужно только для оперативных действий. Для работы, тем более билиотеки, необходимо сделать с нуля в родной системе.

Share this post


Link to post
Share on other sites
Любой импорт - зло.

+1

Нужно только для оперативных действий.

Я бы сказал чтобы только посмотреть, и стянуть чего нибудь полезного.

Для работы, тем более билиотеки, необходимо сделать с нуля в родной системе.

ой, наверное в среднем раз 3-5 лет с нуля

Даже тут иногда что-то.

вот последнее это пот требования Vault

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this