Jump to content

    
Sign in to follow this  
3.14

MG Expedition ликбез ...

Recommended Posts

5 minutes ago, NewYear85 said:

Т.к. не получается назначить диффпары.

Посмотрите, у вас случайно галочки на общих компонентах не стоят?

1519741108_2.png.d4cd5b909eb1f55c85c5c5fabcc55427.png

Share this post


Link to post
Share on other sites

Да, она стоит на всех элементах. Что она означает? Снял на двух конденсаторах, где проходила диффпара, получилось назначить

Share this post


Link to post
Share on other sites
27 minutes ago, NewYear85 said:

Да, она стоит на всех элементах. Что она означает? Снял на двух конденсаторах, где проходила диффпара, получилось назначить

если галка стоит, то через резистор, конденсатор, индуктивность, мелкосхему происходит объединение двух физ.цепей в одну логическую

Share this post


Link to post
Share on other sites

Хоспади, мне прям подфартило с проектом, в котором столько всего =) Суть проблемы

Есть BMC микросхема с пинами 60 и 65. На схеме, имена цепей соответствуют тому, что на рисунке.

Но, по факту, эти цепи в CES и XPEDITION видятся как одна, но с префиксом. Сам не схемотехник, спросил у разработчиков. Ребята пожали плечами, сказали "в схеме все нормально".

Как решить данный вопрос?

1.thumb.jpg.a728cdd4860a1663798a094d6116559d.jpg

2.thumb.jpg.692ae7f4cc407df13b93796e1d40b4bb.jpg

3.jpg.7161f777e0d4d57579e40549f4f8b296.jpg

 

Share this post


Link to post
Share on other sites

Похоже закоротили через шину на схеме. Скорее всего подвели к шине сигнал в ней не прописанный и закоротили с прописанным.

Share this post


Link to post
Share on other sites
5 minutes ago, fill said:

Похоже закоротили через шину на схеме. Скорее всего подвели к шине сигнал в ней не прописанный и закоротили с прописанным.

Вы не подскажете, как это можно проверить? Вот что отображается в схематехническом редакторе, когда раскрываю шину

4.jpg.5dfb93df04830f2766ae2d91e1447b2e.jpg

Share this post


Link to post
Share on other sites
1 hour ago, NewYear85 said:

Вы не подскажете, как это можно проверить? Вот что отображается в схематехническом редакторе, когда раскрываю шину

 

Оторвите от шины цепь EN_VDD1V5 и посмотрите что получится. Проверьте Bus Contents - там должны быть перечислены все цепи, входящие в члены шины.

Share this post


Link to post
Share on other sites
25 minutes ago, fill said:

Оторвите от шины цепь EN_VDD1V5 и посмотрите что получится. Проверьте Bus Contents - там должны быть перечислены все цепи, входящие в члены шины.

После отцепления, цепи стали самостоятельными в плане имен, другими словами, сработало.

Вот что было в Bus Contents, и окно, которое открылось, после подключения ресета. Вторая цепь подцепилась правильно

Вроде ресет внесет в BUS, но как то странно. Для меня это ново, пытаюсь понять, чтобы передать разработчикам на исправление

6.jpg.e5dc2ff214efdb92c612dc0edc7520c8.jpg5.jpg.6ff8a15f50dec3977c440823baac1ae0.jpg

 

Edited by NewYear85

Share this post


Link to post
Share on other sites
40 minutes ago, NewYear85 said:

После отцепления, цепи стали самостоятельными в плане имен, другими словами, сработало.

Вот что было в Bus Contents, и окно, которое открылось, после подключения ресета. Вторая цепь подцепилась правильно

Вроде ресет внесет в BUS, но как то странно. Для меня это ново, пытаюсь понять, чтобы передать разработчикам на исправление

 

 

 

~RESET~_SPSTx8 и ~RESET_SPSTx8 это не одно и тоже. В описании шины включена цепь ~RESET~_SPSTx8. А на схеме нарисован сегмент с именем ~RESET_SPSTx8.

Share this post


Link to post
Share on other sites

Добрый вечер, коллеги. В Xpedition столкнулся с необычной функией. Когда ставлю отверстия через ADD VIA, он ставит так, как будто снята галка в common setting - interactive place/route drc. Хотя она там стоит. Более того, если ставить переходное отверстие, то трассы, находящиеся на пути установки раздвинуться.

Где снять галочку, чтобы отверстия через addvia ставились с учетом constrain ?

Share this post


Link to post
Share on other sites
17 minutes ago, NewYear85 said:

Добрый вечер, коллеги. В Xpedition столкнулся с необычной функией. Когда ставлю отверстия через ADD VIA, он ставит так, как будто снята галка в common setting - interactive place/route drc. Хотя она там стоит. Более того, если ставить переходное отверстие, то трассы, находящиеся на пути установки раздвинуться.

Где снять галочку, чтобы отверстия через addvia ставились с учетом constrain ?

странно, ни когда такого не было

и "Более того, если ставить переходное отверстие, то трассы, находящиеся на пути установки раздвинуться." - как это понимать ?

Share this post


Link to post
Share on other sites
1 minute ago, Frederic said:

странно, ни когда такого не было

и "Более того, если ставить переходное отверстие, то трассы, находящиеся на пути установки раздвинуться." - как это понимать ?

Галочка Trace shove. Если она стоит, то, например, если на соседнем слое находится трасса, где вы хотите переходное поставить, то трасса "подвинется" автоматом. 

Share this post


Link to post
Share on other sites

Добрый день.

Не подскажите в схемотехническом редакторе можно вводить многострочный текст?

Share this post


Link to post
Share on other sites
1 hour ago, cniism said:

Добрый день.

Не подскажите в схемотехническом редакторе можно вводить многострочный текст?

Напрямую нет. Но можно вставить отображение текста из файла Add>Insert_Object.

Share this post


Link to post
Share on other sites
1 hour ago, fill said:

Напрямую нет. Но можно вставить отображение текста из файла Add>Insert_Object.

а у меня получается вводит через А (Text)
через Shift+Enter создается новая строка
Enter заканчивает ввод текста

text.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this