Jump to content

    
Sign in to follow this  
inter_pro

Ошибки работы Altium Designer 15

Recommended Posts

AD v17.1.6

Выделим в PCB какую-либо КП или часть цепи и перейдем в Design/Classes. Выберем или создадим (если нет) класс цепи с произвольным именем. Как я понимаю, кнопка Add Selected in Workspace по которой можно было бы добавить выделенную на плате цепь в NetClass должна быть доступна. А у меня нет и недоступна при любых условиях.

А вот добавить компонент в Component Class по этой кнопке можно. Для цепей не работает. У всех так?

Share this post


Link to post
Share on other sites
28-слойной? оО А что вы создаете такое, на 28-ми слоях? Оо

Тихо курю в сторонке.....

Вопрос конечно не в тему ветки- но в основном я занимаюсь дизайном мазерборд под промышленные применения(от SoM до "полноценных" плат), всевозможных FPGA карточек, скоростными камерами под техническое зрение и т.д.: это там где много слоев. Сказано к тому что есть на чем проверить производительность и возможности AD, особенно в той части которая касается полигональной разводки и выравнивания проводников в ограниченном пространстве.

 

Курить вредно для здоровья и по правде говоря завидовать тут нечему :laughing:

Share this post


Link to post
Share on other sites
Вопрос конечно не в тему ветки- но в основном я занимаюсь дизайном мазерборд под промышленные применения(от SoM до "полноценных" плат), всевозможных FPGA карточек, скоростными камерами под техническое зрение и т.д.: это там где много слоев. Сказано к тому что есть на чем проверить производительность и возможности AD, особенно в той части которая касается полигональной разводки и выравнивания проводников в ограниченном пространстве.

 

Курить вредно для здоровья и по правде говоря завидовать тут нечему :laughing:

 

 

Зачитал в слух тем, кто 10 слоями заниматеся.

Спросили, а AD может считать задержку распространения сигнала, если трасса ныряет с одного слоя на другой?

Пардон за оофтоп, но покоя теперь нету)

 

Про ошибки(?).

Версия 17.1.6 (Build 538)

Переходим из 2D в 3D, кнопочкой 3, затем возвращаемся обратно? кнопочкой 2.

При возвращении включаются отключенные мною слои, и сбрасывается галка "Convert Special Strings".

 

А еще, в 3D режиме у меня маска белая во всех вариантах, хоть зеленый, хоть коричневый.

Мне кажется я и раньше такое замечал.

Edited by Sanchosd

Share this post


Link to post
Share on other sites
Спросили, а AD может считать задержку распространения сигнала, если трасса ныряет с одного слоя на другой?

Может, но не задержку, а длину

Переходим из 2D в 3D, кнопочкой 3, затем возвращаемся обратно? кнопочкой 2.

При возвращении включаются отключенные мною слои, и сбрасывается галка "Convert Special Strings".

 

А еще, в 3D режиме у меня маска белая во всех вариантах, хоть зеленый, хоть коричневый.

Мне кажется я и раньше такое замечал.

Это не ошибка. Оно загружает сохраненные настройки. Когда вы переходите в 3D настройи не сохраняются.

Сохраните настройки 2D ( в прочем и 3D) такими, как вам надо-- и нет проблем

Share this post


Link to post
Share on other sites
Спросили, а AD может считать задержку распространения сигнала, если трасса ныряет с одного слоя на другой?

Пардон за оофтоп, но покоя теперь нету)

В тайминги конечно не может - и я думаю не сможет еще очень долго, да и когда это произойдет другие пакеты убегут далеко вперед. Именно поэтому я пишу:

по правде говоря завидовать тут нечему

Решение таких задач в альтуиме сопряженно с невероятным гимором- мне решать их удается потому что владею "магией" и использую свои и чужие утилиты для оценки/контроля того, что в альтиуме не сделать. Расчет задержки распространения- как раз хороший пример :laughing:

 

Просто платят хорошо за гимор в альтиуме :biggrin: - особенно кастомеры из РФ, которые не захотели/не смогли купить что-нибудь помощнее.

Share this post


Link to post
Share on other sites
Может, но не задержку, а длину

 

Это не ошибка. Оно загружает сохраненные настройки. Когда вы переходите в 3D настройи не сохраняются.

Сохраните настройки 2D ( в прочем и 3D) такими, как вам надо-- и нет проблем

 

Это тыцнуть L а затем Save as View Configuration, и в файлик сохранить?

 

 

Share this post


Link to post
Share on other sites
да

 

В прочем скоро это не будет актуальным.

Будут отдельно хранится и текущие настройки для 2D и 3D режимов

 

Что-то все равно не так....

Захожу в L, выбираю в левой части окна Altium 3D Dk Green,

смотрю, цвета масок зеленые, Непрозрачность почти 100%.

Закрываю, опять все белое...

Присмотрелся... а он мне верхний слой показывает, как буд-то маски нет...

ЧЯДНТ? )))

 

ЗЫ: это портабельная версия AD, может здесь порылась собака?

Share this post


Link to post
Share on other sites

Скорее всего он выделен или замаскирован одной из предыдущих операций.

Снимите. В левом нижнем углу кнопка Clear или Ctrl+C

Share this post


Link to post
Share on other sites
Скорее всего он выделен или замаскирован одной из предыдущих операций.

Снимите. В левом нижнем углу кнопка Clear или Ctrl+C

 

Вы обо мне слишком низкого мнения)))

Пробовал конечо)))

 

Еще заметил.

17.1 AD

 

Каким-то непонятным образом сами сбрасываются настройки. Вчера были, весь день, сегодня сбросились. Ставишь заново, например размер Via, преезагружаешь AD, и снова все по дефолту.

Может конечо это особенность портабельной версии, ща полезу ставить стационарную....

Edited by Sanchosd

Share this post


Link to post
Share on other sites

В последней версии опять всплыла ошибка формирования GERBER.

Изготовители жалуются, что файл ПУСТОЙ.

При анализе оказалось, что Альтиум не корректно формирует файлы ( иногда! и почему - не понятно!).

Проверка файлов - открытие их в БЛОКНОТЕ.

Если видна корректная структура - все хорошо.

В противном случае виден мусор!

Примеры. Первый хороший, второй мусор.

Метод "лечения" - перевыпуск GERBER, но не пакетом, а отдельного файла.

post-51805-1508562587_thumb.png

post-51805-1508562596_thumb.png

Edited by v-vovchek

Share this post


Link to post
Share on other sites

Забыл указать, что Альтиум своими средствами просмотра Gerber открывает оба файла, как нормальный , так и покалеченный.

Так что перепроверяйтесь!

Для любопытных - в архиве пример.

Если запустить из Альтийм - файлы не отличаются.

Но файл с припиской ПЛОХОЙ производители открыть не могут ( что наши, что китайцы).

______.zip

Share this post


Link to post
Share on other sites

Друзья, запускаю Draftsman, пытаюсь вставить Board Assembly View, а получаю такое окошко:

 

 

IMG_20171025_140822.jpg

 

Фотка потому, что при снятии скриншота, содржимое окошка магическим образом испаряется. Пришлось охотится за ним с фотоаппаратом.

 

PS: если открыть дургой проект, сделанный совершенно левым человеком, в левом альтии, то вставляется.

Мож кто сталкивался.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this