Jump to content

    
Sign in to follow this  
xtkjdtr

CC1101 уход частоты

Recommended Posts

Доброго времени!

 

Делаю передатчик на CC1101. Схему и топологию "слизал" с отладочной платы.

Настраиваю через SmartRF Studio на 868 МГц, 1.2 кбод (самая первая настройка из предопределенных).

 

Сходу связь с отладкой установить не удалось из-за смещения частоты моего передатчика (на выходе я вижу на 70 кГц меньше).

 

В чем может быть причина этого ухода частоты?

 

Результат тот же даже если комплектацию перепаиваю с отладочной платы. Предполагаю, что кварц в этом не виноват.

 

Может быть, у него есть какая-нибудь процедура калибровки?

Share this post


Link to post
Share on other sites
Доброго времени!

 

Делаю передатчик на CC1101. Схему и топологию "слизал" с отладочной платы.

Настраиваю через SmartRF Studio на 868 МГц, 1.2 кбод (самая первая настройка из предопределенных).

 

Сходу связь с отладкой установить не удалось из-за смещения частоты моего передатчика (на выходе я вижу на 70 кГц меньше).

 

В чем может быть причина этого ухода частоты?

 

Результат тот же даже если комплектацию перепаиваю с отладочной платы. Предполагаю, что кварц в этом не виноват.

 

Может быть, у него есть какая-нибудь процедура калибровки?

 

А конденсаторы на кварце одинаковые?

Мы то же с платой не могли связаться, чтобы заработало надо:

1. Кварцы должны быть одинаковы по частоте

2. Расстояние между приемником и передатчиком не менее 1-2м- рядом не работали)

Впоследствии использовали генераторы с точностью 5ррм

 

Процедура калибровки есть и описана в документации.

Share this post


Link to post
Share on other sites

Когда мне потребовалось работать на относительно низкой скорости (32 кбита на 433 MHz), влияние неправильно выбранных конденсаторов (было поставлено 22 pF вместо оптимальных 18 pF) оказалось фатальным. Самый простой способ проверки - на GDOx выдать поделенный опорник и измерить результат частотомером.

Share this post


Link to post
Share on other sites
Когда мне потребовалось работать на относительно низкой скорости (32 кбита на 433 MHz), влияние неправильно выбранных конденсаторов (было поставлено 22 pF вместо оптимальных 18 pF) оказалось фатальным. Самый простой способ проверки - на GDOx выдать поделенный опорник и измерить результат частотомером.

Вот, а я работал на 9600, поэтому и генератор, чтобы не зависить от всяких там конденсаторов.

Share this post


Link to post
Share on other sites

а я взял anaren модули, но оказалось что всё равно га..о - сейчас использую semtech sx1276 в lora режиме - сильно лучше и по дальности и по стабильности.

Share this post


Link to post
Share on other sites

Пользовался китайскими модулями с СС1101 типа такого то же попадался со смещением на 40 кГц менял обвязку и кварц не помогало только замена чипа помогла.

post-70445-1402896350.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this