Jump to content

    

Правка файла борды

Однажды у меня выла такая проблема при монтировании файловой системы с СДкарты.

Монтировалась как RW, а на СДкарте стояла защита от записи.

 

 

1. Подключите терминал к сериальному выходу (полагаю уже подключен раз вы видите сообщения)

2. Включите питание и в момент счета счетчика u-boot нажмите пробел (иногда enter).

3. если все остановилось наберите printenv

4. Все что напечаталось скопируйте и покажите нам.

 

На каком диске ваша рут файловая система?

 

 

Спасибо, познавательно. Честно говоря я так и знал что нигде кроме как в mach-type.h и при вызове MACHINE_START этот id не упоминается.

У меня ситуация такая: u-boot собран для одной машины (с конкретным id), а ядро новое не содержало такого machine id. Я просто взял и поменял руками номер для борды в файле mach-types.h

не помогло.

 

1 )Вопрос:

 

имеем MACHINE_START(MX53_LOCO, "Freescale MX53 LOCO Board"). Проверяется ли где то второй аргумент? или это только для вывода на экран?

 

2) в новых версиях ядер файл борды разделён на две части (board_xxx.c и board_xxx.dts). Вижу что не для всех aайлов board_xxx.c, которые в ядре по умолчанию, есть соответствующий board_xxx.dts что странно...

 

Я хорошо знаком с LOCO бордом. И этот файл хорошо перелопатил. MACHINE_START(MX53_LOCO, "Freescale MX53 LOCO Board") берет из сгенерированного файла хедера константу .....MX53_LOCO. вместо точек у них у всех одно и то же. сами найдете в хедере. Я не понмю. Вот эта константа и должна соответствовать бут лоадеру.

Я поменял текст "Freescale MX53 LOCO Board", но начались проблемы. Пока я разбирался, то обнаручил, что если оставить "Freescale MX53" в начале и дописать далее свой текст, то все работает безупречно.

 

В ядре 2.6 каждому устройству создавалась структура. В функции

static void __init mx53_loco_board_init(void)

 

часть из них регистрируется. Как сделано для остальных устройств я не помню. Был еще один файл в котором все устройства оформлены в виде структур, но давно с этим не возился.

 

В более поздних версиях кернела вместо разрозненных структур используется единое дерево устройств, где все собрано вместе и легко конфигурировать параметры.

Edited by Tarbal

Share this post


Link to post
Share on other sites

Полный лог загрузки ядра

NAND read: device 0 offset 0x80000, size 0x280000
2621440 bytes read: OK
## Booting kernel from Legacy Image at c0700000 ...
  Image Name:   Linux-3.3.0
  Image Type:   ARM Linux Kernel Image (uncompressed)
  Data Size:    2235936 Bytes =  2.1 MB
  Load Address: c0008000
  Entry Point:  c0008000
  Verifying Checksum ... OK
  Loading Kernel Image ... OK
OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
':dt-0004096' (c7002b4c): fill_kobj_path: path = '/kernel/slab/:dt-0004096'
JFFS2 version 2.2. (NAND) © 2001-2006 Red Hat, Inc.
msgmni has been set to 228
io scheduler noop registered (default)
da8xx_lcdc da8xx_lcdc.0: GLCD: No valid panel found
Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x1c42000 (irq = 25) is a AR7
serial8250.0: ttyS1 at MMIO 0x1d0c000 (irq = 53) is a AR7
serial8250.0: ttyS2 at MMIO 0x1d0d000 (irq = 61) is a AR7
console [ttyS2] enabled
ahci ahci: forcing PORTS_IMPL to 0x1
ahci ahci: AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl platform mode
ahci ahci: flags: ncq sntf pm led clo only pmp pio slum part ccc
scsi0 : ahci_platform
ata1: SATA max UDMA/133 mmio [mem 0x01e18000-0x01e19fff] port 0x100 irq 67
UBI error: ubi_init: UBI error: cannot initialize UBI, error -2
davinci_mdio davinci_mdio.0: davinci mdio revision 1.5
davinci_mdio davinci_mdio.0: detected phy mask fffffffd
davinci_mdio.0: probed
davinci_mdio davinci_mdio.0: phy[1]: device davinci_mdio-0:01, driver SMSC LAN8710/LAN8720
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ohci ohci.0: DA8xx OHCI
ohci ohci.0: new USB bus registered, assigned bus number 1
Waiting for USB PHY clock good...
ohci ohci.0: irq 59, io mem 0x01e25000
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
input: TPS6507x Touchscreen as /devices/platform/i2c-gpio.1/i2c-1/1-0048/input/input0
omap_rtc omap_rtc: rtc core: registered omap_rtc as rtc0
omap_rtc: RTC power up reset detected
i2c /dev entries driver
watchdog watchdog: heartbeat 60 sec
cpuidle: using governor ladder
cpuidle: using governor menu
davinci_mmc davinci_mmc.1: Using DMA, 4-bit mode
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
TCP cubic registered
NET: Registered protocol family 17
regulator_init_complete: LDO2: incomplete constraints, leaving on
regulator_init_complete: LDO1: incomplete constraints, leaving on
regulator_init_complete: VDCDC3: incomplete constraints, leaving on
regulator_init_complete: VDCDC2: incomplete constraints, leaving on
regulator_init_complete: VDCDC1: incomplete constraints, leaving on
davinci_emac davinci_emac.1: using random MAC addr: ce:65:6a:e9:01:62
omap_rtc omap_rtc: setting system clock to 2000-01-01 00:00:00 UTC (946684800)
ata1: SATA link down (SStatus 0 SControl 300)
VFS: Cannot open root device "ubi0:rootfs" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

 

 

вывод printenv в U-boot:

 

baudrate=115200
ethaddr=00:11:22:33:44:55
bootdelay=2
ipaddr=192.168.0.107
serverip=192.168.0.103
mtdids=nand0=davinci_nand.0
mtdparts=mtdparts=davinci_nand.0:128k(uboot_env),384k(uboot),2560k(kernel),-(ubi)
partition=nand0,0
mtddevnum=0
mtddevname=uboot_env
bootargs=ip=192.168.0.107:192.168.0.103:192.168.0.1:255.255.255.0:Owlboard:eth0 rootfstype=ubifs root=ubi0:rootfs ubi.mtd=ubi rw mem=128M
autoboot=nand read.e 0xc0700000 kernel; bootm 0xc0700000
bootcmd=run autoboot
stdin=serial
stdout=serial
stderr=serial
ver=U-Boot 2009.11 (Nov 24 2012 - 16:05:51)

 

Самое странное, у меня полность совпадают переменные окружения u-boot и строки bootargs в ядре у старого и нового ядра.

Старое грузится нормально, новое нет((

Share this post


Link to post
Share on other sites

Если работает сеть, загрузитесь с nfs. Потом можно будет спокойно разобраться с NAND и ubi.

Share this post


Link to post
Share on other sites
Если работает сеть, загрузитесь с nfs. Потом можно будет спокойно разобраться с NAND и ubi.

если загружусь с nfs, как мне понять, что нужно делать чтобы разобраться с NAND?

Share this post


Link to post
Share on other sites
рутовая на NAND, поддержка ubifs включена в ядре

 

а вас вот тут ошибка:

UBI error: ubi_init: UBI error: cannot initialize UBI, error -2

 

ubifs включается в двух местах - сделано?

полный лог можно копипастить на pastebin.com и линк сюда..

 

в логе должно быть примерно такое (с вашими реалиями):

 

[    0.968719] NAND device: Manufacturer ID: 0x2c, Chip ID: 0xda (Micron MT29F2G08ABAEAWP)
[    0.977294] Creating 8 MTD partitions on "omap2-nand.0":
[    0.982879] 0x000000000000-0x000000020000 : "SPL"
[    0.989166] 0x000000020000-0x000000040000 : "SPL.backup1"
[    0.996124] 0x000000040000-0x000000060000 : "SPL.backup2"
[    1.003051] 0x000000060000-0x000000080000 : "SPL.backup3"
[    1.009948] 0x000000080000-0x000000260000 : "U-Boot"
[    1.017211] 0x000000260000-0x000000280000 : "U-Boot Env"
[    1.024108] 0x000000280000-0x000000780000 : "Kernel"
[    1.032653] 0x000000780000-0x000010000000 : "File System"

 

и при монтирование размеченного раздела:

 

[  133.922149] UBI: attaching mtd7 to ubi0
[  133.926269] UBI: physical eraseblock size:   131072 bytes (128 KiB)
[  133.932800] UBI: logical eraseblock size:    126976 bytes
[  133.938446] UBI: smallest flash I/O unit:    2048
[  133.943359] UBI: VID header offset:          2048 (aligned 2048)
[  133.949615] UBI: data offset:                4096
[  136.081298] UBI: max. sequence number:       10
[  136.105377] UBI: attached mtd7 to ubi0
[  136.109313] UBI: MTD device name:            "File System"
[  136.115081] UBI: MTD device size:            248 MiB
[  136.120269] UBI: number of good PEBs:        1988
[  136.125183] UBI: number of bad PEBs:         0
[  136.129821] UBI: number of corrupted PEBs:   0
[  136.134460] UBI: max. allowed volumes:       128
[  136.139282] UBI: wear-leveling threshold:    4096
[  136.144195] UBI: number of internal volumes: 1
[  136.148834] UBI: number of user volumes:     1
[  136.153472] UBI: available PEBs:             0
[  136.158111] UBI: total number of reserved PEBs: 1988
[  136.163299] UBI: number of PEBs reserved for bad PEB handling: 19
[  136.169647] UBI: max/mean erase counter: 5/2
[  136.174102] UBI: image sequence number:  0
[  136.178405] UBI: background thread "ubi_bgt0d" started, PID 1166
[  139.822357] UBIFS: mounted UBI device 0, volume 0, name "rootfs"
[  139.828704] UBIFS: file system size:   247984128 bytes (242172 KiB, 236 MiB, 1953 LEBs)
[  139.837066] UBIFS: journal size:       12443648 bytes (12152 KiB, 11 MiB, 98 LEBs)
[  139.844970] UBIFS: media format:       w4/r0 (latest is w4/r0)
[  139.851257] UBIFS: default compressor: lzo
[  139.855560] UBIFS: reserved for root:  4952683 bytes (4836 KiB)

 

успешное наличие из первой части лога можно посмотреть:

root@неважно:~# ls /dev/mtd*
/dev/mtd0    /dev/mtd1ro  /dev/mtd3    /dev/mtd4ro  /dev/mtd6    /dev/mtd7ro     /dev/mtdblock2  /dev/mtdblock5
/dev/mtd0ro  /dev/mtd2    /dev/mtd3ro  /dev/mtd5    /dev/mtd6ro  /dev/mtdblock0  /dev/mtdblock3  /dev/mtdblock6
/dev/mtd1    /dev/mtd2ro  /dev/mtd4    /dev/mtd5ro  /dev/mtd7    /dev/mtdblock1  /dev/mtdblock4  /dev/mtdblock7

 

второй:

root@неважно:~# ls /dev/ubi*
/dev/ubi0  /dev/ubi0_0  /dev/ubi_ctrl

Edited by Jury093

Share this post


Link to post
Share on other sites

А в случае когда грузится, что пишет про монтирование файловой системы? Можете скопировать?

 

Сравните в конфигурации ядер есть ли разница в определении всего имеющего отношение к драйверам флэш памяти.

 

Share this post


Link to post
Share on other sites

прошу прощения, проблема по прежнему не решена.

Вот полный лог загрузки, рабочей системы:

 

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
[    0.000000] Linux version 2.6.37 (rusar@v1310) (gcc version 4.4.1 (Sourcery G++ Lite 2009q3-67) ) #116 PREEMPT Wed Nov 28 18:20:03 EET 2012
[    0.000000] CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ), cr=00053177
[    0.000000] CPU: VIVT data cache, VIVT instruction cache
[    0.000000] Machine: Owlboard Plus OMAP-L138/AM1808
[    0.000000] Memory policy: ECC disabled, Data cache writeback
[    0.000000] DaVinci da850/omap-l138/am18x variant 0x1
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line: ip=192.168.0.107:192.168.0.103:192.168.0.1:255.255.255.0:Owlboard:eth0 rootfstype=ubifs root=ubi0:rootfs ubi.mtd=ubi rw mem=128M
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Memory: 128MB = 128MB total
[    0.000000] Memory: 124988k/124988k available, 6084k reserved, 0K highmem
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
[    0.000000]     DMA     : 0xff000000 - 0xffe00000   (  14 MB)
[    0.000000]     vmalloc : 0xc8800000 - 0xfea00000   ( 866 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xc8000000   ( 128 MB)
[    0.000000]     modules : 0xbf000000 - 0xc0000000   (  16 MB)
[    0.000000]       .init : 0xc0008000 - 0xc0031000   ( 164 kB)
[    0.000000]       .text : 0xc0031000 - 0xc0486000   (4436 kB)
[    0.000000]       .data : 0xc0486000 - 0xc04b4820   ( 187 kB)
[    0.000000] SLUB: Genslabs=13, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] Preemptable hierarchical RCU implementation.
[    0.000000] 	RCU-based detection of stalled CPUs is disabled.
[    0.000000] 	Verbose stalled-CPUs detection is disabled.
[    0.000000] NR_IRQS:245
[    0.000000] Console: colour dummy device 80x30
[    0.000372] Calibrating delay loop... 185.54 BogoMIPS (lpj=927744)
[    0.220077] pid_max: default: 32768 minimum: 301
[    0.220492] Mount-cache hash table entries: 512
[    0.221599] CPU: Testing write buffer coherency: ok
[    0.223995] devtmpfs: initialized
[    0.232429] DaVinci: 144 gpio irqs
[    0.232972] regulator: core version 0.5
[    0.235499] regulator: dummy: 
[    0.236154] NET: Registered protocol family 16
[    0.287562] mcbsp1  0
[    0.452957] bio: create slab <bio-0> at 0
[    0.461922] SCSI subsystem initialized
[    0.469973] usbcore: registered new interface driver usbfs
[    0.471353] usbcore: registered new interface driver hub
[    0.472644] usbcore: registered new device driver usb
[    0.485166] regulator: VDCDC1: 3200 <--> 3300 mV at 3300 mV 
[    0.488221] regulator: VDCDC2: 1750 <--> 3300 mV at 3300 mV 
[    0.491612] regulator: VDCDC3: 950 <--> 1350 mV at 1200 mV 
[    0.493968] regulator: LDO1: 1800 mV 
[    0.497024] regulator: LDO2: 1150 <--> 1300 mV at 1200 mV 
[    0.498383] i2c i2c-1: Invalid 7-bit I2C address 0x00
[    0.498438] i2c i2c-1: Can't create device at 0x00
[    0.498485] i2c i2c-1: Invalid 7-bit I2C address 0xa2
[    0.498523] i2c i2c-1: Can't create device at 0xa2
[    0.498588] i2c-gpio i2c-gpio.1: using pins 20 (SDA) and 21 (SCL)
[    0.499674] vpif vpif: vpif probe success
[    0.506674] Advanced Linux Sound Architecture Driver Version 1.0.23.
[    0.509520] Switching to clocksource timer0_1
[    0.608398] musb-hdrc: version 6.0, host, debug=0
[    0.608721] musb-hdrc musb-hdrc: dma type: dma-cppi41
[    0.610259] Waiting for USB PHY clock good...
[    0.630576] musb-hdrc musb-hdrc: MUSB HDRC host driver
[    0.630713] musb-hdrc musb-hdrc: new USB bus registered, assigned bus number 1
[    0.634281] hub 1-0:1.0: USB hub found
[    0.634420] hub 1-0:1.0: 1 port detected
[    0.635354] musb-hdrc musb-hdrc: USB Host mode controller at fee00000 using DMA, IRQ 58
[    0.637114] NET: Registered protocol family 2
[    0.637539] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.638595] TCP established hash table entries: 4096 (order: 3, 32768 bytes)
[    0.638859] TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
[    0.639046] TCP: Hash tables configured (established 4096 bind 4096)
[    0.639084] TCP reno registered
[    0.639129] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.639199] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.640155] NET: Registered protocol family 1
[    0.641722] RPC: Registered udp transport module.
[    0.641779] RPC: Registered tcp transport module.
[    0.641815] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.644620] EMAC: RMII PHY configured, MII PHY will not be functional
[    0.759170] NTFS driver 2.1.29 [Flags: R/O].
[    0.763385] JFFS2 version 2.2. (NAND) © 2001-2006 Red Hat, Inc.
[    0.768516] msgmni has been set to 244
[    0.775492] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    0.775562] io scheduler noop registered
[    0.775600] io scheduler deadline registered
[    0.776190] io scheduler cfq registered (default)
[    0.778598] da8xx_lcdc da8xx_lcdc.0: GLCD: Found DT_atm0700d4 panel
[    0.806108] Console: switching to colour frame buffer device 100x30
[    0.848461] Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
[    0.856046] serial8250.0: ttyS0 at MMIO 0x1c42000 (irq = 25) is a AR7
[    0.859126] serial8250.0: ttyS1 at MMIO 0x1d0c000 (irq = 53) is a AR7
[    0.862662] serial8250.0: ttyS2 at MMIO 0x1d0d000 (irq = 61) is a AR7
[    1.362661] console [ttyS2] enabled
[    1.373204] ahci ahci: forcing PORTS_IMPL to 0x1
[    1.378106] ahci ahci: AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl platform mode
[    1.386385] ahci ahci: flags: ncq sntf pm led clo only pmp pio slum part ccc 
[    1.398567] scsi0 : ahci_platform
[    1.405152] ata1: SATA max UDMA/133 mmio [mem 0x01e18000-0x01e19fff] port 0x100 irq 67
[    1.421365] NAND device: Manufacturer ID: 0xec, Chip ID: 0xf1 (Samsung )
[    1.430507] Creating 4 MTD partitions on "davinci_nand.1":
[    1.436140] 0x000000000000-0x000000020000 : "uboot_env"
[    1.444660] 0x000000020000-0x000000080000 : "uboot"
[    1.452622] 0x000000080000-0x000000300000 : "kernel"
[    1.460803] 0x000000300000-0x000008000000 : "ubi"
[    1.468732] davinci_nand davinci_nand.1: controller rev. 2.5
[    1.478268] UBI: attaching mtd3 to ubi0
[    1.482600] UBI: physical eraseblock size:   131072 bytes (128 KiB)
[    1.488940] UBI: logical eraseblock size:    129024 bytes
[    1.494616] UBI: smallest flash I/O unit:    2048
[    1.499402] UBI: sub-page size:              512
[    1.504422] UBI: VID header offset:          512 (aligned 512)
[    1.510462] UBI: data offset:                2048
[    1.559998] usb 1-1: new high speed USB device using musb-hdrc and address 2
[    1.759966] ata1: SATA link down (SStatus 0 SControl 300)
[    1.868011] UBI: max. sequence number:       244
[    1.893233] UBI: attached mtd3 to ubi0
[    1.897074] UBI: MTD device name:            "ubi"
[    1.902117] UBI: MTD device size:            125 MiB
[    1.907144] UBI: number of good PEBs:        996
[    1.912013] UBI: number of bad PEBs:         4
[    1.916513] UBI: number of corrupted PEBs:   0
[    1.921117] UBI: max. allowed volumes:       128
[    1.925787] UBI: wear-leveling threshold:    4096
[    1.930662] UBI: number of internal volumes: 1
[    1.935155] UBI: number of user volumes:     2
[    1.939738] UBI: available PEBs:             0
[    1.944249] UBI: total number of reserved PEBs: 996
[    1.949169] UBI: number of PEBs reserved for bad PEB handling: 9
[    1.955317] UBI: max/mean erase counter: 3/1
[    1.959920] UBI: image sequence number:  -1958061123
[    1.964997] UBI: background thread "ubi_bgt0d" started, PID 513
[    1.971658] spi_davinci spi_davinci.1: DMA: supported
[    1.976830] spi_davinci spi_davinci.1: DMA: RX channel: 18, TX channel: 19, event queue: 0
[    1.988168] m25p80 spi1.0: mx25l6405d (8192 Kbytes)
[    1.993450] Creating 4 MTD partitions on "mx25l6405d":
[    1.998678] 0x000000000000-0x000000080000 : "U-Boot"
[    2.006545] 0x000000080000-0x0000000c0000 : "U-Boot-Env"
[    2.015022] 0x0000000c0000-0x000000340000 : "Kernel"
[    2.023146] 0x000000340000-0x000000800000 : "Filesystem"
[    2.031604] spi_davinci spi_davinci.1: Controller at 0xfef0e000
[    2.089754] davinci_mdio davinci_mdio.0: davinci mdio revision 1.5
[    2.096040] davinci_mdio davinci_mdio.0: detected phy mask fffffffd
[    2.104559] davinci_mdio.0: probed
[    2.108047] davinci_mdio davinci_mdio.0: phy[1]: device 0:01, driver SMSC LAN8710/LAN8720
[    2.117486] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    2.124448] ohci ohci.0: DA8xx OHCI
[    2.128118] ohci ohci.0: new USB bus registered, assigned bus number 2
[    2.134991] Waiting for USB PHY clock good...
[    2.139577] ohci ohci.0: irq 59, io mem 0x01e25000
[    2.207451] hub 2-0:1.0: USB hub found
[    2.211689] hub 2-0:1.0: 1 port detected
[    2.217287] Initializing USB Mass Storage driver...
[    2.223950] scsi1 : usb-storage 1-1:1.0
[    2.231800] usbcore: registered new interface driver usb-storage
[    2.237917] USB Mass Storage support registered.
[    2.245612] mice: PS/2 mouse device common for all mice
[    2.255203] input: TPS6507x Touchscreen as /devices/platform/i2c-gpio.1/i2c-1/1-0048/input/input0
[    2.271133] omap_rtc omap_rtc: rtc core: registered omap_rtc as rtc0
[    2.277574] omap_rtc: RTC power up reset detected
[    2.282863] omap_rtc: already running
[    2.288388] i2c /dev entries driver
[    2.300674] Linux video capture interface: v2.00
[    2.311650] cpia2: V4L-Driver for Vision CPiA2 based cameras v3.0.0
[    2.319195] usbcore: registered new interface driver cpia2
[    2.329877] gspca: v2.10.0 registered
[    2.346019] tvp514x: tvp514x decoder driver registered !!
[    2.356973] vpif_capture vpif_capture: registered sub device tvp514x-0
[    2.364031] vpif_capture vpif_capture: VPIF Capture driver initialized
[    2.378237] usbcore: registered new interface driver uvcvideo
[    2.389368] USB Video Class driver (v1.0.0)
[    2.394126] watchdog watchdog: heartbeat 60 sec
[    2.403677] cpuidle: using governor ladder
[    2.416549] cpuidle: using governor menu
[    2.422714] sdhci: Secure Digital Host Controller Interface driver
[    2.428974] sdhci: Copyright© Pierre Ossman
[    2.434046] davinci_mmc: probe of davinci_mmc.0 failed with error -16
[    2.447759] davinci_mmc davinci_mmc.1: Using DMA, 4-bit mode
[    2.463078] usbcore: registered new interface driver usbhid
[    2.468756] usbhid: USB HID core driver
[    2.506309] asoc: tlv320aic3x-hifi <-> davinci-mcbsp.1 mapping ok
[    2.521796] ALSA device list:
[    2.524833]   #0: DA850/OMAP-L138 EVM
[    2.536099] TCP cubic registered
[    2.539407] NET: Registered protocol family 17
[    2.555321] regulator_init_complete: incomplete constraints, leaving LDO2 on
[    2.572196] regulator_init_complete: incomplete constraints, leaving LDO1 on
[    2.580429] regulator_init_complete: incomplete constraints, leaving VDCDC3 on
[    2.588562] regulator_init_complete: incomplete constraints, leaving VDCDC2 on
[    2.601087] regulator_init_complete: incomplete constraints, leaving VDCDC1 on
[    2.609071] davinci_emac_probe: using random MAC addr: d6:c7:e1:28:81:76
[    2.636240] omap_rtc omap_rtc: setting system clock to 2000-01-01 00:00:00 UTC (946684800)
[    3.152426] davinci_mdio davinci_mdio.0: resetting idled controller
[    3.160549] net eth0: attached PHY driver [sMSC LAN8710/LAN8720] (mii_bus:phy_addr=0:01, id=7c0f1)
[    3.232071] scsi 1:0:0:0: Direct-Access     USB 2.0  USB Flash Drive  0.00 PQ: 0 ANSI: 2
[    3.253954] sd 1:0:0:0: [sda] 7897088 512-byte logical blocks: (4.04 GB/3.76 GiB)
[    3.262337] sd 1:0:0:0: Attached scsi generic sg0 type 0
[    3.276788] sd 1:0:0:0: [sda] Write Protect is off
[    3.287363] sd 1:0:0:0: [sda] Assuming drive cache: write through
[    3.307041] sd 1:0:0:0: [sda] Assuming drive cache: write through
[    3.377598]  sda: sda1
[    3.452103] sd 1:0:0:0: [sda] Assuming drive cache: write through
[    3.458295] sd 1:0:0:0: [sda] Attached SCSI removable disk
[    4.180514] IP-Config: Complete:
[    4.183657]      device=eth0, addr=192.168.0.107, mask=255.255.255.0, gw=192.168.0.1,
[    4.196653]      host=Owlboard, domain=, nis-domain=(none),
[    4.202439]      bootserver=192.168.0.103, rootserver=192.168.0.103, rootpath=
[    4.266018] UBIFS: recovery needed
[    4.328200] UBIFS: recovery completed
[    4.332103] UBIFS: mounted UBI device 0, volume 0, name "rootfs"
[    4.338211] UBIFS: file system size:   49287168 bytes (48132 KiB, 47 MiB, 382 LEBs)
[    4.349752] UBIFS: journal size:       2451456 bytes (2394 KiB, 2 MiB, 19 LEBs)
[    4.357166] UBIFS: media format:       w4/r0 (latest is w4/r0)
[    4.379738] UBIFS: default compressor: lzo
[    4.383926] UBIFS: reserved for root:  2327954 bytes (2273 KiB)
[    4.392289] VFS: Mounted root (ubifs filesystem) on device 0:14.
[    4.404871] devtmpfs: mounted
[    4.408093] Freeing init memory: 164K
[    4.930983] UBIFS: recovery needed
[    4.968886] UBIFS: recovery completed
[    4.977762] UBIFS: mounted UBI device 0, volume 1, name "storage"
[    4.984098] UBIFS: file system size:   75220992 bytes (73458 KiB, 71 MiB, 583 LEBs)
[    4.991951] UBIFS: journal size:       3741696 bytes (3654 KiB, 3 MiB, 29 LEBs)
[    4.999356] UBIFS: media format:       w4/r0 (latest is w4/r0)
[    5.009735] UBIFS: default compressor: lzo
[    5.013918] UBIFS: reserved for root:  3552872 bytes (3469 KiB)
Starting logging: OK
Initializing random number generator... done.
Starting network...
ip: RTNETLINK answers: File exists
Starting dropbear sshd: OK
Starting sshd: Could not load host key: /etc/ssh_host_dsa_key

Could not load host key: /etc/ssh_host_ecdsa_key

OK
Starting HPA's tftpd: /etc/init.d/S80tftpd-hpa: line 79: /usr/sbin/in.tftpd: not found
thttpd
[0;32mroot[m [1;34m/root[m [1;32m#[m [1;37m

 

сравнивал логи рабочей и не рабочей системы, зметил что в рабочей версии удивительным оразом всё последовательно настраивается, монтируются разделы UBI файловой системы. В нерабочем враинте всё совсем не так. Хотя конфиги практически идентичны и фалы борды одинаковые. Различаются версии ядер.

Share this post


Link to post
Share on other sites
прошу прощения, проблема по прежнему не решена.

Вот полный лог загрузки, рабочей системы:

более интересен лог нерабочей системы, фильтрация из .config (grep UBI, grep MTD, grep NAND) и куски файла борды, касающиеся нанда..

 

совсем не так. Хотя конфиги практически идентичны и фалы борды одинаковые. Различаются версии ядер.

пробейте по гуглю - может именно в этой версии ядра глючная подсистема (nand, ubifs)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this