Перейти к содержанию

    

не запускается Keil

Перестал работать Keil 4, для ARM, Win7 x64

после установки каких то драйверов точно не помню.

Переустановка программы не помогла. та же самая ошибка. Пробовал новую версию ставить Keil 5 всё равно не запускается. Вот что пишет

post-71010-1390764141_thumb.jpg

 

думаю поможет переустановка винды. может есть еще методы?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
... может есть еще методы?

 

из лога апгрэйда оси выписать названия патчей последних и откатить через установку-анинсталяцию софта.

100% нету, но возможно разродится. после этого при апгрэйдах анчекаут указанный патч. периодически можно пытаться и

его накатывать - возможен и положительный результат.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Win7x64, все последние апдейты от мелкомягких стоят. Что 4.72а, что 5 стартуют нормально. Как правильно сказал kolobok0, вспоминайте какие дрова ставили и откатывайте.

 

Все телепаты на майдане. :D

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

скорее всего это началось после установки тулчейна для АВР.

Сейчас поудалял все программы связанные с программированием. Регклинером почистел. но результата нет. Что еще нужно вычистить\удалить ???

 

из лога апгрэйда оси выписать названия патчей последних...

это где посмотреть можно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Попробуйте снести полностью кейл, пройтись по реестру и по новой поставить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

именно так и сделал, несколько раз. Не помогло.

Кеил был установлен в папку C:\keil

может он еще куда свои файлы кладет? поиск результатов не дал.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Поиском по реестру с keil?

Иначе или переустановка винды, или.. даже не знаю что. мб откатить винду до одной из установок?

Или пробуйте варианты, или переустанавливайте винду. Третьего не дано.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Контроль учетных записей попробуйте отключить и запустить от имени администратора и установку тоже.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

не помогает) уже без антивирусника устанавливал, чистил всё. Не помогает. я уже думаю, может фирма keil обиделась, что без лицензии работал, хотя проэкты не комерческие...

Могли же вирус мне запустить. Ведь все остальные программы норм работают! Даже жалко винду перебивать из-за этого.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
не помогает) уже без антивирусника устанавливал, чистил всё. Не помогает. я уже думаю, может фирма keil обиделась, что без лицензии работал, хотя проэкты не комерческие...

Могли же вирус мне запустить. Ведь все остальные программы норм работают! Даже жалко винду перебивать из-за этого.

Попробовать поставить "виртуальную машину" и установить там.

В случае чего "виртуалка" удаляется как любая другая программа.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

тоже не помогло!

Переустановил винду, поставил Keil 5, все драйвера, всё работает!!! Старые проэкты открывает, короче всё ОК!!!

Но, когда открыл пример, скачанный давно с сайта STM, опять повторилась ошибка!!! Ксати с этого примера всё и началось в прошлый раз.

 

короче это пример скачанный с офицального сайта, вот его имя в распакованном виде

..\stm32_f105-07_f2_f4_usb-host-device_lib\STM32_USB-Host-Device_Lib_V2.1.0\Project\USB_Device_Examples\VCP\MDK-ARM\usbd_vcp.uvproj

 

не знаю что и думать...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Попробуйте переименовать папку с проектом, который был открыт в Keil перед возникновением ошибки. После этого должен нормально запуститься - зависает в процессе открытия проекта.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

попробую... только для этого винду переустановить нужно. После этой ошибки Кеил напрочь отказывается запускатся.

Повторюсь, пробовал переустанавливать кеил разных версий, и 4й и 5й ((( чистил реестр Регклинером, ССклинером, удалял обновления винды, устанавливал обновления винды, чистил диск С всё со словами Keil MDK ARM STM...

короче помогает только переустановка винды

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

не!!! остановитесь!

 

у кейла запоминается последний открытый проект, если он не тогось, то все входит в ступор. Попробуйте в любой другой проект 2 раза мышой тыкнуть, чтобы это запустило кеил на открытие. А также попробуйте переименовать папку последнего открытого проекта, чтобы он при старте проект не нашел.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация