Jump to content

    

Recommended Posts

Проверяйте схему подключения конденсатора на VRTC и SIM карты, и номиналы в цепи симки.

Можете выложить кусок разодки платы - посмотрим на правильность.

 

Ну и как самый худший вариант - выводы на симку выбиты статикой. Нужно смотреть осциллографом по VSIM есть ли попытка запроса карты.

 

http://www.microchip.ua/simcom/SIM900x/App...znoe/SIMVDD.pdf

 

Три импульса запроса для 1.8 вольт карт и три импульса для 3.0 вольт карт.

 

 

Кстати - а как подключены к модулю? Контроллером или через согласователь UART? Какие уровни сигналов?

Я не вижу чтобы отслеживали вывод STATUS, там фантомная запитка случайно не загуляла?

Share this post


Link to post
Share on other sites

Подключил я на VRTC - 4.7 мкф. Полярность на схеме не правильная так как когда выбирал корпус там она была изменена на противоположную.

Вся проблема заключалась в том что вход VCC сим карты я по ошибке подключил к SIM_PRE sim908. Чем мне это могло обернуться? Сегодня всё переделал, подключил VCC на SIM_VDD. Теперь без вставленной сим карты всё работает нормально, на команды sim908 отвечает, но как только вставляю сим карту, включаю, он начинает мигать светодиодом (ищет сеть) и сразу выключается, как будто срабатывает какая то защита. Что это может быть?

 

"Ну и как самый худший вариант - выводы на симку выбиты статикой. Нужно смотреть осциллографом по VSIM есть ли попытка запроса карты." - Если карты не вставлена всё равно будет на SIM_VDD запрос проходить? P.S. статике сим908 не подвергался!

 

post-79077-1390924903_thumb.jpg

 

Вывод STATUS не к чему не подключал!

Edited by red-30

Share this post


Link to post
Share on other sites
Теперь без вставленной сим карты всё работает нормально, на команды sim908 отвечает, но как только вставляю сим карту, включаю, он начинает мигать светодиодом (ищет сеть) и сразу выключается, как будто срабатывает какая то защита. Что это может быть?

Сколько ж можно говорить. Не стоит гадать на кофейной гуще. Выставте на модуле фиксированую скорость. Тогда модуль больше логов скажет. И логи в студию. Это даст информацию для поиска причин.

 

Share this post


Link to post
Share on other sites
Сколько ж можно говорить. Не стоит гадать на кофейной гуще. Выставте на модуле фиксированую скорость. Тогда модуль больше логов скажет. И логи в студию. Это даст информацию для поиска причин.

То есть мне без сим карты выставить скорость и скинуть логи? Так как если с он будет с сим картой он через несколько секунд выключиться как я писал выше.

Share this post


Link to post
Share on other sites

>>>Так как если с он будет с сим картой он через несколько секунд выключиться как я писал выше.

 

:)

 

А питаете модуль от чего??? То что написано выше - признак хренового питания - модуль при регистрации потребляет почти 2 ампера и если БП не даст ток, то модуль отключится.

Или с антенной проблемы - перегруз RF тракта тоже может привести к отключению или сдыханию RFPA

 

Конденсаторы электролиты небось оксидные стоят? Ну-ну. Там вообще-то согласно документа должен тантал low ESR стоять.

 

>>>Вывод STATUS не к чему не подключал!

 

А почему? До появления и после пропадания STATUS на цифровых входах модуля не должно быть уровней. Иначе неадекватное поведение можно прогнозировать с вероятностью 98%

Share this post


Link to post
Share on other sites
То есть мне без сим карты выставить скорость и скинуть логи? Так как если с он будет с сим картой он через несколько секунд выключиться как я писал выше.

Выставьте скорость без карты, а потом лог включения без карты.. и с картой. Поймите простую истину, чем больше информации, тем проще. Ваши крики - "включаю , не регистрируется" сравними с криком - "сел в машину - не едет - в чем проблема?"

Share this post


Link to post
Share on other sites
Выставьте скорость без карты, а потом лог включения без карты.. и с картой. Поймите простую истину, чем больше информации, тем проще. Ваши крики - "включаю , не регистрируется" сравними с криком - "сел в машину - не едет - в чем проблема?"

post-79077-1390988654_thumb.jpg

Share this post


Link to post
Share on other sites

По логам видно, карта видится модулем. Так что из списка проблем , проблему с видимостью карты можно исключать. Так что смотрим уровень сети (антена, согласование антены), и напряжение питания, источник питания.

Share this post


Link to post
Share on other sites

Компоновка на плате достойна кисти Сальвадора Дали. Макетку надо разводить максимально приближенно к релизной. Кондер С2 не замыкает часом?

Моя макетка (маска может и лишнее). И проблем с железом не возникало. Все в полпинка.

post-65866-1391014723_thumb.jpg

post-65866-1391014731_thumb.jpg

post-65866-1391014865.jpg

Edited by V125

Share this post


Link to post
Share on other sites

Всем спасибо большое за помощь!!! Проблема заключалась в 2-х вещах: 1) Что вход VCC сим карты я по ошибке подключил к SIM_PRE sim908, 2) Диод который у меня стоял на входе не мог обеспечить ток = 2А при подключении сим.

 

А питаете модуль от чего??? То что написано выше - признак хренового питания - модуль при регистрации потребляет почти 2 ампера и если БП не даст ток, то модуль отключится.

Или с антенной проблемы - перегруз RF тракта тоже может привести к отключению или сдыханию RFPA

Спасибо больше за эту информацию, без неё бы не нашёл проблему!

 

Кондер С2 не замыкает часом?

Моя макетка (маска может и лишнее). И проблем с железом не возникало. Все в полпинка.

Нет это первоначальный вариант был, просто другого не было под рукой. С2 уже там не чего не замыкает)

Спасибо)

 

По логам видно, карта видится модулем. Так что из списка проблем , проблему с видимостью карты можно исключать. Так что смотрим уровень сети (антена, согласование антены), и напряжение питания, источник питания.

Спасибо большое за помощь!

Share this post


Link to post
Share on other sites

Как правильно работать с GPS? Отправляю AT+CGPSRST=0, но он после этого выставляет CGPSRST в единицу. При отправке AT+CGPSINF=0 приходят следующие данные

0,0.000000,0.000000,0.000000,20101010004441.003,0,0,0.000000,0.000000

0,0.000000,0.000000,0.000000,20101010004442.003,0,0,0.000000,0.000000

и так далее, то есть не находит спутники

Используется активная антенна, ножка GPS_VCC_RF и GPS_VANT замкнуты между собой и 2.8В имеется.

Share this post


Link to post
Share on other sites

Всем доброго времени суток! Скажите пожалуйста какие значения по умолчанию в командах AT+CSCS и AT+CSMP? И как можно узнать баланс через AT-команды на sim908?

Share this post


Link to post
Share on other sites

>>>какие значения по умолчанию в командах AT+CSCS и AT+CSMP?

 

А прочесть в даташите???

 

SIM908_AT Command Manual_V1.02.pdf

 

CSCS - "GSM" GSM 7 bit default alphabet (3GPP TS 23.038); - в описании команды

 

 

и в табличке дефаулт конфигурации - Parameter impacted by &F command:

AT+CSMP <fo> 0x11

AT+CSMP <vp> 0x00

AT+CSMP <vp> 0x18

AT+CSMP <vp> 0x00

AT+CSMP <vp> 0x00

AT+CSMP <fo> 0x11

AT+CSMP <vp> 0x00

AT+CSMP <vp>0x18

AT+CSMP <vp> 0x00

AT+CSMP <vp> 0x00

AT+CSMP <fo> 0x11

AT+CSMP <vp> 0x00

AT+CSMP <vp> 0x18

AT+CSMP <vp> 0x00

AT+CSMP <vp> 0x00

AT+CSMP <vp> 0x00..0x00

AT+CSMP <pid> 0x00

AT+CSMP <dcs> 0x00

 

 

 

Баланс через CUSD или ATD как на телефоне.

Формат смотрим у оператора, а как передавать на форуме было неоднократно

Share this post


Link to post
Share on other sites

Большое спасибо CADiLO за ответ!

Помогите ещё пожалуйста разобраться с балансом, вот такие проблемы: я пишуAT+CSCS="GSM" ответ OK, зачем AT+CUSD=1,"*100#" и когда отправляю он почему то отправляет post-79077-1398510900.jpg и пишет ERROR. Как будто он не воспринимает символ # вообще. Из за чего это может быть?

Через ATD*100# такая же фигня(

Edited by red-30

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this