Jump to content

    

Особенность работы AT89S8252 при подаче питания

Добрый день!

 

Недавно сделал одну схемку на базе AT89S8252 и при отладке столкнулся с такой штукой:

 

При подаче питания на всех выходах контроллера несколько мс висит лог.0, который мне совсем не кстати, а потом, как и должно быть, выходы инициализируются в лог.1.

Схема питается от импульсного источника (МДМ5-1В05) с временем установления выходного напряжения 0.1с.

Я так предполагаю, что этот лог.0 выскакивает пока напряжение контроллера нарастает до номинального значения.

Все бы ничего, но у меня к выходам контроллера подключены транзисторные (p-n-p) каскады, кот. от этого нуля при включении питания "клацают".

 

Кто-нибудь сталкивался с подобным?

Может кто-то знает оптимальное решение этой проблемы?

Заранее, спасибо!

Share this post


Link to post
Share on other sites

Может выличиться поставив монитор питания типо MB3771 !

 

 

 

 

 

Если надо то могу присалть схему включения!

Share this post


Link to post
Share on other sites
Может выличиться поставив монитор питания типо MB3771 !

Я так понимаю, монитор помогает корректно RESET контроллеру сделать, а в моем случае с этим все в порядке. Даже если RESET вручную, с помощью тумблера (!) снимать - эффект не исчезает :(

Edited by sergey-sv

Share this post


Link to post
Share on other sites
Добрый день!

 

Недавно сделал одну схемку на базе AT89S8252 и при отладке столкнулся с такой штукой:

 

При подаче питания на всех выходах контроллера несколько мс висит лог.0, который мне совсем не кстати, а потом, как и должно быть, выходы инициализируются в лог.1.

Схема питается от импульсного источника (МДМ5-1В05) с временем установления выходного напряжения 0.1с.

Я так предполагаю, что этот лог.0 выскакивает пока напряжение контроллера нарастает до номинального значения.

Все бы ничего, но у меня к выходам контроллера подключены транзисторные (p-n-p) каскады, кот. от этого нуля при включении питания "клацают".

 

Кто-нибудь сталкивался с подобным?

Может кто-то знает оптимальное решение этой проблемы?

Заранее, спасибо!

 

Имел такую же проблему с механическими счетчиками,

решилась после того как поставил второй транзистор после первого

(двойная инверсия).

 

Удачи!

Share this post


Link to post
Share on other sites
Имел такую же проблему с механическими счетчиками,

решилась после того как поставил второй транзистор после первого

(двойная инверсия).

Мне кажется, хоть 10 поставь, все равно будут щелкать.

Если с этого конца к решению подходить, то можно, конечно, внешней RC-цепочкой миллисекундные импульсы отфильтровать.

Share this post


Link to post
Share on other sites

Можно попробовать поставить тот же супервизор питания, только его управляющий выход подключить не к RESET-у контроллера, а к базе транзистора, который в свою очередь открывает полевик через который питается контроллер. Во загнул :) Короче, надо сделать задержку подачи питания на контроллер.

Share this post


Link to post
Share on other sites

На сколько я помню после включения питания у этого контроллера порты настроены на вход, т.е. их входное сопротивление велико. Так что ноль появится там может только если это задумано в исходнике. Может в нем покопаться.

Share this post


Link to post
Share on other sites
Можно попробовать поставить тот же супервизор питания, только его управляющий выход подключить не к RESET-у контроллера, а к базе транзистора, который в свою очередь открывает полевик через который питается контроллер. Во загнул :) Короче, надо сделать задержку подачи питания на контроллер.

Типа того, только задерживать питание надо не контроллера, а наоборот внешних цепей :)

Спасибо!

 

На сколько я помню после включения питания у этого контроллера порты настроены на вход, т.е. их входное сопротивление велико. Так что ноль появится там может только если это задумано в исходнике. Может в нем покопаться.

Совершенно верно - на вход, но после (!) включения питания.

А вот ты попробуй померить сопротивление ноги контроллера относительно минуса при снятом с микросхемы питании.

Share this post


Link to post
Share on other sites

Всем привет! Когда-то в какой-то умной книжке было написано, что пока не запустится и не стабилизируется генератор контроллера и не пройдет процедура сброса (корректно), состояние выводов портов будет неопределенным. А запуск генератора, особенно с низкой частотой, может занять десятки милисекунд. Может, проблема в этом? Удачи!

Share this post


Link to post
Share on other sites
Добрый день!

 

Недавно сделал одну схемку на базе AT89S8252 и при отладке столкнулся с такой штукой:

 

При подаче питания на всех выходах контроллера несколько мс висит лог.0, который мне совсем не кстати, а потом, как и должно быть, выходы инициализируются в лог.1.

Схема питается от импульсного источника (МДМ5-1В05) с временем установления выходного напряжения 0.1с.

Я так предполагаю, что этот лог.0 выскакивает пока напряжение контроллера нарастает до номинального значения.

Все бы ничего, но у меня к выходам контроллера подключены транзисторные (p-n-p) каскады, кот. от этого нуля при включении питания "клацают".

 

Кто-нибудь сталкивался с подобным?

Может кто-то знает оптимальное решение этой проблемы?

Заранее, спасибо!

 

 

У меня в схеме сделано так: на p-n-p каскады питание подаётся через ключ с задержкой.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this